.titleBar { margin-bottom: 5px!important; }

Problem beim Update auf Asterisk 1.6.0.0

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von jogyfl, 4 Okt. 2008.

  1. jogyfl

    jogyfl Neuer User

    Registriert seit:
    30 Aug. 2006
    Beiträge:
    49
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Zusammen,

    ich wollte von der Asterisk 1.4.22 auf die neue 1.6 umsteigen und habe erstmal auf einer VM Ubuntu, Asterisk 1.6.0 und Chan-sccp-b installiert.

    Das Cisco Telefon meldet sich normal an den Asterisk an, nur bei der extensions.conf scheint es noch einige Probleme zu geben.

    Einige Funktionen scheint es nicht mehr zu geben oder die Syntax wurde geändert, habe bereits im Forum gesucht aber nichts passendes gefunden:confused:...

    Meine Extensions.conf:
    Code:
    [general]
    static = yes
    writeprotect = no
    ; --------------------------------------------------------------------
    
    [echotest]
    exten => 81,1,answer
    exten => 81,2,wait,1
    exten => 81,3,playback,demo-echotest
    exten => 81,4,echo
    exten => 81,5,playback,demo-echodone
    exten => 81,6,hangup
    
    [mailbox]
    exten => 80,1,answer
    exten => 80,n,wait,1
    exten => 80,n,voicemailmain
    exten => 80,n,hangup
    
    [mailbox_own]
    exten => 88,1,answer
    exten => 88,n,wait,1
    exten => 88,n,voicemailmain,s${CALLERID(number)}
    exten => 88,n,hangup
    
    [lokal]
    ; Erreichbarkeit der Nebenstellen 2XX untereinander herstellen
    exten => _2XX,1,NoCDR()
    exten => _2XX,n,Dial,SCCP/${EXTEN}|15|Ttr
    exten => _2XX,n,VoiceMail(${EXTEN})
    
    [blocken]
    exten => _X.,1,Dial,SCCP/259|20|r
    exten => _X.,2,voicemail,b259
    exten => _X.,3,Hangup()
    
    [sipgate_out]
    exten => _0.,1,Dial,SIP/${EXTEN}@6312121e0|45|r
    
    [carpo-out]
    exten => _9.,n,Dial(SIP/0049${EXTEN:2}@carpo-out|30|T)
    
    
    [ankommend]
    exten => carpo,1,Dial,SCCP/260|20|r
    exten => carpo,n,voicemail,b260
    
    ;ankommende Anrufe über Sipgate
    ;---------------------------------
    exten => 6312121e0/04642366683,1,Goto(blocken,,1)
    exten => 6312121e0,1,noop()
    exten => 6312121e0,n,Dial,SCCP/256|20|r
    exten => 6312121e0,n,voicemail,b256
    
    
    ;Voicemailbox abfragen
    ;---------------------------------
    exten => 6312121e2,1,answer
    exten => 6312121e2,n,wait,1
    exten => 6312121e2,n,voicemailmain
    
    
    ; --------------------------------------------------------------------
    [default]
    include => lokal
    include => echotest
    include => mailbox
    include => mailbox_own
    include => sipgate_out
    include => carpo-out
    include => blocken
    
    Wenn ich eine Rufnummer wähle bekomme ich folgendes auf der CLI:
    Code:
    ubuntu*CLI>
        -- SEP0015C69E020B: New call on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000000 (0) on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000008 (8) on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000000 (0) on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000000 (0) on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000001 (1) on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000007 (7) on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000002 (2) on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000001 (1) on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000002 (2) on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000001 (1) on line 259
        -- SEP0015C69E020B: Cisco Digit: 00000002 (2) on line 259
        -- SEP0015C69E020B: Cisco Digit: 0000000f (15) on line 259
        -- SCCP: set variable SKINNY_PRIVATE to: 0
    [Oct  4 11:47:55] WARNING[25022]: pbx.c:3082 pbx_extension_helper: No application 'Dial,SIP/${EXTEN}@6312121e0|45|r' for extension (default, 08001721212, 1)
      == Spawn extension (default, 08001721212, 1) exited non-zero on 'SCCP/259-00000002'
        -- SCCP: Asterisk request to hangup channel SCCP/259-00000002
    ubuntu*CLI>
    
    Wenn ich die Meldung richtig verstehe, gibt es den Befehl "Dial" nicht mehr, aber wo finde ich jetzt die neuen Befehle:confused:

    Kann mir vielleicht jemand helfen und mir sagen was ich ändern muss?

    Vielen Dank schon mal;)

    Gruß
    JogyFL
     
  2. ilmtuelp0815

    ilmtuelp0815 Aktives Mitglied

    Registriert seit:
    4 Sep. 2005
    Beiträge:
    1,296
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Dipl.-Ing. für Gerätetechnik, Informatikspezialist
  3. jogyfl

    jogyfl Neuer User

    Registriert seit:
    30 Aug. 2006
    Beiträge:
    49
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #3 jogyfl, 4 Okt. 2008
    Zuletzt bearbeitet: 4 Okt. 2008
  4. droemel

    droemel Neuer User

    Registriert seit:
    11 Juni 2005
    Beiträge:
    53
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @jogyfl
    Das Problem könnte an den Pipe-Zeichen ("|") in Deinen Dial-Befehlen liegen. Das sollten nun Kommas sein.
     
  5. clan

    clan Mitglied

    Registriert seit:
    21 Apr. 2005
    Beiträge:
    266
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ein bischen anders ist das schon: dort steht als Beispiel

    Dial(type/identifier, timeout, options, URL)

    in deiner extensions.conf dagegen

    Dial,SCCP/${EXTEN}|15|Ttr

    Anscheinend wird die von dir benutzte alte Form ohne Klammern und mit '|' als Trenner inzwischen nicht mehr unterstützt. Etwas indirekt findet man auch was in der UPGRADE.txt
     
  6. Nimrod

    Nimrod Aktives Mitglied

    Registriert seit:
    26 Juli 2005
    Beiträge:
    1,172
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bei mir gabs den Befehl Wait nicht mehr, scheint sich wirklich einiges geändert zu haben. Hab vor einem halben Jahr mir mal angeschaut wie es jetzt aussehen soll.

    Wenn man das manuell macht scheint sich einiges vereinfacht zu haben, da ich das aber per Webinterface mache und die neuen Versionen dafür die ich gerne hätte noch nicht ganz aktualisiert wurden warte ich erst noch ein bisschen.