.titleBar { margin-bottom: 5px!important; }

Problem mit octobri, qozap und config

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von OttTheTormentor, 19 Nov. 2006.

  1. OttTheTormentor

    OttTheTormentor Neuer User

    Registriert seit:
    29 Sep. 2006
    Beiträge:
    23
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo schon wieder,

    Problem Nr. 1: wenn ich qozap.ko entladen will, bleibt der PC stehen (BUG: soft lockup detected). Ein "Screenshot" davon ist hier: http://img167.imageshack.us/my.php?image=pb190002iy2.jpg
    Hat jemand sowas auch schon gehabt?

    Problem Nr. 2: die richtige Angabe der Ports beim Laden von qozap. Ich will S/T 1+8 2+7 als TE und S/T 3+6 4+5 als NT betreiben. Stimmt dann die Angabe "ports=60" beim Laden? Das ergibt dann im syslog [TE TE NT NT NT NT TE TE]. Demzufolge habe ich dann auch folgendes in der zaptel.conf eingetragen:
    Code:
    span=1,1,3,ccs,ami
    span=2,1,3,ccs,ami
    span=3,0,3,ccs,ami
    span=4,0,3,ccs,ami
    span=5,0,3,ccs,ami
    span=6,0,3,ccs,ami
    span=7,1,3,ccs,ami
    span=8,1,3,ccs,ami
    
    # span=1        TE ISDN-1
    bchan=1-2
    dchan=3
    # span=2        TE ISDN-2
    bchan=4-5
    dchan=6
    # span=3        NT TK-1
    bchan=7-8
    dchan=9
    # span=4        NT TK-2
    bchan=10-11
    dchan=12
    # span=5        NT TK-3
    bchan=13-14
    dchan=15
    # span=6        NT TK-4
    bchan=16-17
    dchan=18
    # span=7        TE ISDN-3
    bchan=19-20
    dchan=21
    # span=8        TE ISDN-4
    bchan=22-23
    dchan=24
    
    Stimmt diese Reihenfolge so?

    Mit der Minimalkonfiguration in extensions.conf (alle Anrufe nur durchreichen) funktioniert schon ein Anruf von aussen, aber nicht andersrum. Meldung z.B.
    Code:
     Nov 19 02:17:12 VERBOSE[1548] logger.c:     -- Extension 's' in context 'pbx-incoming' from '030xxxxxxxx' does not exist.  Rejecting call on channel 0/2, span 6
    
    (die x sind von mir)

    Dann auch immer reichlich Meldungen dieser Art:
    Code:
    Nov 19 02:17:17 VERBOSE[1545] logger.c:   == Primary D-Channel on span 3 down
    Nov 19 02:17:17 WARNING[1545] chan_zap.c: No D-channels available!  Using Primary channel 9 as D-channel anyway!
    
     
  2. OttTheTormentor

    OttTheTormentor Neuer User

    Registriert seit:
    29 Sep. 2006
    Beiträge:
    23
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Problem reduziert auf Verbindung mit Tenovis Integral 5

    Das Problem mit dem Entladen von qozap ist bekannt und es wird dran gearbeitet, mit "ztcfg -s" vorm "rmmod" bleibt der PC nicht stehen (Dank an kpj at junghanns.net).

    Was noch offen bleibt ist die erste Leitung zur Integral. Das hier ist der Originalkonfiguration:

    Code:
      NTBA-3 NTBA-2 NTBA-1
        |      |      |
        |      |      |
        \      /      \
         \    /        \    +---- HVT
          \  /          \  /
           \/            \/
           ||            ||
           ||            ||
           ||            ||
        S0T0 3/4      S0T0 1/2
    
             Baugruppe T8S
    
    Im PC habe ich eine octobri, 2 Ports als TE durch ein Patchpanel von den NTBA, 2 Ports als NT durch das Patchpanel zur TK. Leitung 1 zur TK meldet:

    logger.c: == Primary D-Channel on span 3 down
    chan_zap.c: No D-channels available! Using Primary channel 9 as D-channel anyway!

    wobei in zapata.conf definiert ist:

    ; span 3 mit D-Kanal 9
    channel => 7-8

    Auf ISDN-Ebene sieht das wie folgt aus:
    Code:
    Nov 28 18:39:09 WARNING[1546] chan_zap.c: No D-channels available!  Using Primary channel 9 as D-channel anyway!
    Nov 28 18:39:10 VERBOSE[1546] logger.c: 3 Sending Set Asynchronous Balanced Mode Extended
    Nov 28 18:39:10 VERBOSE[1546] logger.c: 3
    > [ 02 01 7f ]
    Nov 28 18:39:10 VERBOSE[1546] logger.c: 3
    > Unnumbered frame:
    Nov 28 18:39:10 VERBOSE[1546] logger.c: 3 > SAPI: 00  C/R: 1 EA: 0
    >  TEI: 000        EA: 1
    Nov 28 18:39:10 VERBOSE[1546] logger.c: 3 >   M3: 3   P/F: 1 M2: 3 11: 3  [ SABME (set asynchronous balanced mode extended) ]
    > 0 bytes of data
    Nov 28 18:39:11 VERBOSE[1546] logger.c: 3 Sending Set Asynchronous Balanced Mode Extended
    
    ... ohne Antwort von der TK

    Wenn ich Leitung 1 zur TK weglasse, dann funktioniert alles nur mit Leitung 2 und 3 (d.h. 3mal ISDN incoming, 2mal zur TK). Die Verkabelung ist in Ordnung, wenn ich 1 und 2 zur TK tausche, dann kommen die Beschwerden über einen anderen fehlenden D-Kanal. Ich könnte ja fast mit nur 2 Leitungen zur TK leben, aber Leitung 1 geht zu einer anderen Abteilung mit eigenem Telefon+Fax.

    Hat noch jemand eine Idee, was ich ausprobieren könnte? In der Tenovis möchte ich nach Möglichkeit nichts ändern, so dass man beim PC-Crash durch einfaches Umstecken von 3 Leitungen wieder den Originalzustand wiederherstellen kann.