.titleBar { margin-bottom: 5px!important; }

Problem: SIP-Accounts sind nicht registriert

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von joosi, 5 Okt. 2006.

  1. joosi

    joosi Neuer User

    Registriert seit:
    3 Aug. 2006
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    nach der Umstellung auf Realtime habe ich mit den sippeers das Problem, dass die nicht angemeldet werden.

    Meine extconfig.conf sieht so aus:
    Code:
    sipusers => mysql,asterisk,sip
    sippeers => mysql,asterisk,sip
    
    Meine sip.conf sieht so aus:
    Code:
    [general]
    context=default
    bindport=5060
    bindaddr=80.*.*.*
    srvlookup=yes
    language=de
    
    rtupdate=yes
    rtchachefriends=yes
    rtautoclear=no
    
    register => 3******:*****@sipgate.de/3******
    ....
    
    Beim Aufruf von realtime load sippeers name 3*****
    Code:
    Column Name  Column Value
              --------------------  --------------------
                                id  4
                           bitType  sip
                              name  3*****
                          username  3******
                              type  peer
                            secret  ******
                          disallow  all
                             allow  ulaw
                               nat  no
                              host  sipgate.de
                       canreinvite  no
                          fromuser  ******
                        fromdomain  sipgate.de
                          insecure  very
                        regseconds  0
    
    
    Beim Aufruf von "sip show registry" werden die Accounts als registered angezeigt. Wenn ich aber auf der Nummer anrufe, dann kommt immer das Zeichen, dass die Nummer nicht verfügbar wäre.

    Habe ich etwas vergessen? Ich habe dasselbe für die iax.conf gemacht, dort funktioniert es.

    Hat jemand eine Idee woran das liegen könnte?
    Bin für alle Hinweise sehr dankbar.
     
  2. joosi

    joosi Neuer User

    Registriert seit:
    3 Aug. 2006
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hat denn niemand eine Idee, wie ich herausfinden könnte, an was das liegt?
     
  3. madiehl

    madiehl Mitglied

    Registriert seit:
    15 Feb. 2005
    Beiträge:
    438
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich bin so schlecht im Erraten der extensions.conf, daher weiss ich nicht, ob Du überhaupt einen eingehenden Kontext dafür definiert hast......
     
  4. joosi

    joosi Neuer User

    Registriert seit:
    3 Aug. 2006
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Also in der Tabelle sip gibt es auch noch folgenden Eintrag (hier in ausgeschriebener Form):

    Code:
    [sipgate_de_in]
    type=peer
    fromdomain=sipgate.de
    host=sipgate.de
    disallow=all
    allow=ulaw
    context=sipgate_ankommend
    
    Meine extensions.conf ist noch nicht auf realtime umgestellt und sieht so aus:

    Code:
    [sipgate_ankommend]
    exten => 3******,1,macro,.....
    ...
    
    Sollte laut meinem Verständis funktionieren. Oder liege ich da falsch?