.titleBar { margin-bottom: 5px!important; }

[PROBLEM] Snom 360 Setting URL per NOTIFY ändern

Dieses Thema im Forum "snom" wurde erstellt von NovasoN, 25 Sep. 2008.

  1. NovasoN

    NovasoN Neuer User

    Registriert seit:
    25 Sep. 2008
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi!

    Ich habe ein Snom 360 bei dem ich gerne die Setting-URL mit einem Notify ändern würde.Das wird auf der Snom-Website mit einem Trace beschrieben, mehr gibts dazu leider nicht.

    Ich versuch das ganze einfach mit SIPp zu senden. Meine xml-Datei für SIPp sieht wie folgt aus:

    Code:
    <scenario name="Basic Sipstone UAC">
      <!-- In client mode (sipp placing calls), the Call-ID MUST be         -->
      <!-- generated by sipp. To do so, use [call_id] keyword.                -->
      <send retrans="500">
        <![CDATA[
    NOTIFY sip:1002@10.16.10.216:5060 SIP/2.0
    Via: SIP/2.0/[transport] [local_ip]:;[local_port]branch=[branch]
    Max-Forwards: 70
    To: sip:1002@10.16.10.216
    From: sip:sipp@10.16.10.198
    Call-ID: [call_id]
    CSeq: 1 NOTIFY
    Content-Type: application/url
    Event: xml
    http://10.16.10.198/snom/kunibert.xml
        ]]>
    
      </send>
    
      <!-- By adding rrs="true" (Record Route Sets), the route sets         -->
      <!-- are saved and used for following messages sent. Useful to test   -->
      <!-- against stateful SIP proxies/B2BUAs.    
      <recv response="200" rtd="true">
      </recv>
    
    </scenario>
    
    10.16.10.216 = IP des Snom-Phones angemeldet mit der Identität 1002 auf dem Proxy mit der IP 10.16.10.155
    10.16.10.198 = IP von der aus ich SIPp ausführe und gleichzeitig der HTTP-Server mit der settings.xml-Datei bzw. der Test-Datei kunibert.xml

    Das Snom reagiert leider auf alles was ich ihm schicke mit einem "ICMP Port unreachable". Und zwar auf ALLEN Ports. Ich hab die Nachricht auch schon öfters verändert, immer das gleiche Problem.

    Ich weiß leider nicht mehr weiter. Könnt ihr mir vielleicht helfen?

    Grüße
     
  2. NovasoN

    NovasoN Neuer User

    Registriert seit:
    25 Sep. 2008
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #2 NovasoN, 26 Sep. 2008
    Zuletzt bearbeitet: 3 Okt. 2008
    Hi!

    Ich hab eine Lösung zumindest teilweise gefunden, nachdem ich folgendes auf der Snom-Seite zu einem leicht anderen Thema gefunden und eingestellt habe, bekomm ich jetzt zumindest keine ICMP Port unreachable Nachrichten mehr.

    # disable the Filter Packets from Registrar
    # disable offer GRUU option
    # set Network identity (port) to value "5060" to have a static sip port

    kA warum, aber mein Port war verstellt.

    Jetzt bekomm ich SIP 404 Antworten. Mal schauen wie ich das lösen kann.

    Gruß NovasoN
     
  3. NovasoN

    NovasoN Neuer User

    Registriert seit:
    25 Sep. 2008
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi!

    leider komm ich nicht weiter. Vom Snom (jetzt ein 370er) kommt zwar ein 200 OK, aber die URL wird nicht übernommen.

    kann mir jemand helfen?

    hier der Code der SIPp-XML:

    Code:
    
      <send retrans="500">
        <![CDATA[
    NOTIFY sip:10.16.10.202:5060 SIP/2.0
    Via: SIP/2.0/[transport] [local_ip]:;[local_port]branch=[branch]
    Max-Forwards: 20
    To: sip:5005@10.16.10.198
    From: sip:sipp@10.16.10.198
    Call-ID: [call_id]
    CSeq: 1 NOTIFY
    Content-Type: application/url
    Event: xml
    
    http://10.16.10.198/snom/success.xml
        ]]>
    
      </send>
    
    
      <recv response="200" rtd="true">
      </recv>
    
    </scenario>
    
    
    10.16.10.202 = IP des Snom 370
    10.16.10.198 = IP des openSER, HTTP-Servers und des SIPp-Hosts