Probleme bei Konfiguration Asterisk zu Alcatel 4400

bkopatschek

Neuer User
Mitglied seit
14 Okt 2004
Beiträge
16
Punkte für Reaktionen
0
Punkte
0
Hallo Leute!

Wir haben folgenden Aufbau vor

PSTN -> S2M -> Asterik -> S2M -> Alcatel 4400

Der Asterisk Server ist auf Ubuntu 6.06 mit Kernel 2.6.15 aufgesetzt. Versionen sind Asterisk 1.2.11, Zaptel 1.2.8 und LibPRI 1.2.3
Als Hardware setzen wir 2x Digium TE110P ein. Eine geht zum Amt eine zur Alcatel.

Die Alcatel hat 1 PRA2 Board eingebaut. Hat ne CPU6 und Rel. 5.1 aufgespielt.

Unser Ziel ist es eine sanfte Migration weg von der Alcatel hin z ur offen VOIP Welt zu machen.

Die installation hat auf Anhieb gepaßt und funktioniert. Nach einigem Basteln haben wir auch ein passendes Kabel hinbekommen zu Verbindung vom Asterisk zur Alcatel, denn Alcatel scheint ja da ihr eigenes Süppchen zu kochen.

So folgende Situation haben wir. Wenn alles verkabelt ist, zeigen beide Karten den Status OK in ZTTOOL sowie die LEDs sind grün.
Vom Asterisk können per CLI DIAL Commandos abgesetzt werden und man wird auch korrekt angerufen. Ruft man allerdings dann unsere Kopfnr. die 968-0 an, bekommt man die Meldung:" Diese Nr ist uns nicht bekannt.". Wählt man eine direkte Durchwahl der Alcatel an, kommt ein Besetztzeichen.
Versucht man von der Alcatel aus rauszutelefonieren, meldet die Alcatel sofort Falsche Nr.

Hier die Zapata.conf
[trunkgroups]
;#--==[trunkgroups end]==--#;

[channels]

language=de
context=default
overlabdial = yes
usecallingpres=yes
switchtype=euroisdn
nationalprefix=0
internationalprefix=00
echocancel=yes
echocancelwhenbridged=no
echotraining=no

callerid=asrecived

;#span 1 (Karte 0) auf TE110P (PMI Anschluss vom Provider)
signalling = pri_cpe
context = from-pstn
group = 1
channel => 1-15,17-31

;#span 2 (Karte 1) auf TE110P (PMI Anschluß zu Telefonanlage)
signalling = pri_net
context = from-legacy-pbx
group = 2
channel => 32-46,48-62
;#--==[channels end]==--#;

Zaptel.conf
#Karte 0
span=1,1,0,ccs,hdb3,crc4
bchan=1-15,17-31
dchan=16

#Karte 1
span=2,0,0,ccs,hdb3,crc4
bchan=32-46,48-62
dchan=47

extensions.conf
;# The "General" category is for certain variables.
[general]
static=yes
writeprotect=no
;#--==[general end]==--#;

[globals]
language=de

;#RUFREGELN/DIALPLAN

[from-legacy-pbx]
exten => _0.,1,Dial(Zap/g1/${EXTEN:1})
exten => _0.,2,Hangup
;#--==[from-legacy-pbx]==--#;

[from-pstn]
exten => _9684[5-7]X,1,Dial(IAX2/10.4.138.51/${EXTEN},55,Ttr)
exten => _9684[5-7]X,2,Hangup
exten => _968XXX,1,Dial(Zap/g2/${EXTEN:3})
exten => _968XXX,2,Hangup
;#--==[from-pstn]==--#;


Hat jemand ne Idee was wir falsch machen???

Vielen Dank

Gruß
Björn
 

olaf_TT

Mitglied
Mitglied seit
15 Mrz 2005
Beiträge
302
Punkte für Reaktionen
0
Punkte
0
overlabdial = yes

Rechtschreibung?

968-0 ist auch nicht definiert!

968-xxx ist definiert

exten => _968XXX,1,Dial(Zap/g2/${EXTEN:3})
exten => _968XXX,2,Hangup

Habt ihr in der Alcatel was in den Entitiys geändert?
Wenn nicht sollte das: EXTEN:3 auch nicht gut sein, da die 4400 die volle Nummer erwartet.
 
Zuletzt bearbeitet:

bkopatschek

Neuer User
Mitglied seit
14 Okt 2004
Beiträge
16
Punkte für Reaktionen
0
Punkte
0
Hi Olaf!

Wer lesen kann ist klar im Vorteil da hast du recht. Dank Overlapdial können wir zwar jetzt von der Alcatel raustelefonieren aber egal über welchen Teilnehmer werden alle Gespräche beim angerufenen mit der 9680 angezeigt und nicht mit der Nebenstellennr.

Die Entitys haben wir nicht geändert.

Das Problem ist das weiterhin wenn über die 0 angerufen wird die Ansage kommt"Diese Nr ist uns nicht bekannt" und wenn man über die Nebenstelle anruft bekommt man ein besetzt.
Über die CLI sehen wir das das Gespräch vom Asterisk angenommen wird und versucht wird weiterzuleiten, dies aber leider scheinbar nicht funktioniert.
Wir haben die Änderungen wie du sie angeregt hast vorgenommen.

Die Ausgabe auf der CLI ist:
ASTDENM001*CLI>
-- Accepting overlap call from '0170XXXXXX' to '968567' on channel 0/1, span 1
-- Starting simple switch on 'Zap/1-1'
-- Executing Dial("Zap/1-1", "Zap/g2/968567") in new stack
-- Requested transfer capability: 0x00 - SPEECH
-- Called g2/968567
-- Zap/32-1 is proceeding passing it to Zap/1-1
-- Channel 0/1, span 2 got hangup request
-- Hungup 'Zap/32-1'
== Everyone is busy/congested at this time (1:0/0/1)
-- Executing Hangup("Zap/1-1", "") in new stack
== Spawn extension (from-pstn, 968567, 2) exited non-zero on 'Zap/1-1'
-- Hungup 'Zap/1-1'
ASTDENM001*CLI>


Noch ne Idee was wir falsch machen?

Danke nochmal

Gruß
Björn
 

stoner

Neuer User
Mitglied seit
15 Jul 2005
Beiträge
35
Punkte für Reaktionen
0
Punkte
0
Hi Björn,

evtl. nochmal Rechtschreibung?

callerid => asreceived

Wie schaut denn deine zaptel.conf, zapata.conf und extensions.conf den jetzt aus?

Gruss,

stoner
 

bkopatschek

Neuer User
Mitglied seit
14 Okt 2004
Beiträge
16
Punkte für Reaktionen
0
Punkte
0
Hallo stoner,

schaue mir morgen früh die zapata.conf an, ob ich das da falsch geschrieben habe, das wäre eine Idee!

Dann Poste ich die aktuellen Dateien auch noch mal.

Habe eigentlich nur den schreibfehler raus genommen und die extensions.conf um die 0 erweitert.

Danke!

Gruß
Björn
 

bkopatschek

Neuer User
Mitglied seit
14 Okt 2004
Beiträge
16
Punkte für Reaktionen
0
Punkte
0
Guten morgen,

ich habe jetzt die Einstellung "callerid=asreceived" in der zapata.conf verbessert. Ja da hatte ich mich auch vertippt. Habe zusätzlich noch "pridialplan=local" rein genommen, jetzt gehts... Ich bin mir nicht ganz sicher für was es ist oder ob ich local nehmen muss. Aber da geht es! Hat jemand eine Erklärung?

Ein und Ausgehende gespräche Funktionieren nun auch. Aber eine Frage hab ich noch mal. Ist es möglich ein Freizeichen zu bekommen wenn man ein an der Alcatel angeschlossenes Telefon nimmt und die 0 wählt, dass man dann ein Freizeichen bekommt.

Hier wie versprochen noch mal die config Dateien:

######################################################
# zaptel.conf
######################################################
loadzone=de
defaultzone=nl

# For Digium TE110P
#Karte 0
span=1,1,0,ccs,hdb3,crc4
bchan=1-15,17-31
dchan=16

#Karte 1
span=2,0,0,ccs,hdb3,crc4
bchan=32-46,48-62
dchan=47
######################################################


######################################################
# zapata.conf
######################################################
[trunkgroups]
;#--==[trunkgroups end]==--#;

[channels]
language=de
;context=default
immediate=no
overlapdial=yes
usecallingpres=yes
switchtype=euroisdn
nationalprefix=0
internationalprefix=00
echocancel=no
echocancelwhenbridged=no
echotraining=no
callerid=asreceived
callwaitingcallerid=yes
busydetect=no
callprogress=no
pridialplan=local
;prilocaldialplan=local

;#span 1 (Karte 0) auf TE110P (PMI Anschluss vom Provider)
signalling = pri_cpe
context = from-pstn
group = 1
channel => 1-15,17-31

;#span 2 (Karte 1) auf TE110P (PMI Anschluß zu Telefonanlage)
signalling = pri_net
context = from-legacy-pbx
group = 2
channel => 32-46,48-62
;#--==[channels end]==--#;
######################################################


######################################################
# extensions.conf
######################################################
[general]
static=yes
writeprotect=no
;#--==[general end]==--#;

[globals]
language=de

;###############################################################################
;#RUFREGELN/DIALPLAN
[from-legacy-pbx]
;#Zur telekom gehend
exten => _0.,1,SetCallerID(${CALLERIDNUM:1})
exten => _0.,2,Dial(Zap/g1/${EXTEN})
exten => _0.,3,Hangup
exten => _Z.,1,SetCallerID(${CALLERIDNUM:1})
exten => _Z.,2,Dial(Zap/g1/${EXTEN})
exten => _Z.,3,Hangup
;#--==[from-legacy-pbx]==--#;

[from-pstn]
;#Von telekom kommend
exten => _9680,1,SetCallerID(${CALLERIDNUM:1})
exten => _9680,2,Dial(Zap/g2/${EXTEN})
exten => _9680,3,Hangup
exten => _968[0-35-9].,1,SetCallerID(${CALLERIDNUM:1})
exten => _968[0-35-9].,2,Dial(Zap/g2/${EXTEN})
exten => _968[0-35-9].,3,Hangup
exten => _9684[0-48-9].,1,SetCallerID(${CALLERIDNUM:1})
exten => _9684[0-48-9].,2,Dial(Zap/g2/${EXTEN})
exten => _9684[0-48-9].,3,Hangup
exten => _9684[5-7]X,1,SetCallerID(${CALLERIDNUM:1})
exten => _9684[5-7]X,2,Dial(IAX2/10.4.138.51/${EXTEN},55,Ttr)
exten => _9684[5-7]X,3,Hangup
;#--==[from-pstn]==--#;
######################################################

Gruß
Björn
 

stoner

Neuer User
Mitglied seit
15 Jul 2005
Beiträge
35
Punkte für Reaktionen
0
Punkte
0
Hallo,

freut mich dass nun alles klappt.
Leider kenn ich mich mit den Alcatel kaum aus, arbeite nur mit Hipath Anlagen.
Bei Siemens kann in der TK-Anlage der Amtswählton simuliert werden ("0CZ"), k.a. ob das bei Alcatel auch geht, mit Asterisk ist mir keine Lösung bekannt.


Ciao,
stoner
 

olaf_TT

Mitglied
Mitglied seit
15 Mrz 2005
Beiträge
302
Punkte für Reaktionen
0
Punkte
0
Mit einer ARS Amtsanlassung sollte es gehen.
Nur ist das ein Lizenzabhängiges Flag.

Gruß
Olaf
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,874
Beiträge
2,027,599
Mitglieder
350,992
Neuestes Mitglied
tbnbc