.titleBar { margin-bottom: 5px!important; }

Probleme mit deutschen Sound Files

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von robi1a, 19 Jan. 2009.

  1. robi1a

    robi1a Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    74
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo
    Ich habe bei mir die deutschen Sprachpakete installiert, nur kommen zwischendurch Ansagen in englisch. Folgend der Ablauf:

    Abhören der Mailbox: (die Ansagen sind in deutsch)

    -- <SIP/15-08202c80> Playing 'vm-youhave' (language 'de')
    -- <SIP/15-08202c80> Playing 'digits/2' (language 'de')
    -- <SIP/15-08202c80> Playing 'vm-Old' (language 'de')
    -- <SIP/15-08202c80> Playing 'vm-first' (language 'de')
    -- <SIP/15-08202c80> Playing 'vm-message' (language 'de')
    == Parsing '/var/spool/asterisk/voicemail/default/11/Old/msg0000.txt': Found
    -- <SIP/15-08202c80> Playing 'vm-received' (language 'de')

    ab hier ist die Ansage jetzt engisch:
    -- <SIP/15-08202c80> Playing 'digits/day-6' (language 'de')
    -- <SIP/15-08202c80> Playing 'digits/h-17' (language 'de')
    -- <SIP/15-08202c80> Playing 'digits/mon-0' (language 'de')
    -- <SIP/15-08202c80> Playing 'digits/2' (language 'de')
    -- <SIP/15-08202c80> Playing 'digits/thousand' (language 'de')
    [Jan 19 22:08:54] WARNING[6607]: file.c:602 ast_openstream_full: File digits/and does not exist in any format
    [Jan 19 22:08:54] WARNING[6607]: file.c:912 ast_streamfile: Unable to open digits/and (format 0x8 (alaw)): No such file or directory
    -- <SIP/15-08202c80> Playing 'digits/9' (language 'de')
    -- <SIP/15-08202c80> Playing 'digits/at' (language 'de')
    -- <SIP/15-08202c80> Playing 'digits/20' (language 'de')
    -- <SIP/15-08202c80> Playing 'digits/oclock' (language 'de')
    -- <SIP/15-08202c80> Playing 'digits/6' (language 'de')
    -- <SIP/15-08202c80> Playing '/var/spool/asterisk/voicemail/default/11/Old/msg0000' (language 'de')

    Die entsprechenden Files sind allerdings im de Verzeichnis und de/digits vorhanden. Auch das digits/and File gibt es. Ich habe schon mit dem Format Parameter in der voicemail.conf herum gespielt. Keine Änderung.
    Ev. hat jemand einen Tipp für mich.
     
  2. FrankIT

    FrankIT Mitglied

    Registriert seit:
    4 Feb. 2006
    Beiträge:
    735
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Welche Asterisk-Version verwendest du? Welchen Wert hat languageprefix in der asterisk.conf? Falls "yes", ist das korrekte Verzeichnis digits/de (statt de/digits).
     
  3. robi1a

    robi1a Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    74
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das war das Problem.
    languageprefix steht auf yes.
    Habe entsprechende Symlinks gesetzt.
    Danke für die Hilfe