Probleme mit Hints+Snom 320

henk469

Neuer User
Mitglied seit
18 Apr 2007
Beiträge
52
Punkte für Reaktionen
0
Punkte
0
Hallo,mich beschäftigt das Thema auch, wenn bei uns in der Firma die Asterisk neu gestartet wird, funktionieren ersteinmal die Hints nicht mehr, ich habe sogar das gefühl, das die bei manchen gar nicht mehr funktionieren, bis man das telefon neustartet...:( Das stiftet hier bei uns dann natürlich große verwirrung, weshalb ich das ganze gerne aus der welt schaffen würde...
Die Telefone neu zu starten ist natürlich eine Möglichkeit, die ich auch schon in Betracht gezogen hatte, allerdings Gefällt mir die Lösung mit der Zeit runterstellen für die nächste subscribe anmeldung wesentlich besser, da die Telefone nicht neu gestartet werden müssen, was bei uns auch schon bei einigen Telefonen zu abstürzen geführt hat, sodass die telefone nicht mehr richtig hochgekommen sind, was wiederum verwirrung stiftet.
Würde mich sehr freuen, wenn mir eben jemand sagt, wie man das mit der Zeit runterstellen macht, ich hab so jetzt nichts gefunden!
MFG
henk469
 
F

foschi

Guest
[Ich hab das Posting mal aus einem 2 Jahre alten Thread abgetrennt.]

Das gesamte Hints/Subscription-System im Asterisk ist buggy, es muß nicht unbedingt an den Endgeräten liegen. Das von Dir geschilderte Verhalten zeigt aber, dass anscheinend irgendwo grundsätzlich der Wurm drin ist.

Wenn Du ein wenig mehr schilderst kann man Dir ggf. helfen...
 

henk469

Neuer User
Mitglied seit
18 Apr 2007
Beiträge
52
Punkte für Reaktionen
0
Punkte
0
Also das Grundlegende Problem ist, das nach dem Neustart der Asterisk die Hints an den Telefonen erst einmal nicht mehr funktionieren, bei den meisten Telefonen legt sich das mit der Zeit, und die Hints werden wieder angezeigt, allerdings gibt es auch Telefone die dieses Verhalten nicht aufweisen, d.h.bei denen die hints auch nach mehreren Tagen noch nicht angezeigt werden. Aus diesem Grund habe ich dann ein "script" zum neustarten der Asterisk geschrieben, bei dem nach dem neustart durch ein Sip notify die Telefone neu gestartet werden, allerdings bestand bei diesem Vorgehen das Problem, das die Telefone teilweise beim neustarten hängen bleiben.

Weil ich keine Lust habe alle Telefone bei uns zu überprüfen, bzw. nach dem Neustart duch die Firma zu laufen und die hängen gebliebenen Telefone von Hand neu zu starten, wäre es am elegantesten, wenn ich die Zeit bis zum subscribe runtersetzen könnte!

Ich hoffe mit der Problembeschreibung kann jemand was anfangen? Sonst einfach nachfragen, ich gebe gerne mehr informationen, wüsste nur momentan nicht welche...;-)

ach doch, es handelt sich zum größten Teil um Snom 360 und einige 320, alle über PoE versorgt mit einer Firmware der Version 7 und hängen an einer Asterisk Version 1.2

MFG
henk469
 
F

foschi

Guest
Du "erfährst" ein Asterisk-Problem, welches Du auch nicht ohne weiteres durch das Ändern des Timings korrigieren kannst...
 

Guard-X

Aktives Mitglied
Mitglied seit
14 Mai 2005
Beiträge
2,497
Punkte für Reaktionen
0
Punkte
0
Es gibt ein paar Möglichkeiten über diverse snom Settings eine kleinere Besserung herbeizurufen. Allerdings werden trotzdem einige Tasten "durchrutschen".

Warum startest du den Asterisk denn neu?
 

Tweety

Mitglied
Mitglied seit
2 Apr 2005
Beiträge
215
Punkte für Reaktionen
0
Punkte
0
Wie wäre es, wenn man ein Event, ähnlich wie für reboot-snom, einführt um eine Erneuerung der Subscriptions manuell zu veranlassen?

Das wäre doch mal ein Feature Request bei Snom wert!?
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,297
Beiträge
2,032,514
Mitglieder
351,838
Neuestes Mitglied
Bobrob3