push_firmware klappt nicht wg. "link down"

dsteinkopf

Mitglied
Mitglied seit
29 Jul 2005
Beiträge
263
Punkte für Reaktionen
0
Punkte
0
Hallo,

jetzt muss ich doch mal fragen, auch wenn ich meine, es schonmal gelesen zu haben, aber ich finde es nicht mehr:

Seit ich die Fritzbox nicht mehr über einen Switch mit dem Linux-Rechner verbunden habe, klappt push_firmware nicht mehr. Ich nehme an, es liegt daran, dass die Netzwerkkarte am Linux-Rechner nach dem Fritz-Reboot nicht schnell genug sieht, dass der Fritzbox-Link wieder da ist. Und deswegen ist keins der Test-Pings erfolgreich. Über den Switch klappt es, weil da einfach durchgehend ping-Pakete geschickt werden.

Unter Windows kann man ja das "Media Sensing" abschalten - wohl aus genau diesem Grund. Steht im Wiki.

Wie löse ich das unter Linux?

Danke.


Dirk
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Hm, das hab ich ja noch nie gehört. Ist das wirklich ein Linux PC oder gehts um eine virtuelle Maschine?

MfG Oliver
 

supamicha

Mitglied
Mitglied seit
3 Dez 2004
Beiträge
591
Punkte für Reaktionen
4
Punkte
18
Gnome Desktop in Verbindung mit dem NM-Applet macht die gleichen Probleme wie Windows.
Lösung: NM-Applet deinstallieren und das Netz von Hand konfigurieren.
 

dsteinkopf

Mitglied
Mitglied seit
29 Jul 2005
Beiträge
263
Punkte für Reaktionen
0
Punkte
0
Nein, es ist ist ein "richtiger" Linux-Rechner. Wenn ihr jetzt so sagt, dass das unter Linux ungewöhnlich ist, fällt mir ein, dass mein eth0 Teil einer Bridge (br0) ist. Evtl. hat es ja damit was zu tun.

Folgende Meldungen erhalte ich beim Reboot der FritzBox:

Code:
Feb 23 06:40:54 martinihost kernel: br0: topology change detected, propagating
Feb 23 06:40:54 martinihost kernel: br0: port 1(eth0) entering forwarding state
Feb 23 06:40:54 martinihost kernel: r8169: eth0: link down
Feb 23 06:40:54 martinihost kernel: br0: port 1(eth0) entering disabled state
Feb 23 06:40:56 martinihost kernel: r8169: eth0: link up
Feb 23 06:40:56 martinihost kernel: br0: port 1(eth0) entering learning state
Feb 23 06:40:59 martinihost kernel: r8169: eth0: link down
Feb 23 06:40:59 martinihost kernel: br0: port 1(eth0) entering disabled state
Feb 23 06:41:41 martinihost kernel: r8169: eth0: link up
Feb 23 06:41:41 martinihost kernel: br0: port 1(eth0) entering learning state
Feb 23 06:41:42 martinihost kernel:  CIFS VFS: server not responding
Feb 23 06:41:42 martinihost kernel:  CIFS VFS: No response for cmd 50 mid 30
Feb 23 06:41:56 martinihost kernel: br0: topology change detected, propagating
Feb 23 06:41:56 martinihost kernel: br0: port 1(eth0) entering forwarding state
Hat vielleicht noch jemand das Ethernet in einer Bridge?

Außerdem hat mein lokales Netz ander IPs als 192.168.178.*, sodass mein ich eine zweite IP (192.168.178.2) auf dem br0 eingerichtet habe (br0:1). Aber das sollte ja nicht weiter stören. Mit Switch geht es ja auch.


Dirk
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
234,422
Beiträge
2,046,335
Mitglieder
354,163
Neuestes Mitglied
wadwadqwed