.titleBar { margin-bottom: 5px!important; }

[Gelöst] Radvd and Aiccu issues with freetz-1.2_rc1

Dieses Thema im Forum "Freetz" wurde erstellt von RomMon, 4 Feb. 2012.

  1. RomMon

    RomMon Neuer User

    Registriert seit:
    29 Aug. 2011
    Beiträge:
    105
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    #1 RomMon, 4 Feb. 2012
    Zuletzt bearbeitet: 8 Okt. 2012
    I hope someone can have a look at my issues when I try to use Aiccu and Radvd.

    I'm running 74.04.90 with Freetz-1.2_rc1 on my 7270v3.
    (wget http://freetz.org/downloads/freetz-1.2_rc1.tar.bz2)

    During configuring of make I selected also IPv6 and packages:
    aiccu, Dnsmasq, Dropbear, radvd, tcdpdump, Inadyn-mt, ndas


    Currently I see 3 IPv6 related issues.
    - The -6 option is not accepted with ping (e.g. ping -6 <IPv6 name | IPv6 address>) Solved by suggestion of Whoopie
    - Aiccu is trying to start before NTP sync the router at router reboot. Solved by configuring a wait time (Maximal time waiting for time-synchronisation (seconds)). But I'm a bit surprised that the default settings don't behave to work in most situations.
    - Radvd is complaining about 'sendmsg: Invalid argument' and fails to start.


    Seen a number of times that the whole router rebooted when adapting radvd.
    -when applying the initial configuration of radvd,
    -when restarting radvd.
    -when changing configuration of radvd.

    Info after configuring aiccu and radvd via the web interface:
    Code:
    # ip -f inet6 route
    2001:a:b:c::/64 dev sixxs  metric 256  expires 42909512sec
    fe80::/64 dev sixxs  metric 256  expires 42909512sec
    fe80::/64 dev lan  metric 256  expires 42909513sec
    ff00::/8 dev sixxs  metric 256  expires 42909512sec
    ff00::/8 dev lan  metric 256  expires 42909513sec
    default via 2001:a:b:c::1 dev sixxs  metric 1024  expires 42909512sec
    #
    >>>> I'm missing a /64 route 2001:x.y::/64 pointing to lan.
    >>>> Is this an function that is part of the radvd script that fails?

    Code:
    # ip -f inet6 addr
    2: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    6: lan: <BROADCAST,MULTICAST,UP,LOWER_UP200> mtu 1500
        inet6 2001:x:y::1/128 scope global                   <<<<< shouldn't this be a /64 address?
           valid_lft forever preferred_lft forever
        inet6 fe80::224:feff:fefa:a344/64 scope link
           valid_lft forever preferred_lft forever
    38: sixxs: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1280 qlen 500
        inet6 2001:a:b:c::2/64 scope global
           valid_lft forever preferred_lft forever
        inet6 fe80::410:b:c:2/64 scope link
           valid_lft forever preferred_lft forever
    #
    logread:
    Jan 1 01:01:35 fritz local7.err syslog: Couldn't resolve host tic.sixxs.net, service 3874
    Jan 1 01:01:35 fritz local7.err syslog: Couldn't connect to the TIC server tic.sixxs.net
    Jan 1 01:01:35 fritz local7.err syslog: Couldn't retrieve first tunnel for the above reason, aborting
    Jan 1 01:01:35 fritz user.notice FREETZMOD: Starting aiccu ... failed.
    after restart of aiccu after a NTP sync:
    Feb 4 12:44:14 fritz local7.info syslog: Succesfully retrieved tunnel information for Txxxxx
    Feb 4 12:44:14 fritz local7.info syslog: AICCU running as PID 2822
    Feb 4 12:44:14 fritz local7.info syslog: [AYIYA-start] : Anything in Anything (draft-02)
    Feb 4 12:44:14 fritz local7.info syslog: [AYIYA-tun->tundev] : (Socket to TUN) started


    Jan 1 01:01:35 fritz daemon.info radvd[2118]: version 1.7 started
    Jan 1 01:01:36 fritz daemon.warn radvd[2119]: sendmsg: Invalid argument
    Jan 1 01:01:36 fritz user.notice FREETZMOD: Starting radvd ... done.
    >> I don't see this 'Invalid argument' when I start radvd manunally (see below). Is a script causing this?


    # ping -6 2001:a:b:c::1 soved by suggestion of Whoopie
    ping: invalid option -- 6
    BusyBox v1.18.5 (2012-02-03 21:31:22 CET) multi-call binary.

    Usage: ping [OPTIONS] HOST

    Send ICMP ECHO_REQUEST packets to network hosts

    Options:
    -4,-6 Force IP or IPv6 name resolution
    -c CNT Send only CNT pings
    -s SIZE Send SIZE data bytes in packets (default:56)
    -I IFACE/IP Use interface or IP address as source
    -W SEC Seconds to wait for the first response (default:10)
    (after all -c CNT packets are sent)
    -w SEC Seconds until ping exits (default:infinite)
    (can exit earlier with -c CNT)
    -q Quiet, only displays output at start
    and when finished
    # ping 2001:a:b:c::1
    ping: bad address '2001:a:b:c::1'

    # cat /proc/sys/net/ipv6/conf/all/forwarding
    1


    If I start radvd manually it is ok, and I can get advertising and routing working:
    Rebooted the router and via telnet performed the following steps:

    # radvd -v
    # cat /var/run/radvd.pid
    # kill -9 <pid>
    # rm /var/run/radvd.pid
    # radvd -C /mod/etc/radvd.conf -d 2& <<< so config generated by web interface is ok.
    Now radvd is working. It is advertising IPv6 addresses and a default IPv6 route.
    # ip -f inet6 route add 2001:x:y::/64 dev lan
    Now routing is also working. And I can ping an global IPv6 route or its DNS name from a connected (Win7) system.

    IPv6 routing table of the 7270v3:
    # ip -f inet6 route
    2001:a:b:c::/64 dev sixxs metric 256 expires 42946491sec
    2001:x:y::/64 dev lan metric 1024 expires 42949538sec
    fe80::/64 dev lan metric 256 expires 42946258sec
    fe80::/64 dev sixxs metric 256 expires 42946491sec
    ff00::/8 dev lan metric 256 expires 42946258sec
    default via 2001:a:b:c::1 dev sixxs metric 1024 expires 42946492sec
    #
     
  2. Whoopie

    Whoopie Aktives Mitglied

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    812
    Zustimmungen:
    3
    Punkte für Erfolge:
    18
    There's a ping6 command (FREETZ_BUSYBOX_PING6), but you have to select it under "Advanced options -> BusyBox options -> IPv6 Options".
     
  3. RomMon

    RomMon Neuer User

    Registriert seit:
    29 Aug. 2011
    Beiträge:
    105
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    #3 RomMon, 5 Feb. 2012
    Zuletzt bearbeitet: 10 Feb. 2012
    Whoopie, Thanks I found the ping6 option and created an new image with these options enabled.
    I have to wait until I can install it until nobody is using the router. Hopefully I can do this later today.

    I also found the script that is starting radvd: /etc/init.d/rc.radvd
    But don't see a line that could cause the 'sendmsg: Invalid argument' message.

    And the /etc/init.d/rc.aiccu scripts does have a wait for NTP sync, depending on a couter.
    Not sure what the default counter is.

    Edit:
    Found the default counter: /etc/default.aiccu/aiccu.cfg >> export AICCU_WAITTIME='0'
    So I have to configure a wait time in the Advanced section of the Freetz web interface it looks.
    Edit3: Aiccu starts normal at boot of the router with a wait time configured. I configured 'Maximal time waiting for time-synchronisation (seconds)' with a value of 3600. I expected the default settings would allow AICCU to work normally (e.g. endless wait time until NTP got a sync).

    Edit2:
    Whoopie, YES your correct. now both ping6 and ping -6 are working fine.
     
  4. RomMon

    RomMon Neuer User

    Registriert seit:
    29 Aug. 2011
    Beiträge:
    105
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    #4 RomMon, 10 Feb. 2012
    Zuletzt bearbeitet: 8 Okt. 2012
    Radvd isn't working properly.
    -after staring radvd route adverising isn't working.
    -the whole router unexpectedly reboots when changing the config if radvd is running.


    I configured the following:
    IPv6 interface: lan (=default)
    IPv6 address: 2001:a:b::1/64 (the first address with a /64 mask from the 2001:a:b::/48 range I obtained from Sixxs.net)
    IPv6 address: 2001:a:b::/64 (the first /64 range of the /48 obtained)
    selected 'Activate on start resp. deactivate on stop the IPv6 forwarding.' (=default)
    selected 'Set on start resp. unset on stop the IPv6 address of the interface.'

    The generated config in /mod/etc/radvd.conf works fine if I manual start Radvd.


    Edit (8-10-2012):
    Found a workaround for the router crashing issue by unselecting 'Activate on start resp. deactivate on stop the IPv6 forwarding.' option.
    Also radvd route adverising is now working normal. Which was probably caused by all the changes.
    For more info see: http://freetz.org/wiki/packages/radvd.en and http://freetz.org/ticket/1921