.titleBar { margin-bottom: 5px!important; }

Raustelefonieren gestört, aber erreichbar: [avm_power]event: 27 not handled

Dieses Thema im Forum "Freetz" wurde erstellt von ao, 20 Sep. 2008.

  1. ao

    ao Aktives Mitglied

    Registriert seit:
    15 Aug. 2005
    Beiträge:
    2,078
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich habe 29.04.63freetz-devel-2500 auf meiner 7170, die via ata-Modus hinter einem Kabelmodem (KD) hängt. Von Zeit zu Zeit kann ich nicht raustelefonieren, bin aber weiterin erreichbar.
    Beim Versuch rauszutelefonieren, kommt ein lang gestreckter Ton die akustische Mitteilung:
    Das scheint eine Mitteilung von KD bzw. vom Kabelmodem zu sein, aber ich denke halt, dass es an der Fritzbox bzw. an meiner Freetz-Installation liegt, da ein FB-Neustart das Problem (vorerst) löst.
    Jetzt habe ich mal das syslog angeschaut (ohne Box-Neustart):
    Code:
    Sep 20 10:27:21 fritz daemon.info callmonitor: [61] event detected:
    Sep 20 10:27:21 fritz daemon.info callmonitor:   EVENT=out:connect
    Sep 20 10:27:21 fritz daemon.info callmonitor:   SOURCE='0123456789'
    Sep 20 10:27:21 fritz daemon.info callmonitor:   DEST='0987654321'
    Sep 20 10:27:26 fritz user.warn kernel: [avm_power]event: 27 not handled
    Sep 20 10:27:26 fritz user.info kernel: kdsld: internet: masq_dst_gc: 0 of 0 checked (0 mappings, 0 hash)
    Immer wieder reproduzierbar taucht dabei die Zeile "[avm_power]event: 27 not handled" auf. Könnt Ihr damit etwas anfangen?
     
  2. Silent-Tears

    Silent-Tears IPPF-Promi

    Registriert seit:
    3 Aug. 2007
    Beiträge:
    7,456
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    BI
    Taucht bei mir auch auf, stört aber überhaupt nicht ;)
     
  3. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Über was reden wir hier? VOIP?
    Dann könnte es helfen den voipd mal mit -fv zu starten und sich die Logs anzuschauen, wenn das Problem auftritt.

    MfG Oliver
     
  4. ao

    ao Aktives Mitglied

    Registriert seit:
    15 Aug. 2005
    Beiträge:
    2,078
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #4 ao, 20 Sep. 2008
    Zuletzt bearbeitet: 20 Sep. 2008
    VoIP? Gute Frage! Ich nehme ja an, dass Telefonieren bei Kabel Deutschland auf alle Fälle VoIP ist.
    Code:
    /var/mod/root # ps | grep voip
      580 root      4232 S <  voipd 
     1180 root      1164 S    grep voip 
    /var/mod/root # kill -9 580 && voipd -fv
    voipd: startup (AVM FRITZ!Box Fon WLAN 7170 29.04.63 AVM SIP v9.03.229 Aug  1 2008 11:09:27)
    voipd: using capi controller 5
    voipd: using b1 protocol 10 for 8kHz
    voipd: using b1 protocol 11 for 16kHz
    voipd: tel: NOT supported
    voipd: ENUM NOT supported
    voipd: T38 Init Params t38[16644] Aug  1 2008 11:03:49 
    voipd: T.38 supported
    voipd: VoIP led value = 0
    voipd: no useragent configured
    voipd: INFO led: off (value=0)
    voipd: VoIP SRTP led value = 0
    voipd: priority is -20
    voipd: encaplen 24
    voipd: brutto speed 22080000/1184000 voip speed 1168000
    voipd: connstatus 0 -> 5
    voipd: PCMA/8000/1: 98933 bits/second (encaplen=24,30ms)
    voipd: PCMU/8000/1: 98933 bits/second (encaplen=24,30ms)
    voipd: G726-32/8000/1: 56533 bits/second (encaplen=24,30ms)
    voipd: G726-40/8000/1: 70666 bits/second (encaplen=24,30ms)
    voipd: G726-24/8000/1: 56533 bits/second (encaplen=24,30ms)
    voipd: iLBC/8000/1: 42400 bits/second (encaplen=24,30ms)
    voipd: PCMA/16000/1: 197866 bits/second (encaplen=24,30ms)
    voipd: PCMU/16000/1: 197866 bits/second (encaplen=24,30ms)
    voipd: CLEARMODE/8000/1: 98933 bits/second (encaplen=24,30ms)
    voipd: G722/8000/1: 98933 bits/second (encaplen=24,30ms)
    voipd: PCMA/8000/1: 106000 bits/second (encaplen=24,20ms)
    voipd: PCMU/8000/1: 106000 bits/second (encaplen=24,20ms)
    voipd: G726-32/8000/1: 84800 bits/second (encaplen=24,20ms)
    voipd: G726-40/8000/1: 84800 bits/second (encaplen=24,20ms)
    voipd: G726-24/8000/1: 63600 bits/second (encaplen=24,20ms)
    voipd: iLBC/8000/1: 63600 bits/second (encaplen=24,20ms)
    voipd: PCMA/16000/1: 212000 bits/second (encaplen=24,20ms)
    voipd: PCMU/16000/1: 212000 bits/second (encaplen=24,20ms)
    voipd: CLEARMODE/8000/1: 106000 bits/second (encaplen=24,20ms)
    voipd: G722/8000/1: 106000 bits/second (encaplen=24,20ms)
    
    Seit dem voipd Neustart geht es wieder, so dass ich kein verbose output anhängen kann, sorry.
    Aber wie mache ich das nun, dass im Falle eines erneuten Problems auch entsprechend verbose output lesbar wird?
    Landet das dann auch mittels syslogd im Ringpuffer, oder sollte ich das evtl. sinnvoller mit "voipd -v -D /var/tmp/voipd.log" erledigen?

    Edit:
    Habe es eben so ausprobiert, aber unter /var/tmp/ wird keine Datei voipd.log angelegt, obwohl ich dort schreiben kann.
    Wie kann man denn den (verbose) output von voipd in eine Datei loggen, wenn es nicht mit dem -D Parameter geht?
    Ist es dann sinnvoller, den gesamten syslogd output in einer Datei statt im Ringpuffer zu loggen?
    Ich möchte das dann aber möglichst auf den syslogd output begrenzen, da die Datei sonst doch ziemlich groß wird.

    Bis dahin habe ich voipd mal so gestartet: voipd -v (also im Hintergrund).

    Nochmals danke für Eure Hilfe!