.titleBar { margin-bottom: 5px!important; }

Reboot bei Schreibvorgängen auf NFS Share

Dieses Thema im Forum "Freetz" wurde erstellt von Herr des Lichts, 3 Jan. 2009.

  1. Herr des Lichts

    Herr des Lichts Neuer User

    Registriert seit:
    28 Jan. 2006
    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Moin moin,

    ich habe das Verzeichnis /var/media/uStor01 (1GB USB-Stick) per NFS freigegeben (rw). Schreibe ich nun mehrere (MP3)-Dateien dorthin, dann bootet die FB reproduzierbar :-( Dies passiert so ab ca. 50-60MB.
    Lesevorgänge von diesem Share funktionieren problemlos. Ebenso funktionieren Schreibvorgänge problemlos wenn ich dieses Share via Samba (freetz) o. von der AVM-Webgui freigebe.

    exports:
    /var/media/ftp/uStor01 *(rw,anonuid=0,anongid=0,insecure,async,fsid=0,no_subtree_check)

    mount:
    mount.nfs 192.168.1.101:/var/media/ftp/uStor01 /mnt/test -v -w
    mount.nfs: timeout set for Sat Jan 3 09:42:53 2009
    mount.nfs: text-based options: 'addr=192.168.1.101'
    mount.nfs: trying 192.168.1.101 prog 100003 vers 3 prot TCP port 2047
    mount.nfs: trying 192.168.1.101 prog 100005 vers 3 prot UDP port 1029
    mount.nfs: text-based options (retry): 'addr=192.168.1.101,nfsvers=3,proto=tcp,port=2047,mountproto=udp'
    192.168.1.101:/var/media/ftp/uStor01 on /mnt/test type nfs



    Any hint?

    Cu

    Achim
     
  2. Silent-Tears

    Silent-Tears IPPF-Promi

    Registriert seit:
    3 Aug. 2007
    Beiträge:
    7,456
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    BI
    Wie sieht es denn mit der auslastung deiner Box aus zu der Zeit, wo du die Sachen schreibst? Hast du swap aktiviert? Prozessoraktivität?
     
  3. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    #3 olistudent, 3 Jan. 2009
    Zuletzt bearbeitet: 3 Jan. 2009
    Hi.
    Ich hab das mal auf meiner 7270 ausprobiert. Mir scheint, dass die kopierten Daten im RAM zwischengespeichert werden. Wenn ich eine 100 MB Datei kopiere, dann geht der Fortschrittsbalken innerhalb von Sekunden auf ca. 35 MB und tut sich erstmal mehere Sekunden lange nichts.
    Einen Reboot konnte ich aber nicht feststellen, wobei ich das Problem hab, dass ich immer nur eine Datei kopieren kann. Da stimmt noch irgendwas mit den Rechten nicht...

    MfG Oliver

    edit: Ich hab den Reboot gerade bekommen als ich die nfs-Module entfernen wollte...
    Code:
    Jan  3 14:22:30 fritz user.err kernel: sunrpc: failed to unregister ip_map cache
    Jan  3 14:22:30 fritz user.err kernel: BUG: warning at fs/proc/generic.c:732/remove_proc_entry()
    Jan  3 14:22:30 fritz user.err kernel: Call Trace:
    Jan  3 14:22:30 fritz user.err kernel: [<9400d824>] dump_stack+0x8/0x34
    Jan  3 14:22:30 fritz user.err kernel: [<940a64fc>] remove_proc_entry+0x16c/0x1e0
    Jan  3 14:22:30 fritz user.err kernel: [<94044fb4>] sys_delete_module+0x198/0x1dc
    Jan  3 14:22:30 fritz user.err kernel: [<94010300>] stack_done+0x20/0x3c
    Jan  3 14:22:30 fritz user.err kernel:
    
     
  4. n.primera

    n.primera Neuer User

    Registriert seit:
    13 Okt. 2007
    Beiträge:
    32
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hey,

    du bist mit dem Problem nicht allein. :) Hab dieses schon vor längerer Zeit im Thread (hier) gelesen, und selber auch die Erfahrung gemacht (hier). Zum kopieren auf Usb nutze ich samba, damit klappts ja.

    Nun hab ich aber noch ein anderes Problem. Seit dem ich auf "Firmware-Version 29.04.67freetz-devel-2979M" geupdetet habe, funktioniert bei mir der nfs-mount am client nicht mehr. Der nfs-Server auf der Fritz wird scheinbar ordnungsgemäss gestartet. Die configuration im Fretz ist die gleiche. Bin dann wieder zurück zur "7170_04.59freetz-1.0.1" dort klappt der mount wieder ohne Probleme. Woran kann das liegen? Finde leider nichts was mir weiterhilft.

    exports
    thx
    mfg