Replace Kernel -> Box läuft nicht (5050)

snowyrain

Neuer User
Mitglied seit
31 Jul 2006
Beiträge
125
Punkte für Reaktionen
0
Punkte
16
Hallo,

ich wollte bei meiner 5050 den Kernel ersetzten. Wenn ich Freetz das machen lasse, läuft soweit alles durch. Nach dem Flashen startet die Box ist aber nur über die serielle Konsole erreichbar. Die LEDs blinken im Takt:

-LEDs aus (ganz kurz)
-LED Power an (IHMO 0,2 Sekunde)
-Alle LEDs an (IHMO 0,2 Sekunde)
Das ganze acht mal.
danach LED Power an (IHMO 1 Sekunde)
Alles zusammen in einer Endlosschleife.

Freetz mit WOL lief bei mir. Ich habe die Version 1.0 und den Stable-Branch versucht. Gleicher Effekt.

Anbei habe ich die BootMsgs und die Kernel und Freetz .config. Die Bootanzeige mit dem Replace-Kernel sieht anders aus. Vielleicht kann jemand da was mit anfangen und helfen.

Schönen Sonntag noch.

Snowyrain
 

Anhänge

Zuletzt bearbeitet:

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Hi.
Sieht so aus als würden die Module nicht zum Kernel passen. Hab leider grad keine Zeit für mehr Details...

MfG Oliver
 

snowyrain

Neuer User
Mitglied seit
31 Jul 2006
Beiträge
125
Punkte für Reaktionen
0
Punkte
16
Hallo,

es wäre sehr nett wenn Du Dir das ansehen würdest.

EDIT: die Befehle:
make kernel-dirclean
make menuconfig
make config-clean-deps
make kernel-menuconfig
make kernel-precompiled

brachten auch keine Besserung.



Gruß

Snowyrain
 
Zuletzt bearbeitet:

snowyrain

Neuer User
Mitglied seit
31 Jul 2006
Beiträge
125
Punkte für Reaktionen
0
Punkte
16
Hallo,

das Problem besteht leider doch noch. Ich kann bei der 5050 nicht korrekt den Kernel ersetzen lassen. Die 5050 bootet ist nur über LAN1 erreichbar. Und wirft ne Menge Fehlermedlungen (siehe oben). Wenn ich eine Firmware mit org Kernel flashe geht soweit alles. Mein Vorgehensweise:

1. Stinkylinux (frisch)
2. Freetz 1.0 ausschecken (mit stable und trunk gleicher Effekt)
3. make menuconfig
- 5050 auswählen
- Erweiterte Einstellungen aktivieren
- Replace Kernel aktivieren
- Exit and Save
4. make
- 23Min warten (Athlon64 3000+)
5. image mit "tar" entpacken
6. image mit pushfirmware flashen
-dabei fehler: ftp: setsockopt (ignored) Permissions denied (Ich denke das ist trotzdem OK)
7. - Firmware fehlerhaft. Bootet zwar, aber nur Zugriff über Lan A und viele Fehlerweldungen auf der seriellen Konsole.

Gleiche Vorgehensweise (wirklich exakt genauso) nur ohne "Replace Kernel" und es läuft.

Ich verstehe es nicht, was mache ich nur falsch?

Gruß

Snowyrain

Edit1:
Ich kann mit der oben gezeigten Vorgehensweise eine Image mit eigenem Kernel für eine W501V machen. Da sehe ich auch, dass das Image etwas (im zweistelligen kb Bereich) größer wird (wenn Replace Kernel aktiviert ist). Aber die 5050 kriege ich nicht zum Laufen. Warum läuft es bei der 5050 nicht?
 
Zuletzt bearbeitet:

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Hi.
Probier mal bitte mit angehängtem Patch.
1. Patch einspielen (bunzip2 ... & patch -p0 < 5050_kernel_fix.patch)
2. "make menuconfig"
3. "make"
Jetzt sollte der neue Kernel gebaut werden.

Gehts damit? Wenn nicht, dann änder bitte das 33 in 30 und probier nochmal.

MfG Oliver
 

Anhänge

snowyrain

Neuer User
Mitglied seit
31 Jul 2006
Beiträge
125
Punkte für Reaktionen
0
Punkte
16
Hallo und vielen Dank,

es scheint mit dem Patch zu gehen. Ich bin aber gerade ziemlich müde werde morgen weiter testen.

Gruß

Snowyrain
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Hi.
Morgen ist rum? Funktioniert alles was die Box so kann?

MfG Oliver
 

snowyrain

Neuer User
Mitglied seit
31 Jul 2006
Beiträge
125
Punkte für Reaktionen
0
Punkte
16
Hallo,

es sieht gut aus. Zuerst einal zu dem Abändern von 30 auf 33, wenn ich 30 anstatt 33 setze bekomme ich beim erstellen folgende Meldung:
Code:
dl/fritzbox7141-source-files-04.30.tar.bz2« gespeichert [41303083]

mkdir -p source/avm-gpl-04.30
tar -C source/avm-gpl-04.30  -xjf dl/fritzbox7141-source-files-04.30.tar.bz2
touch source/avm-gpl-04.30/.unpacked
rm -rf source/ref-4mb_26-04.30/kernel
mkdir -p source/ref-4mb_26-04.30/kernel
cp -a  source/ref-4mb_26-04.30/kernel/kernel_8mb_26_build
cp: Fehlender Zieldatei-Operand hinter „source/ref-4mb_26-04.30/kernel/kernel_8mb_26_build“
„cp --help“ gibt weitere Informationen.
make: *** [source/ref-4mb_26-04.30/kernel/.unpacked] Fehler 1
Mit dem Patch direkt, sieht es viel besser aus. Das Image wird mit Kernel erstellt. Ich kann leider nicht das DSL-Modem oder ISDN testen. Aber Lan B FON 1 und 2 gehen jetzt. Vielen Dank

Gruß

Snowyrain
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Okay. Dann bau ich das mal ein und hoffe, dass der Rest auch funzt.

MfG Oliver
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,831
Beiträge
2,027,213
Mitglieder
350,919
Neuestes Mitglied
patka