.titleBar { margin-bottom: 5px!important; }

RTP hinter NAT geht, aber nur kurz

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von jomat, 1 Feb. 2009.

  1. jomat

    jomat Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Ich suche jetzt schon eine ganze Weile, wenngleich ich auch nicht so recht weiss, wonach ich suchen soll... am besten, ich fange mit meinem Problem ganz am Anfang an, der Konfiguration:

    Sipgate.de ---NAT--- Asterisk 1.4.21.2~dfsg-2 ---LAN--- VoIP-Telefon

    Ich habe mehrere VoIP-Telefone, Siemens S675IP, Nokia N800, mit denen ich intern über den Asterisk telefoniere. Ich möchte auch über Sipgate mit Asterisk raustelefonieren, aber da dazwischen findet NAT statt. Soweit kein Problem, der Echo-Test von Sipgate (Rufnummer 10005) funktioniert, ich kann mich selbst hören. Die Testnummer 10000 funktioniert auch, mir wird eine Ansage vorgespielt, aber jedes der Gespräche verstummt nach einer Weile. Im Log sieht das so aus (Verbosity von 20, rtp debug, rtcp debug):

    Code:
    Got  RTP packet from    192.168.4.11:9002 (type 00, seq 001100, ts 73778080, len 000160)
    Sent RTP packet to      217.10.79.30:14770 (type 08, seq 065217, ts 73778080, len 000160)
    Got  RTP packet from    217.10.79.30:14770 (type 08, seq 037878, ts 160000, len 000160)
    Sent RTP packet to      192.168.4.11:9002 (type 00, seq 043896, ts 160000, len 000160)
    Got  RTP packet from    192.168.4.11:9002 (type 00, seq 001101, ts 73778240, len 000160)
    Sent RTP packet to      217.10.79.30:14770 (type 08, seq 065218, ts 73778240, len 000160)
    gaia*CLI> 
    
    Got RTCP from 217.10.79.30:14771
    PT: 200(Sender Report)
    Reception reports: 1
    SSRC of sender: 1970270577
    NTP timestamp: 3442431373.2128356167680
    RTP timestamp: 160000
    SPC: 1000       SOC: 160000
      Fraction lost: 1
      Packets lost so far: 7
      Highest sequence number: 65214
      Sequence number cycles: 0
      Interarrival jitter: 67
      Last SR(our NTP): 21905.385362653373005824
      DLSR: 4.9260 (sec)
      RTT: 70(sec)
    
    
    Got RTCP from 217.10.79.30:14771
    PT: 202(Unknown)
    Reception reports: 1
    SSRC of sender: 1970270577
    Received an SDES from 217.10.79.30:14771
    * Sent RTCP SR to 217.10.79.30:14771
      Our SSRC: 590929596
      Sent(NTP): 1233442582.1354678272
      Sent(RTP): 73778240
      Sent packets: 997
      Sent octets: 159520
      Report block:
      Fraction lost: 0
      Cumulative loss: 0
      IA jitter: 0.0008
      Their last SR: 1435311864
      DLSR: 0.0030 (sec)
    
    Got  RTP packet from    192.168.4.11:9002 (type 00, seq 001102, ts 73778400, len 000160)
    Sent RTP packet to      217.10.79.30:14770 (type 08, seq 065219, ts 73778400, len 000160)
    * Sent RTCP SR to 192.168.4.11:9003
      Our SSRC: 1812236371
      Sent(NTP): 1233442582.1436573696
      Sent(RTP): 160000
      Sent packets: 999
      Sent octets: 159840
      Report block:
      Fraction lost: 0
      Cumulative loss: 0
      IA jitter: 0.0002
      Their last SR: 0
      DLSR: 55062.3500 (sec)
    
    Got  RTP packet from    192.168.4.11:9002 (type 00, seq 001103, ts 73778560, len 000160)
    Sent RTP packet to      217.10.79.30:14770 (type 08, seq 065220, ts 73778560, len 000160)
    Got  RTP packet from    192.168.4.11:9002 (type 00, seq 001104, ts 73778720, len 000160)
    Sent RTP packet to      217.10.79.30:14770 (type 08, seq 065221, ts 73778720, len 000160)
    Got  RTP packet from    192.168.4.11:9002 (type 00, seq 001105, ts 73778880, len 000160)
    
    Wie man sieht, kommen keine Pakete mehr von Sipgate an. Ich hab' überall canreinvite=no (global, bei den Telefonen und für Sipgate), ebenso directrtpsetup=no. In der rtp.conf ist 49000 bis 49030 eingestellt, die Ports sind auch für UDP an den Rechner geforwarded.

    Bin um jeden Hinweis dankbar!
    Jomat
     
  2. chaos2000

    chaos2000 Aktives Mitglied

    Registriert seit:
    22 Aug. 2004
    Beiträge:
    2,028
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Ort:
    LE
    wer macht den bei dir NAT, speedport?
     
  3. jomat

    jomat Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nein, das ist ein Sinus 1054 DSL. Leider ist noch mehr Hardware dazwischen, mindestens 3 WRT54GL, wobei zwei davon mit DD-WRT und einer mit OpenWRT betrieben wird. Leider habe ich keinen Zugriff darauf, bis auf den OpenWRT. Das ist ein gemeinsam genutztes Netz, der OpenWRT ist mein eigener Router zwischen diesem und meinem. Den einzige Moeglichkeit, Einfluss zu nehmen, ist dem Administrator Mails zu schreiben mit Anweisungen :-/