.titleBar { margin-bottom: 5px!important; }

Samba Schreibzugriff auf USB-Device unter DS-Mod 2.9-26.12

Dieses Thema im Forum "Freetz" wurde erstellt von binduli, 5 Jan. 2007.

  1. binduli

    binduli Neuer User

    Registriert seit:
    21 Nov. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Zusammen,

    ich habe ein Problem mit den Rechten beim Samba-Server des neusten DS-Mods.
    Das Ganze läuft auf einer 7141.

    Es gibt hierbei Probleme mit dem Schreibzugriff auf die externe Platte die an der Box hängt. Lesen funktioniert einwandfrei.

    Hier ein auszug per ssh:
    /var/media/ftp/SeagateExternalDrive-Partition-1-1 $ ls -la
    drwxr-xr-x 8 anonymou root 32768 Jan 1 1970 .
    drwxr-xr-x 3 root root 0 Jan 1 01:01 ..
    drwxr-xr-x 5 anonymou root 32768 Jan 1 01:07 Dokumente
    drwxr-xr-x 2 anonymou root 32768 Dec 25 2006 Recycled
    drwxr-xr-x 5 anonymou root 32768 Jan 1 2000 Sonstiges
    drwxr-xr-x 3 anonymou root 32768 Dec 23 2006 System Volume Information

    Als User steht hier "anonymou".
    Ist dieser auch beim Smaba-Server berücksichtigt? Oder liegt es ganz an was anderem?

    Danke und Gruß

    Uli
     
  2. Darkyputz

    Darkyputz Aktives Mitglied

    Registriert seit:
    27 Juli 2005
    Beiträge:
    2,320
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Ort:
    Newton, New Jersey
    was steht in deiner samba.conf
    guest account=root oder
    guest account=samba?

    wenn da samba steht, dann änder das mal ganz flux in root und die welt iss glücklich...
     
  3. kriegaex

    kriegaex Aktives Mitglied

    Registriert seit:
    7 Nov. 2006
    Beiträge:
    2,927
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Projektmanagement-Coach (Certified Scrum Professio
    Ort:
    Großraum Nürnberg
    Das einzige, was mich stört, ist, daß die Änderung jedesmal wieder überklatscht wird, wenn ich was an der Samba-Konfiguration in der DS-Mod-Weboberfläche ändere. Es klappt nur ein Weilchen, wenn ich die beiden Dienste von der Kommandozeile neu starte.

    Liegt es daran, daß der nvi-Wrapper, respektive modsave flash, nichts sichern, was in /var/mod/etc liegt? Dort befindet sich nämlich smb.conf. Oder muß ich die noch woanders hin kopieren? Ich stecke da leider nicht so drin.
     
  4. dns138

    dns138 Neuer User

    Registriert seit:
    20 Apr. 2007
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #4 dns138, 25 Juli 2007
    Zuletzt bearbeitet: 27 Juli 2007