.titleBar { margin-bottom: 5px!important; }

Schwerer Bug in 0.62

Dieses Thema im Forum "JFritz" wurde erstellt von frankwbb, 29 Nov. 2006.

  1. frankwbb

    frankwbb Neuer User

    Registriert seit:
    25 Juli 2006
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Ich nutze Suse 10.1. Sobald ich jfritz 0.62 mit dem Befehle "java -jar /home/franky/Software/jfritz/jfritz,jar" in der Konsole ausführe, kommt folgende Meldung:

    franky@linux:/> java -jar /homefranky/Software/jfritz/jfritz.jar
    Unable to access jarfile /homefranky/Software/jfritz/jfritz.jar
    franky@linux:/> java -jar /home/franky/Software/jfritz/jfritz.jar
    (Update) Program version: 0.6.2
    (Update) Locale: de_de
    (Update) Update on start: false
    (Update) Saving update-properties......done
    Exception in thread "main" java.lang.RuntimeException: Wrong working directory! Could not find jfritz-internals.jar.
    at de.moonflower.jfritz.autoupdate.JFritzUpdate.startJFritz(JFritzUpdate.java:181)
    at de.moonflower.jfritz.autoupdate.JFritzUpdate.main(JFritzUpdate.java:165)


    jfritz-internals.jar ist aber im gleichen Verzeichnis, wie die jfriz.jar. Warum findet er die nicht?

    Wenn ich aber in der Konsole direkt in das Verzeichnis wechsel:
    cd home/franky/Software/jfritz und dann den Befehl java -jar jfritz.jar funktioniert es.

    Mit der 0.61 hat es auch mit folgendem Befehl einwandfrei funktioniert:
    java -jar /home/franky/Software/jfritz/jfritz,jar
     
  2. Ranga

    Ranga Neuer User

    Registriert seit:
    21 Jan. 2006
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi frank,

    das ist kein bug von jfritz.

    Wenn Du das Programm aus einem anderen Verzeichnis starten möchtest musst du im Aufrufdie zusätzlichn JARS auch im CLASSPATH angeben.

    Version 0.6.1 fun ktionierte noch so, da es dort nur ein jar jfritz.jar gab.

    Gruß
    Ranga
     
  3. frankwbb

    frankwbb Neuer User

    Registriert seit:
    25 Juli 2006
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    #3 frankwbb, 29 Nov. 2006
    Zuletzt bearbeitet: 29 Nov. 2006
    @Ranga

    Wie lautet dann der Befehl mit CLASSPATH in der Konsole?

    Denn ich möchte, dass jfritz automatisch mit jedem Start gestartet wird.
     
  4. Ranga

    Ranga Neuer User

    Registriert seit:
    21 Jan. 2006
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Frank,

    schon mal gegoogelt ;)

    entweder setzt Du die CLASSPATH Variable im Environment

    Code:
    export CLASSPATH=pafd/jarfile:pfad/jarfile
    
    oder Du fügst bei bei deinem Aufruf noch den Parameter

    Code:
    -classpath pafd/jarfile:pfad/jarfile 
    
    hinzu

    siehe auch zum Beispiel hier http://java.sun.com/j2se/1.3/docs/tooldocs/win32/classpath.html

    Gruß
    Ranga
     
  5. Whoopie

    Whoopie Aktives Mitglied

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    814
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    Hi,

    sorry, aber ich krieg's auch irgendwie nicht hin.

    Meine Befehlszeile lautet:
    java -jar /usr/local/lib/jfritz/jfritz.jar -classpath /usr/local/lib/jfritz/


    Was ist daran falsch?

    Danke für Eure Hilfe.
    Beste Grüße,
    Whoopie
     
  6. robot_rap

    robot_rap Aktives Mitglied

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    2,094
    Zustimmungen:
    2
    Punkte für Erfolge:
    38
    Ort:
    Karlsruhe
    probier es mal mit der folgenden shell-datei. Einfach den Text hier in eine Datei einfügen, "jfritz_path" anpassen. Ausführrechte vergeben und in deinen Autostart-Ordner schieben.

    Code:
    #!/bin/bash
    jfritz_path=/usr/local/lib/jfritz
    current_working_dir=$(pwd)
    cd $jfritz_path
    java -jar jfritz.jar &
    cd $current_working_dir
    
    Gruß,
    Rob
     
  7. Whoopie

    Whoopie Aktives Mitglied

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    814
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    Funktioniert!

    Vielen Dank,
    Whoopie