.titleBar { margin-bottom: 5px!important; }

Shrew-Client: VPN-Verbindung zu Fritzbox

Dieses Thema im Forum "FRITZ!Box Fon: DSL, Internet und Netzwerk" wurde erstellt von lenchen, 20 Sep. 2008.

  1. lenchen

    lenchen Neuer User

    Registriert seit:
    19 Sep. 2008
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich habe Probleme beim Verbindungsaufbau. Zwar meldet Shrew, die Verbindung sei aufgebaut ("Tunnel enabled"), die Fritzbox sieht das aber anders ("wird aufgebaut" - kein grünes Licht). Im Trace Log des VPN-Clients bekomme ich eine "invalid id information"-Meldung, wenn ich versuche, einen Rechner oder die Fritzbox im remote LAN anzupingen.

    Bei der Konfiguration habe ich mich an die Screenshots von Whoopie gehalten (siehe http://www.ip-phone-forum.de/attachment.php?attachmentid=23678&d=1206719411), die schon mal sehr hilfreich waren. Dennoch klappt es bei mir nicht :(

    Kurz ein paar Daten zu meiner Konfiguration:

    - lokal FritzFon 7150 mit aktuellster Firmware, IP 192.168.2.1
    - Win XP Pro mit Shrew-Client in Version 2.1.1
    - lokale IP 192.168.2.10, Subnetzmaske 255.255.255.0
    - Remote Fritzbox 7270 mit aktuellster Firmware
    - Subnetz des Remote-LAN: 192.168.0.0, IP der Remote-Fritzbox: 192.168.0.1, Subnetzmaske 255.255.255.0
    - Shrew: Tab "General": Address: 192.168.0.201, MTU 1500, ike config pull
    - Shrew: Tab "Policy": Remote Network Ressource 192.168.0.0/255.255.255.0
    - fritzbox.cfg: analog zu Whoopie (name, user_fqdn und key natürlich anders und entsprechend in Shrew eingetragen), jedoch remote_virtualip = 192.168.0.201; und accesslist = "permit ip 192.168.0.0 255.255.0.0 192.168.0.201 255.255.255.255";
    - Keine Firewall am laufen, kein weiterer VPN-Client
    - IPSec-VPN-Verbindung zu einem anderen Router (Linksys WRV200) klappt mit Shrew problemlos​

    Bin leider völlig :confused: und mit meinem beschränkten IPSec-Latein ohnehin am Ende. Wäre super, wenn mir jemand weiterhelfen könnte.

    Liebe Grüße

    Lena
     
  2. lenchen

    lenchen Neuer User

    Registriert seit:
    19 Sep. 2008
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Weiß niemand Rat?
     
  3. pfeffer

    pfeffer Mitglied

    Registriert seit:
    26 Okt. 2004
    Beiträge:
    755
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hmm - ich kann da keinen Fehler erkennen.
    Versuch das Gleiche doch mal mit der aktuellen Shrew-Version.
    Oder hast Du Dein Problem "bereits" gelöst?

    Nach der Fehlerbeschreibung würde ich vermuten, dass die Policy nicht korrekt ist. - Ist sie vielleicht wirklich: die Subnetzmasken von accesslist und der Policy in Shrew stimmen nicht überein.

    Gruß,
    Pfeffer.
     
  4. cppcodeguru

    cppcodeguru Neuer User

    Registriert seit:
    9 Jan. 2010
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo lenchen, hast Du es inzwischen hinbekommen, ich habe nämlich auch Probleme mit dem Shrew-Client unter Windows 7 64 bit und der FritzBox 7170.
    Bekomme immer die Meldung negotiation timeout nach der Meldung mit dem tunnel. Habe den Shrew-Client laut AVM Anleitung konfiguriert.
     
  5. airattack-ffm

    airattack-ffm Neuer User

    Registriert seit:
    11 Jan. 2010
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo zusammen.

    ich habe selbiges problem. ich habe eine fb 7270 , shrew und win 64bit.

    es wird scheinbar ein tunnel aufgebaut,doch es wird kein standardgateway zugewiesen...

    habe allerdings die letzte laborverion auf der fb....

    wäre ja mal nett wenn das klappen würde.... :)
     
  6. cppcodeguru

    cppcodeguru Neuer User

    Registriert seit:
    9 Jan. 2010
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo habe die VPN-Verbindung Shrew-Client zu FritzBox 7170 inzwischen hinbekommen.

    Ich habe laut Anleitung von AVM die Konfigurationsdatei für die FritzBox und den ShrewVPN-Client erstellt (also mit FritzFernzugang Datei generieren und den Key ersetzen). Dann habe ich laut Anleitung den ShrewClient konfiguriert, das File auf die FirtzBox geladen und es funktionierte nicht. :confused:

    Dann hatte ich gelesen, dass es zu Problemen mit der IP kommen kann, wenn man vom Provider eine IP im 10.x.x.x, 192.x.x.x oder ??? Netz zugewiesen bekommt, was bei mir der Fall war. Also habe ich den nat Eintrag in dem Skript für die FritzBox geändert, funktionierte aber immer noch nicht. :confused:

    Danach habe ich die Konfiguration für den ShrewVPN-Client laut whoopie konfiguriert, und siehe da, endlich eine Verbindung :)

    Also
    Fritzbox: AVM (für ShreVPN) + nat-Änderung
    ShrewVPN: Whoopie

    FritzBox 7170 Version 29.04.76
    ShrewVPN 64 bit Version 2.1.5
    Windows 7 64 bit Professional
     
  7. support

    support Neuer User

    Registriert seit:
    27 Feb. 2007
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    [Edit frank_m24: Sinnfreies Vollzitat vom Beitrag direkt darüber gelöscht, siehe Forumregeln.]

    Hallo,

    bedeutet dies dass die einzige Änderung bei dir das setting
    "NAT-traversal=disabled" war und danach alles geklappt hat ?
     
  8. knoerrli

    knoerrli Mitglied

    Registriert seit:
    22 Nov. 2009
    Beiträge:
    248
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Du bekommst auch keinen Standartgateway auf dem virtuellen Adapter zugewiesen! Das ist also nicht dein Problem.

    Meist liegt es schon wie meine Vorredner schon erwähnt haben am NAT Traversal.