Siemens C470 IP + Sipgate / Ports weiterleiten

jegres

Neuer User
Mitglied seit
19 Nov 2008
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,

ich vermute, die Frage ist für Euch ein "klax" für mich jedoch schier unüberwindbar (leider --> Ärger!).

Also, ich bin bei SipGate Kunde geworden und habe mir ein Siemens GigaSet C470 IP dazubestellt. Die Einrichtung verlief (unerwartet;-)) unkompliziert. Auch gehen Anrufe aus und eingehende klingeln auch. Sprache geht auch raus, NUR, nicht rein.

Laut SipGate Hotline, die mich auf folgende Page verwiesen: https://secure.sipgate.de/faq/index.php?do=displayArticle&article=602&id=249 haben, muss ich "nur" die Ports weiterleiten, was "relativ simpel" sei.

Nun gut, finde ich gar nicht. Ich habe einen SITECOM WLAN Router WL-114v2. Der zieht eine dynamische IP.

Wo muss ich denn verdammt nochmal was eingeben. Folgende Ports sollten (lt. Sipgate) weitergeleitet werden:

Hilfe-Center
Hilfe-Center
Probleme und Störungen
Telefonie
Ich kann nicht telefonieren.
Fehler, die bei der Nutzung von Internet-Telefonie auftreten, resultieren oftmals aus der Verwendung eines Routers. Diese Probleme lassen sich jedoch meist mit wenig Aufwand beheben.

Wenn Sie einen Router und/oder eine Firewall verwenden, sind u.U. einige Einstellungen vorzunehmen, damit eine einwandfreie Nutzung von sipgate gewährleistet werden kann.

Typische Fehler, die durch die Verwendung von Router und/oder Firewall verursacht werden können, sind:

# Ihr Endgerät registriert sich nicht bei sipgate (Status "offline") oder verliert die Registrierung nach einiger Zeit wieder.

# Bei der Gegenseite klingelt es, aber Sie hören keine Sprache.

# Beim Angerufenen klingelt es weiter, obwohl Sie bereits aufgelegt haben.

# Sie sind von außen nicht erreichbar.

# Sie können eine Nummer wählen, hören aber kein Klingeln.

# Sobald jemand abnimmt, kommt kein Gespräch zustande.

# Das Gespräch bricht nach 6-12 Sekunden zusammen.


Diese Fehler sind nicht immer reproduzierbar und tauchen manchmal erst nach Stunden oder Tagen auf.

In den meisten Fällen sollte ein Firmware-Update des Routers ausreichen, um das Problem zu beheben.

Informieren Sie sich dazu bitte beim Hersteller Ihres Routers.

Sollten Sie danach weiterhin Probleme mit der Verbindung haben, aktivieren Sie bitte die Weiterleitung folgender Ports an Ihrem Router/Firewall:

Standard:
Port: 5060 / UDP (SIP-Signalisierung)
Port: 5004 / UDP (RTP, Sprache)
Port: 10000 UDP (STUN)

X-Lite:
Port 5060 / UDP
Port 8000 - 8019 / UDP
Port 10000 /UDP

Zusätzlich: UPnP

Freue mich füber jede Hilfe.

VG
Oliver
 

coprophiliac

Neuer User
Mitglied seit
25 Jun 2005
Beiträge
99
Punkte für Reaktionen
0
Punkte
6
Mhm, ich glaube mit demselben Problem habe ich auch gleich Kontakt wo ein ähnliches Gigaset Telefon hinter einem ADSL Router in Österreich betrieben wird und auch der Angerufene verstanden wird aber der Anrufende Sipgate Nutzer nicht.
Das Problem trat auch erst sporadisch auf und ist nun nicht mehr zu korrigieren.

EDIT: Das Gerät hatte gleich zu Anfang schon eine fixe Adresse per DHCP zugewiesen bekommen. Die restlichen SIP Einstellungen ließen sich dann doch korrigieren. Im SIEMENS Gigaset C475 IP wurde die Verwendung des STUN Servers abgeschalten und die Portweiterleitung angepasst.
Es wurden eingehend folgende Ports auf das SIEMENS Gigaset C475 IP im THOMSON ADSL Gateway eingetragen wie oben und unten beschrieben:
Port: 5004 / UDP (RTP, Sprache)
Port: 5060 / UDP (SIP-Signalisierung)

Der Port 10000 wäre ja ein Port der für den STUN Server stun.sipgate.de:10000 ausgehend freigeschalten werden müsste. Und STUN ist ja auch nur interessant wenn man keine Portweiterleitung einrichten kann - also z.B. hinter einer nicht zu konfigurierenden NAT Lösung.
 
Zuletzt bearbeitet:

surround42

Neuer User
Mitglied seit
21 Feb 2009
Beiträge
198
Punkte für Reaktionen
0
Punkte
16
@jegres) Die Einstellungen mußt Du in Deinem "SITECOM WLAN Router WL-114v2" vornehmen.

Am besten Du machst Dich erstmal mit den Menüs und mit der Bedienungsanleitung dieses Routers vertraut.

Hast Du Dich mit dem Teil schon mal näher beschäftigt?

Wenn ja, dann mußt Du "eigentlich" nur für zwei Dinge sorgen:
1. Dafür dass Dein C470 IP vom Router immer die gleiche IP-Adresse bezieht oder aber dafür dass das C470 IP auf eine feste IP-Adresse im Subnetz des Routers konfiguriert ist (dann aber ausserhalb des Router DHCP-Bereichs).

2. Dafür dass die o.g. Ports im Menu des Routers auf diese feste IP-Adresse weitergeleitet werden, also diese Ports - Standard:
Port: 5060 / UDP (SIP-Signalisierung)
Port: 5004 / UDP (RTP, Sprache)
Port: 10000 UDP (STUN)

Evtl. aber vorher aber noch abchecken ob das C470 IP auch mit diesen Standardports arbeitet... wenn nicht, dann die am C470 IP eingestellten Ports weiterleiten.

Beste Grüße,
surround42

P.S. RTP und STUN sind eigentlich alternative Ansätze... aber in dem Fall schadet doppelt gemoppelt nicht unbedingt (wenn die RTP-Port Verwendung im SIP-Client deaktiviert wird, dann muß STUN funktionieren... sonst nicht unbedingt).

P.P.S. Bist Du mal in die Hilfe bei SipGate gegangen, während Du eingeloggt bist?
Da müßtest Du neben den notwendigen Konfigurationsdaten für ein C470 IP auch zusätzliche Hilfestellung für die Verwendung des Gerätes hinter (D)einem NAT-Router finden.

P.P.P.S. Zum Verständnis:
Ein NAT-Router (wie Deiner) ist immer in der Lage die Datenpakete eines angeschlossenen Gerätes mit Informationen oder mit Sprachdaten zum Provider zu senden... darum können andere Dich hören.
Umgekehrt weiß der Server bei Deinem Provider (SipGate) auch, dass er (Sprach-)Pakete an die IP-Adresse Deines Telefons senden muß. Er weiß aber nicht, dass das Telefon hinter einem Router versteckt ist... er kennt nur die IP-Adresse Deines Routers und die Port-Nummer (hierzu wird nämlich der RTP-Port verwendet).
Die Sprachpakete Deines Gegenübers kommen sicherlich auch jetzt schon beim Router an... aber der weiß nicht, an wen er diese denn nun weitergeben soll... denn theoretisch können an seinem internen Netz 253 verschiedene Geräte wie Dein C470 IP hängen... aber nur für eines von 253 Geräten sind diese Pakete interessant und relevant... nur welches?
Der Router kann das nicht wissen... also mußt Du ihm im Konfigurationsmenü sagen, dass er bitte die RTP-Pakete (welche standardgemäß auf UDP-Port 5004 versendet werden) an die IP-Adresse des Telefons im Subnetz senden soll... und schon hörst Du auch Dein Gegenüber.
Der Haken... nicht alle verwenden den Standardport... und bei interner dynamischer IP-Zuweisung der Geräte am Router könnte Dein Telefon nach einem Neustart von Router und/oder Telefon jedesmal eine andere IP-Adresse beziehen.

Darum:
* dafür sorgen, dass das Telefon immer wieder die gleiche IP im Netz Deines Routers hat.
* dafür sorgen, dass der bei Deinem IP-Telefon eingestellte RTP-Port im Router zu dem Telefon weitergeleitet wird.
* dafür sorgen, dass bei mehreren IP-Telefonen am Router jedes eine eigene feste IP-Adresse hat und dass bei jedem IP-Telefon ein anderer RTP-Port eingestellt und weitergeleitet wird... denn jedes Port kann nur an eine IP-Adresse weitergeleitet werden... womit der Pfad eindeutig bleibt (das Telefon teilt dem Provider in abgesendeten Paketen übrigens mit auf welchem Port es horcht).
* STUN ist ein alternativer Ansatz, aber das führt jetzt hier zu weit.
 
Zuletzt bearbeitet:

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,862
Beiträge
2,027,480
Mitglieder
350,968
Neuestes Mitglied
Stryca