.titleBar { margin-bottom: 5px!important; }

SIP trixbox 2.6 keine eingehende anrufe

Dieses Thema im Forum "FreePBX, TrixBox (Asterisk@Home)" wurde erstellt von cyrano_de_b, 4 Okt. 2008.

  1. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo

    ich möchte gleich sagen das ich seit zwei wochen versuche das problem zu lösen. hab über google alles was ich finden konnte in der richtung in englisch, deutsch, italienisch und französisch gelesen und probiert. ohne erfolg! also wäre ich sehr dankbar für eure hilfe. (falls jemand doch meint das ich was lesen sollte dann bitte gleich den LINK mitgeben.. danke!)

    ich kann intern telefonieren (extensions - extensions),
    ich kann mit der funktion "7777" auch externe telefonate simulieren,
    auch ist es möglich nach "aussen" über die trunks zu telefonieren
    was leider NICHT geht ist anrufe auf die Trunks zu bekommen!!!

    meine konfiguration:

    trixbox 2.6
    SIP trunks bei "citytel" (schweiz)
    sowohl Soft phones als auch analoge phones (über ATA's) als extensions angeschlossen
    hinter einem firewall mit NAT (port forwardet: UDP 5060-5082, TCP 5060, UDP 10000-20000)


    folgend die jeweiligen definitionen:

    anbei screenshots von:
    SIP trunk definition
    Inbound Route defintion
     

    Anhänge:

  2. Beebob007

    Beebob007 Neuer User

    Registriert seit:
    26 Mai 2008
    Beiträge:
    80
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    wie sieht denn deine outbound route aus? ich denke mal da liegt dein fehler
     
  3. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    anbei ein screen-shot meiner outbound regeln.


    danke für deine hilfe....
     

    Anhänge:

  4. Beebob007

    Beebob007 Neuer User

    Registriert seit:
    26 Mai 2008
    Beiträge:
    80
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    was ist denn, wenn du bei den incoming routes direkt auf eine extension umleitest und nicht auf eine ring-group?
    wie sieht deine sip.conf aus?
     
  5. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    das selbe resultat wenn ich die incoming route auf einzelne extensions lege.


    danke für die hilfe!


    anbei kopie der sip-conf:

    ;--------------------------------------------------------------------------------;
    ; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
    ; this file must be done via the web gui. There are alternative files to make ;
    ; custom modifications, details at: http://freepbx.org/configuration_files ;
    ;--------------------------------------------------------------------------------;
    ;

    [general]

    ; These files will all be included in the [general] context
    ;
    #include sip_general_additional.conf

    ;sip_general_custom.conf is the proper file location for placing any sip general
    ;options that you might need set. For example: enable and force the sip jitterbuffer.
    ;If these settings are desired they should be set the sip_general_custom.conf file.
    ;
    ; jbenable=yes
    ; jbforce=yes
    ;
    ;It is also the proper place to add the lines needed for sip nat'ing when going
    ;through a firewall. For nat'ing you'd need to add the following lines:
    ; nat=yes , externip= , localhost= , and optionally fromdomain= .
    ;
    #include sip_general_custom.conf

    ;sip_nat.conf is here for legacy support reasons and for those that upgrade
    ;from previous versions. If you have this file with lines in it please make
    ;sure they are not duplicated in sip_general_custom.conf, if so remove them
    from sip_nat.conf as sip_general_custom.conf will have precedence.
    #include sip_nat.conf

    ;sip_registrations_custom.conf is for any customizations you might need to do to
    ;the automatically generated registrations that FreePBX makes.
    ;
    #include sip_registrations_custom.conf
    #include sip_registrations.conf

    ; These files should all be expected to come after the [general] context
    ;
    #include sip_custom.conf
    #include sip_additional.conf

    ;sip_custom_post.conf If you have extra parameters that are needed for a
    ;extension to work to for example, those go here. So you have extension
    ;1000 defined in your system you start by creating a line [1000](+) in this
    ;file. Then on the next line add the extra parameter that is needed.
    ;When the sip.conf is loaded it will append your additions to the end of
    ;that extension.
    ;
    #include sip_custom_post.conf
     
  6. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ps:

    anbei die defition von Ring Group
     

    Anhänge:

  7. Beebob007

    Beebob007 Neuer User

    Registriert seit:
    26 Mai 2008
    Beiträge:
    80
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  8. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    was genau da?

    sorry.. aber ich finde den fehler bei mir nicht...

    kannst du mir einen tip geben wo den genau der unterschied ist bei mir und auf der seite die du angegeben hast? ..

    danke nochmal für deine hilfe...
     
  9. Beebob007

    Beebob007 Neuer User

    Registriert seit:
    26 Mai 2008
    Beiträge:
    80
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hab es nicht verglichen,aber da steht ja alles was du tun musst......
    hab leider kein sip-account eingebunden, deswegen kann ich dir da auch nicht mehr weiterhelfen.
    deine einstellungen sehen aber so i.o aus auf den ersten blick
     
  10. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    danke für deine hilfe, jedoch kann ich immernoch keine eingehende anrufe bekommen......


    sonst jemand hier mit know how ???


    ich wäre sehr sehr dankbar
     
  11. riedere

    riedere Neuer User

    Registriert seit:
    24 Juli 2005
    Beiträge:
    131
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbstständig
    Ort:
    Zürich
    Gehts jetzt ?

    Bekommst Du dann gar nichts wenn man anruft?
    Was sagt Dir dann ein tail auf dem full.log ?
    Sieht man etwas kommen ?

    Ist die DID richtig eingetragen ?
    (hatte ich auch mit sipcall)

    ---
    nur so bin auf Deinen Beitrag gestossen weil bei mir auch was nicht läuft:
    ich habe enen SN4554 als Trunk dran- ausgehende ok eingehende eigentlich auch aber....
    immer wenn ich anrufe nimmt * ab aber dann die Meldung "The number you have dialed is not in service" das ist kein Problem des SN (der gibts ja weiter aber irgendwo gehts dann in TrixBox falsche Wege - Frage ist nur wo? - hab schon den ganzen Dialplan ausgedruckt und studiert aber komm nicht drauf.
    Dasselbe kommt auch wenn man 7777 also einen eingehenden simuliert.
    ---
    Hoffe helfen zu können, und dass mir jemand einen Tip gibt.

    Gruss Erich
     
  12. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    es funktioniert leider immernoch nicht....

    wenn ich über ein anderes telefon auf eine trixbox nr. anrufe dann kommt immer das besetzt zeichen. dabei wird aber im eingehende protokoll des voip-sip providers auf der nr. ein eingehender anruf verzeichnet, und das trixbox log sieht wie folgt aus:

    [Oct 10 09:41:15] VERBOSE[5082] logger.c: == Parsing '/etc/asterisk/manager.conf': [Oct 10 09:41:15] VERBOSE[5082] logger.c: Found
    [Oct 10 09:41:15] VERBOSE[5082] logger.c: == Parsing '/etc/asterisk/manager_additional.conf': [Oct 10 09:41:15] VERBOSE[5082] logger.c: Found
    [Oct 10 09:41:15] VERBOSE[5082] logger.c: == Parsing '/etc/asterisk/manager_custom.conf': [Oct 10 09:41:15] VERBOSE[5082] logger.c: Found
    [Oct 10 09:41:15] VERBOSE[5082] logger.c: == Manager 'admin' logged on from 127.0.0.1
    [Oct 10 09:41:16] VERBOSE[5082] logger.c: == Manager 'admin' logged off from 127.0.0.1
    [Oct 10 09:41:17] VERBOSE[5084] logger.c: == Parsing '/etc/asterisk/manager.conf': [Oct 10 09:41:17] VERBOSE[5084] logger.c: Found
    [Oct 10 09:41:17] VERBOSE[5084] logger.c: == Parsing '/etc/asterisk/manager_additional.conf': [Oct 10 09:41:17] VERBOSE[5084] logger.c: Found
    [Oct 10 09:41:17] VERBOSE[5084] logger.c: == Parsing '/etc/asterisk/manager_custom.conf': [Oct 10 09:41:17] VERBOSE[5084] logger.c: Found
    [Oct 10 09:41:17] VERBOSE[5084] logger.c: == Manager 'admin' logged on from 127.0.0.1
    [Oct 10 09:41:18] VERBOSE[5084] logger.c: == Manager 'admin' logged off from 127.0.0.1
    [Oct 10 09:41:42] VERBOSE[5089] logger.c: == Parsing '/etc/asterisk/manager.conf': [Oct 10 09:41:42] VERBOSE[5089] logger.c: Found
    [Oct 10 09:41:42] VERBOSE[5089] logger.c: == Parsing '/etc/asterisk/manager_additional.conf': [Oct 10 09:41:42] VERBOSE[5089] logger.c: Found
    [Oct 10 09:41:42] VERBOSE[5089] logger.c: == Parsing '/etc/asterisk/manager_custom.conf': [Oct 10 09:41:42] VERBOSE[5089] logger.c: Found
    [Oct 10 09:41:42] VERBOSE[5089] logger.c: == Manager 'admin' logged on from 127.0.0.1
    [Oct 10 09:41:44] VERBOSE[5089] logger.c: == Manager 'admin' logged off from 127.0.0.1
    [Oct 10 09:41:44] VERBOSE[5098] logger.c: == Parsing '/etc/asterisk/manager.conf': [Oct 10 09:41:44] VERBOSE[5098] logger.c: Found
    [Oct 10 09:41:44] VERBOSE[5098] logger.c: == Parsing '/etc/asterisk/manager_additional.conf': [Oct 10 09:41:44] VERBOSE[5098] logger.c: Found
    [Oct 10 09:41:44] VERBOSE[5098] logger.c: == Parsing '/etc/asterisk/manager_custom.conf': [Oct 10 09:41:44] VERBOSE[5098] logger.c: Found
    [Oct 10 09:41:44] VERBOSE[5098] logger.c: == Manager 'admin' logged on from 127.0.0.1
    [Oct 10 09:41:44] VERBOSE[5098] logger.c: == Manager 'admin' logged off from 127.0.0.1
    [Oct 10 09:41:45] WARNING[2439] chan_sip.c: username mismatch, have <044xxxxxxx city>, digest has <044xxxxxxx>
    [Oct 10 09:41:45] NOTICE[2439] chan_sip.c: Failed to authenticate user "044xxxxxxx" <sip:044xxxxxxx@217.150.243.210>;tag=xxxxxxxxx
    [Oct 10 09:41:50] VERBOSE[5100] logger.c: == Parsing '/etc/asterisk/manager.conf': [Oct 10 09:41:50] VERBOSE[5100] logger.c: Found
    [Oct 10 09:41:50] VERBOSE[5100] logger.c: == Parsing '/etc/asterisk/manager_additional.conf': [Oct 10 09:41:50] VERBOSE[5100] logger.c: Found
    [Oct 10 09:41:50] VERBOSE[5100] logger.c: == Parsing '/etc/asterisk/manager_custom.conf': [Oct 10 09:41:50] VERBOSE[5100] logger.c: Found
    [Oct 10 09:41:50] VERBOSE[5100] logger.c: == Manager 'admin' logged on from 127.0.0.1
    [Oct 10 09:41:51] VERBOSE[5100] logger.c: == Manager 'admin' logged off from 127.0.0.1
    [Oct 10 09:41:51] VERBOSE[5108] logger.c: == Parsing '/etc/asterisk/manager.conf': [Oct 10 09:41:51] VERBOSE[5108] logger.c: Found
    [Oct 10 09:41:51] VERBOSE[5108] logger.c: == Parsing '/etc/asterisk/manager_additional.conf': [Oct 10 09:41:51] VERBOSE[5108] logger.c: Found
    [Oct 10 09:41:51] VERBOSE[5108] logger.c: == Parsing '/etc/asterisk/manager_custom.conf': [Oct 10 09:41:51] VERBOSE[5108] logger.c: Found
    [Oct 10 09:41:51] VERBOSE[5108] logger.c: == Manager 'admin' logged on from 127.0.0.1
    [Oct 10 09:41:51] VERBOSE[5108] logger.c: == Manager 'admin' logged off from 127.0.0.1
    [Oct 10 09:41:53] VERBOSE[5110] logger.c: == Parsing '/etc/asterisk/manager.conf': [Oct 10 09:41:53] VERBOSE[5110] logger.c: Found
    [Oct 10 09:41:53] VERBOSE[5110] logger.c: == Parsing '/etc/asterisk/manager_additional.conf': [Oct 10 09:41:53] VERBOSE[5110] logger.c: Found
    [Oct 10 09:41:53] VERBOSE[5110] logger.c: == Parsing '/etc/asterisk/manager_custom.conf': [Oct 10 09:41:53] VERBOSE[5110] logger.c: Found
    [Oct 10 09:41:53] VERBOSE[5110] logger.c: == Manager 'admin' logged on from 127.0.0.1
     
  13. riedere

    riedere Neuer User

    Registriert seit:
    24 Juli 2005
    Beiträge:
    131
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbstständig
    Ort:
    Zürich
    #13 riedere, 10 Okt. 2008
    Zuletzt bearbeitet: 10 Okt. 2008
    sip:044xxxxxxx@217.150.243.210
    Das sollt die Registrierung sein ? der vordere Teil schaut mir komisch drein
    Ist das Passwort = Telefon Nummer ? und der User sip ?

    Bei sipcall ist es so
    4199432105087:hierDasPasswort@sip.backbone.ch/41432105087

    Ich vermut dass hier der Fehler ist.

    Bei DID Routes musst ich dann angeben (weil das übermittelt kommt)
    41432105087

    noch was . (hab schnell bei citytel geschaut)
    Register string müsst (nach mir) so lauten

    DerUserName:hierDasPasswort@sip.citytel.ch (auch IP geht aber DNS wirst wohl haben, FQD ist besser denn wenn IP wechselt..)
    also irgend so
    0711234567:yx674OvPP@sip.citytel.ch
     
  14. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    mein string sieht wie folgt aus:

    044xxxxxxx:geheim@sip.citytel.ch/044xxxxxxx


    hab die version ohne "/044xxxxxx" auch schon getestet, ohne resultat.


    danke für deine vorschläge.

    würde mich immernoch sehr über hilfe freuen...
     
  15. riedere

    riedere Neuer User

    Registriert seit:
    24 Juli 2005
    Beiträge:
    131
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbstständig
    Ort:
    Zürich
    Ich lös mal ne city telnr und dann versuch ich es
    geht aber vermutlich erst am Montag
     
  16. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    danke ist mega nett!
     
  17. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    sonst jemand eine idee? hilfe?!?
     
  18. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    und? keine vorschläge mehr? bin ich der einzige mit dem problem?
     
  19. riedere

    riedere Neuer User

    Registriert seit:
    24 Juli 2005
    Beiträge:
    131
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbstständig
    Ort:
    Zürich
    Hatte leider noch keine Zeit.

    aber..
    in general settings gibts doch diese Einstellung "Allow Anonymuos SIP inbound calls?"
    bei mir (und dem PATTOON GW) musst ich dies auf yes stellen.
    probier mal.
     
  20. cyrano_de_b

    cyrano_de_b Neuer User

    Registriert seit:
    3 Okt. 2008
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ... ist bei mir genau so eingestellt....


    bin offen für JEDEN vorschlag!!! (hab bald keine haare mehr auf dem kopf um sie mir auszureissen!!...)