.titleBar { margin-bottom: 5px!important; }

sipgate über Asterisk: raus telefonieren geht, rein aber nic

Dieses Thema im Forum "Asterisk Rufnummernplan" wurde erstellt von Joachim, 20 Juni 2005.

  1. Joachim

    Joachim Neuer User

    Registriert seit:
    10 Dez. 2004
    Beiträge:
    146
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Einen guten Tag Euch allen,

    sipgate über Asterisk: raus telefonieren geht, rein aber nicht.
    Konfiguration habe ich anhand der Beispiel hier im Forum eingerichtet.
    Auch den WICHTIG-Fall habe ich berücksichtig.
    Aber da raustelefonieren geht ist das hier nicht ganz der Fall.
    Ich habe im Forum noch jemanden gesehen der das gleich Problem hat.

    Meine Nachforschungen zum Fall:
    Einzige Fehlermeldung die ich finden kann ist
    SIP/2.0 407 Proxy Authentication Required
    Ausschnitt (sip debug):
    Capabilities: us - 14, them - 2047/0, combined - 14
    Non-codec capabilities: us - 1, them - 0, combined - 0
    Reliably Transmitting (NAT):
    SIP/2.0 407 Proxy Authentication Required
    Via: SIP/2.0/UDP 217.10.79.9;branch=z9hG4bKc3a8.5917b5f7.1;received=217.10.79.9
    Via: SIP/2.0/UDP 217.10.79.8;branch=z9hG4bKc3a8.24b8e045.0
    Via: SIP/2.0/UDP 217.10.67.4:5060;branch=z9hG4bK5eeaeab5
    From: "02XXX8763416" <sip:02XXX8763416@217.10.67.4>;tag=as01732870

    Nach reload kann im sip debug sehen das sich asterisk erfolgreich bei sipgate mit der SIPID registriert hat.
    Ich bin mit der 16 am Asterisk angemeldet und kann auch Anrufe entgegennehmen (Funkt.)

    Hier meine Konfig dazu:

    Meine sip.conf (diesbezüglich):
    [general]
    port = 5060 ; Sipport
    bindaddr = 0.0.0.0 ; Addresse für den SIP Kanal
    context = default ; Hier wird den einzelnen Benutzern der Kontext default zugewiesen.
    srvlookup = no ; Enable DNS SRV lookups on outbound calls
    tos=lowdelay ; hier durch wird das Routing verbessert und somit auch die Sprachqualität.
    nat=yes
    disallow=all ; sperrt alle codecs
    allow=ulaw ; erlaubt alle codecs
    allow=alaw
    allow=gsm

    register => SIPID:passwort@sipgate.de/SIPID ; Hier registrieren sie ihren Asteriskserver bei einem anderen DiensT.

    [aesculev1] ; Sipgate ist ihr Account für Gespräche ins Festnetz.
    type=friend
    username=SIPID
    fromuser=SIPID
    secret=
    context=sipgate
    host=sipgate.de
    fromdomain=sipgate.de
    canreinvite=no
    nat=yes
    insecure=very
    qualify=no
    srvlookup = yes


    Mein extensions.conf (diesbezüglich):

    [sipgate]
    exten => _0.,1,SetCallerId,SIPID
    exten => _0.,2,Dial(SIP/${EXTEN}@aesculev1,30,trg)
    exten => _0.,3,Hangup


    [default]
    ;
    ; Bei einem Anruf fügen wir die Demo ein.
    ;
    include => demo
    include => vmailbox
    include => echotest
    include => macro-ruf
    include => Benutzer
    include => sipgate

    [Benutzer]
    exten => 6262073,1,Macro(ruf,SIP/16)


    Danke

    Joachim
     
  2. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
  3. Joachim

    Joachim Neuer User

    Registriert seit:
    10 Dez. 2004
    Beiträge:
    146
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke

    hat geholfen.
    Nachdem ich die Zeile
    caninvite=no
    in der SIP.conf hinzugefügt hatte funkte es.

    Joachim