.titleBar { margin-bottom: 5px!important; }

sl75 bei eingehenden Gesprächen klingelt das Mobilteil nach ca 60 sec.

Dieses Thema im Forum "Gigaset" wurde erstellt von swar0g, 31 Dez. 2006.

  1. swar0g

    swar0g Neuer User

    Registriert seit:
    30 Dez. 2006
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student Elketrotechnik (Uni,Diplom)
    Nun, hallo, Commuity. Ein sehr gutes Forum habt ihr hier :)

    Leider habe ich ein Problem, wo ich schon gar nichts mehr verstehe.

    Nachdem das Mobilteil sich im wlan registriert hat, dauert es etwa eine Minute, bis mit dem sip Provider eine Verbindung aufgebaut wird, soweit, so gut - stun Tests laufen ja etwas länger. Danach kann man auch problemlos ausgehende Gespräche führen - nachdem man eigene Festnetznummer (richtige Festnetznummer, kein voip) wählt, hört man nach 2 Sekunden das Telefon klingeln.


    Das Problem kommt erst mit eingehenden Gesprächen. Wenn man die carpo Nummer wählt, bekommt man einen ordentlichen Piep-Warteton zu hören. In dieser Zeit bleibt das Mobilteil die ganze Zeit aber stumm. Wenn der Anrufende in dieser Zeit wieder auflegt, kommt aufs Mobilteil in ca 30 sec eine Nachricht über einen Anruf in der Abwesenheit.

    Dies fand ich sehr komisch. Hab sl75 abgeschaltet und meinem Laptop die gleiche IP Adresse zugewiesen, die normalerweise das Mobilteil zur Verfügung hat. Einen Softphone (Twinkle) gestartet und gleichzeitig mit Whireshark (so heißt neuerdings Ethereal) die ganze Verbingung geloggt. Nanu. Dauert halt etwas länger, 5-6 Sekunden, aber eingehende Gespräche werden durchgestellt. Als die carpo Nummer von Haustelefon aus gewählt wird, sehe ich sofort im Whireshark die einkommenden udp INVITE Aufforderungen vom sip.carpo.de:5060 auf meine interne LAN IP:5060. Dies bedeutet - die UDP Packete werden vom Router an die interne IP weitergeleitet. So habe ich auch im Router eingestellt.

    Nunja. Hab daraufhin das Mobilteil wieder eingeschaltet, gewartet, bis die Registrierung abgeschlossen war und wieder auf die Carpo Nummer angerufen. Wieder das gleiche Problem - ordentliche Wartepiepser, sl75 rührt sich nicht vom Fleck. Hab dan etwa eine Minute "klingeln" lassen und siehe da, das Mobilteil hat reagiert! Man konnte dann auch den Hörer abnehmen und ganz normal das Gespräch führen.



    Frage an euch: Was kann nun dies für ein Problem sein und wie kann man dies auch beheben?


    Mein sip-Provider ist carpo.de und ich nutze sl75 wlan mit 43er Firmware.
    proxy/registrar: sip.carpo.de
    realm: carpo.de
    stun: stun.carpo.de
    outgoing proxy: sip.carpo.de


    Router: Dlink di-524


    Ich wünsche, ich könnte mit Whireshark die eigentliche Verbindung zwischen sl75 und Internet sniffen. Muss aber überlegen, wie. Ich könnte natürlich versuchen, WAN am Router auszuschalten und auf meinem Laptop mit iptables auch schnell einen Router zu basteln. Dann sehe ich nämlich den ganzen Traffik, auch den vom sl75. Sind dann auch etwas andere Testbedingungen, weil ja der Router nicht der selbe sein wird, aber, wenn's so funktioniert, dann weiß ich bescheid, es liegt am Router.


    Vielleicht gibt es auch irgendeine Möglichkeit irgendwelche vernünftigen Logs durch telnet mobilteil 4159 auf den Bildschirm zu bekommen. Dies hab ich nicht geschafft, obwohl ich ziemlich lange damit gespielt habe.


    Einen guten Rutsch wünsche ich euch!
     
  2. swar0g

    swar0g Neuer User

    Registriert seit:
    30 Dez. 2006
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student Elketrotechnik (Uni,Diplom)
    UPDATE:

    Es hört nicht auf, merkwürdig zu sein. Hab jetzt nun meinen Laptop in den LAN Port des DI-524 Routers eingesteckt, aber auch den benachbarten LAN Port mit meinen DSL Modem verbunden. Dann PPPoE Verbindung gestartet und meinen Laptop als Router eingerichtet

    Code:
    iptables -t nat -A PREROUTING -i ppp0 -p udp --dport 5004 -j DNAT --to 192.168.100.50:5004
    iptables -t nat -A PREROUTING -i ppp0 -p udp --dport 5060 -j DNAT --to 192.168.100.50:5060
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
    
    So werden die Datenpackete zwischen ppp0 (dsl) <-> eth0 (lan) geroutet. Dank des Bridges im DI-524 zwischen LAN und WLAN kann auch mein Laptop vom Siemens SL75 erreicht werden. Soweit, so gut. Dies habe ich so gemacht, damit ich direkt am Laptop, durch den jetzt der gesamte Traffic geht, mit Hilfe eines Sniffers die eventuellen Fehler entdecken kann. Zwar habe ich eine etwas andere Ausgangssituation, aber immerhin.

    Am Mobilteil hab ich die STUN-Server-Nutzung abgeschaltet. Erstens hat es mit dem nicht funktioniert (eingehende Gespräche werden überhaupt nicht durchgestellt). Zweitens werden die Datenpackete jetzt direkt an die betreffenden Ports des Mobilteils weitergeleitet, was den Stun Server überflüssig macht.

    Das Verhalten des SL75 hat sich auch geändert. Jetzt werden die eingehenden Anrufe mal sofort, mal mit Verzögerung von 20 sec durchgestellt. Der Anrufende hört diesmal keinen Warteton, bis das Mobilteil zu klingeln beginnt.

    Einsatz des Sniffers hat auch zu keinem Erfolg geführt. Laut Wireshark werden die UDP Packete an die entsprechenden Ports vermittelt. Die sip INVITEs kommen ins interne Netz definitiv rein. Und jetzt der Hammer. Die Anrufe werden sofort durchgestellt, soweit ich von meinem Laptop ununterbrochen ping Packete ans Mobilteil sende! Dies ist definitiv so und jedes Mal reproduzierbar, wenn mein Laptop den Router spielt. Lässt man einen Linux-Terminal mit pings laufen - klingelt es bei mir sofort, wenn ich angerufen werde. Bricht man mit ping ab, so kommt wieder das selbe Verhalten - mal klingelt es sofort, mal in 20-30 sec, mal gar nicht.


    Wer kann irgendwas mit den obengenannten Symptomen anfangen? Ein Tipp, wie man es in den Griff bekommt?

    Eventuell kann ich hier auch die sniffer-dumps posten.




    P.S. Leider sehr enttäuscht von eingebauter Jabber Funktion. Hin und wieder stürzt das Mobilteil komplett ab, wenn man eine Nachricht bekommt. Ich kann es nicht verstehen, wie eine Firma wie Siemens sich sowas leisten kann.
    Wisst ihr, wie schwer es ist, als Ingenieur bei Siemens anzufangen? Die Anzahl der Bewerbungen ist so überwältigend (was ja auch klar ist, wenn man bei Siemens arbeitet, hat man ausgesorgt), dass man sogar für einen Praktikumsplatz eine Vordiplomnote von 1,2 haben muss (!). Wie schwer es ist, an der Universität im Studiengang Elektrotechnik so einen Durchschnitt im VD zu bekommen, kann ich euch verraten. Es ist nahezu unmöglich. Man muss ein richtiger Genie sein und dazu noch die ganze Zeit ununterbrochen am Paucken sein. Gar ohne Freizeit, sogar am Wochenende. Um später von Siemens übernommen zu werden, muss man wahrscheinlich von diesen Praktikanten, die ja auch nicht alle genommen werden, sowas von überdurchschnitllich sein (man fragt sich natürlich, wie weit geht das noch), dass man so einem Mann vorsichtshalber schon einen Nobelpreis verleihen könnte.

    Spass beiseite. Es ist traurig und unvorstellbar, dass Siemens, der Laden mit den besten Fachkräften, die Deutschland zu bieten hat (zudem muss man bedenken, es werden überhaupt sehr wenig ET/IT Ingenieure "produziert", da die Studiengänge sehr schwierig seien). Ein Laden, der sich leisten kann, Creme de la Creme auszusuchen, es mit diesen Fachkräften nicht geschissen bekommt, das Mobilteil anständig zu bauen, bzw fehlerfreie Firmware zu liefern. Ich habe auf den Forum hier über die Probleme mit Siemens SL75 WLan gelesen. Dazu kommen noch die Abstürze bei Jabber. Neustart, wenn man die IP Adresse und irgendeine Einstellung ändert (neustart bei Linux ist sowieso ein Witz, besonders, um die Netzwerkänderungen zu übernehmen). Keine Möglichkeit, selbst eine Firmware zu bauen und die Fehler zu korrigieren. Die Sources werden zwar wegen GPL ausgeliefert, aber das sind die ganz normalen Sources, die man sowieso von den offiziellen Seiten runterlädt. Was nützen die, wenn überhaupt keine Dokumentation vorhanden ist.