[Gelöst] SmartNode 4552: Anmeldung an Asterisk

wuesten.fuchs

Neuer User
Mitglied seit
4 Sep 2008
Beiträge
72
Punkte für Reaktionen
0
Punkte
6
Hallo zusammen,

mein Smartnode 4552 ist an einem Asterisk angeschlossen und ist für mehrere MSNs zuständig. Eingehende und ausgehende Anrufe funktionieren mit dieser Konfiguration problemlos:

Asterisk:
Code:
[pstn_isdn]
type=peer
host=192.168.23.5
port=5060
fromuser=9218323
context=pstn_incoming

[pstn_fax]
type=peer
host=192.168.23.5
port=5060
fromuser=9218324
context=pstn_incoming
SmartNode:
Code:
authentication-service AUTH_SVC

location-service LOCATION_SVC

  identity-group default

    authentication outbound
      authenticate 1 authentication-service AUTH_SVC

    registration outbound
      register auto

    call outbound
Nun möchte ich gerne, dass sich der SmartNode am Asterisk anmeldet. Allerdings will genau das nicht so recht klappen - ausgehende Anrufe funktionieren weiterhin, ankommende Anrufe werden jedoch nicht zum Asterisk weiter geleitet. Im telnet-Debug bekomme ich folgende Fehlermeldung:
Code:
01:31:04  SIP_ER> [EP IF_SIP_ASTERISK-009e1d68 SES 0xe874e0] NO AUTHENTICATION CREDENTIALS FOUND. User: sip:[email protected]:5060, realm: asterisk
01:31:04  SIP_ER> NO ONGOING CLIENT TRANSACTION
Und im Webinterface des SmartNode steht "State: Registering", also ist er nicht registriert.

Hier die neue Asterisk-Konfiguration:
Code:
[pstn_isdn]
type=friend
host=192.168.23.5
secret=secretPassword
port=5060
fromuser=9218323
context=pstn_incoming

[pstn_fax]
type=friend
host=192.168.23.5
secret=secretPassword
port=5060
fromuser=9218324
context=pstn_incoming
Was muss ich am SmartNode (Firmware R5.3) einstellen, damit die Anmeldung klappt?

Hier die relevante SmartNode-Konfiguration, die derzeit nicht funktioniert:
Code:
authentication-service AUTH_SVC
  realm asterisk
  username pstn_fax password secretPassword

location-service LOCATION_SVC
  domain 1 example.com

  identity pstn_fax

    authentication outbound
      authenticate 1 authentication-service AUTH_SVC username pstn_fax

    registration outbound
      registrar example.com
      lifetime 10
      register auto
      retry-timeout on-system-error 10
      retry-timeout on-client-error 10
      retry-timeout on-server-error 10

    call outbound
 
Zuletzt bearbeitet:

sunseb

Neuer User
Mitglied seit
24 Aug 2005
Beiträge
59
Punkte für Reaktionen
0
Punkte
6
Hallo wuesten.fuchs,

zur weiteren Eingrenzung könntest du noch mal auf der Asterisk-Seite debuggen und schauen was dort "ankommt" und warum dieser das Register ablehnt.

Gruß,
Sebastian
 

sunseb

Neuer User
Mitglied seit
24 Aug 2005
Beiträge
59
Punkte für Reaktionen
0
Punkte
6
Hallo wuesten.fuchs,

funktioniert es jetzt?

Ich würde die Registrierung des Fax auf einen anderen Port legen:

Im asterisk:
[pstn_fax]
...
port=5064

Einen weiteren context sip-gateway mit interface im smartnode:
...
bind interface eth0 context router port 5064

Gruß,
Sebastian
 

wuesten.fuchs

Neuer User
Mitglied seit
4 Sep 2008
Beiträge
72
Punkte für Reaktionen
0
Punkte
6
Hallo sunseb,

bitte entschuldige die späte Antwort; Krankheit hat mich temporär außer Dienst gestellt.

Mittlerweile konnte ich den Fehler beheben. Hier die funktionierende Konfiguration:

sip.conf:
Code:
[pstn_isdn]
type = friend
host = 192.168.23.5
secret = secretPassword
port = 5060
fromuser = 9218323
context = pstn_incoming
qualify = yes
insecure = invite
Und die dazu passende SmartNode-Konfiguration:
Code:
authentication-service AUTH_SVC
  username pstn_isdn password secretPassword

location-service LOCATION_SVC
  domain 1 example.com 5060
  
  identity-group default
  
    registration outbound
      registrar 1 example.com 5060
      register auto
      
  identity pstn_isdn inherits default
  
    authentication outbound
      authenticate 1 authentication-service AUTH_SVC username pstn_isdn
SmartNode-Firmware des 4552 ist übrigens die R5.3.

Vielleicht hilft dieser Post ja jemandem, der mit ähnlichen Problemen zu kämpfen hat :)
 

wuesten.fuchs

Neuer User
Mitglied seit
4 Sep 2008
Beiträge
72
Punkte für Reaktionen
0
Punkte
6
Die vorige Konfiguration war falsch; hier ist die korrekte Version:

sip.conf:
Code:
[pstn_incoming]
secret = secretPassword
type = friend
host = dynamic
port = 5060
acl = local_phones
qualify = yes
insecure = port,invite
context = pstn_incoming
Patton SmartNode:
Code:
authentication-service AUTH_SVC
  username pstn_incoming password secretPassword

location-service LOCATION_SVC
  domain 1 sip1.example.com 5060
  
  identity-group default
  
    registration outbound
      registrar sip1.example.com 5060
      register auto
      lifetime 60
      retry-timeout on-system-error 10
      retry-timeout on-client-error 10
      retry-timeout on-server-error 10

    registration inbound
      lifetime default 60 min 1 max 3600
      
  identity pstn_incoming inherits default
  
    authentication outbound
      authenticate 1 authentication-service AUTH_SVC username pstn_incoming
  
    authentication inbound
      authenticate 1 authentication-service AUTH_SVC username pstn_incoming
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,759
Beiträge
2,038,051
Mitglieder
352,687
Neuestes Mitglied
NickNolte009