[Frage] snom 370 ldap

sascha45

Neuer User
Mitglied seit
4 Jun 2005
Beiträge
144
Punkte für Reaktionen
0
Punkte
0
hallo,
ich hab ein snom 370 aktuellste firmware und einen ldap server
nun möchte ich beide zusammen bringen - doch nur die eingabe der
serverdaten im telefon bringt keine erregung

server: df9xj.de
cn=admin, dc=domain, dc=de
ou=People, dc=domain, dc=de
password: ********* (kann zum test erfragt werden)

nun sollte es was anzeigen, doch nix kommt oder hab ich was vergessen?
auch wenn das interne telefonbuch gelöscht ist kommt nix

mit dem mailprogramm evolution und per php klappt der zugriff (lesen/schreiben) zur
ldap-datenbank. also sollte es da dran nicht liegen?!
gruß
alex
 
Zuletzt bearbeitet:

moshman

Neuer User
Mitglied seit
28 Mai 2009
Beiträge
72
Punkte für Reaktionen
0
Punkte
6
Hi,

ich habe es eingerichtet wie im Tutorial von Snom beschrieben (click).
Funktioniert einwandfrei.

Gruß
Thomas
 

sascha45

Neuer User
Mitglied seit
4 Jun 2005
Beiträge
144
Punkte für Reaktionen
0
Punkte
0
wäre schön wenn es ginge - hab mich auch ans tutorial gehalten. er fragt beim ldapkey nach dem namen und findet ihn dann nicht
 

moshman

Neuer User
Mitglied seit
28 Mai 2009
Beiträge
72
Punkte für Reaktionen
0
Punkte
6
Hi,

es geht also um LDAP mit TLS? Gut, das habe ich nicht, da bei mir alles durch einen OpenVPN-Tunnel läuft.
Vielleicht hilft Dir das das weiter.

Gruß
Thomas
 

sascha45

Neuer User
Mitglied seit
4 Jun 2005
Beiträge
144
Punkte für Reaktionen
0
Punkte
0
noch ohne TLS - mir scheint er nicht mit dem filter (|(cn=%)(sn=%)) bzw (&(telephonenumber=%)(sn=%)) klar zu kommen. habt ihr da anderes eingetragen?

nach der buchstaben eingabe kommt immer (no match) buchstabenkombi
 
Zuletzt bearbeitet:

moshman

Neuer User
Mitglied seit
28 Mai 2009
Beiträge
72
Punkte für Reaktionen
0
Punkte
6
Hi

vielleicht einfach testweise mal die Beispielkonfiguration von der Snom-Website probieren
LDAP name filter
(&(telephoneNumber=*)(sn=%)) --> Example 1
LDAP number filter
(&(telephoneNumber=%)(sn=*)) --> Example 2

LDAP Name Attributes
cn sn displayName --> Example 4
LDAP Number Atrributes
Mobile telephoneNumber ipPhone --> Example 5
LDAP display Name
%displayName --> Example 6

Meine ist z.B.
LDAP name filter
(&(telephoneNumber=*)(|(o=%)(sn=%)))
LDAP number filter
(&(telephoneNumber=%)(sn=*))

LDAP Name Attributes
cn sn o givenName

LDAP Number Atrributes
telephoneNumber

LDAP display Name
%sn, %givenName - %o


Gruß
Thomas
 

sascha45

Neuer User
Mitglied seit
4 Jun 2005
Beiträge
144
Punkte für Reaktionen
0
Punkte
0
alles durchprobiert - immer wieder NO MATCH
kann es sein, dass das snom ssh anfragen absetzt? der server unterstützt zur zeit kein ssh beim ldap?
 

sascha45

Neuer User
Mitglied seit
4 Jun 2005
Beiträge
144
Punkte für Reaktionen
0
Punkte
0
nun klappt es, woran es wirklich lag k.a. nach eingen resets macht es nun was es soll. danke für die hilfe.
als tip nochmal die config die nun geht:

ldap_search_filter!: (|(cn=%)(sn=%)(givenname=%)(displayName=%))
ldap_number_filter!:
(|(telephoneNumber=%)(homePhone=%)(otherPhone=%)(callbackPhone=%)(mobile=%))
ldap_name_attributes!: cn sn o givenName displayName
ldap_number_attributes!: telephoneNumber homePhone otherPhone callbackPhone
mobile
ldap_display_name!: %sn, %givenname, %displayName

und dazu im menu Präferenzen
Nummernanzeigestil: auf "name nummer"
 

sascha45

Neuer User
Mitglied seit
4 Jun 2005
Beiträge
144
Punkte für Reaktionen
0
Punkte
0
nächstes problem - bei anrufen wird der name nicht nachgeschlagen/angezeigt. any idea?
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,863
Beiträge
2,027,497
Mitglieder
350,977
Neuestes Mitglied
Neuer__User