.titleBar { margin-bottom: 5px!important; }

[SOLVED] Faxe empfangen mit capicommand(receivefax) - Die zweite

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von mcbastian, 13 Feb. 2007.

  1. mcbastian

    mcbastian Neuer User

    Registriert seit:
    6 Mai 2005
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 mcbastian, 13 Feb. 2007
    Zuletzt bearbeitet: 16 Feb. 2007
    Hallo,

    ich hab ein generelles problem damit. Kompilieren/starten etc. funktioniert.
    Das auftretende problem ist, Asterisk nimmt ab, und ich höre nur stille auf der leitung. nach dem hangup kann ich mich nicht mehr per "asterisk -r" mit dem asterisk verbinden (der header kommt kurz vor CLI (kommandozeile) hört er aber auf).
    Es hilft dann nur ein "killall -9 asterisk" (ohne -9 passiert auch nix)

    extensions.conf
    Code:
    
    [incoming]
    exten => 123155,1,Goto(handle_fax,s,1)
    
    [handle_fax]
    exten => s,1,SetVar(FAXFILE=/var/spool/asterisk/fax/${UNIQUEID})
    exten => s,n,capicommand(receivefax|${FAXFILE})
    exten => s,3,Hangup()
    exten => h,1,deadagi,fax.php|${FAXID} ${CALLERID} ${CHANNEL};
    
    Asterisk ist die 1.2.3 mit der chan_capi (version kann ich leider nicht sagen, die platte mit den sources ist neulich abgeraucht, im log steht:
    == Registered channel type 'CAPI' (Common ISDN API Driver ($Revision: 1.115 $) )

    ausgabe im log:
    Code:
    2007-02-13 15:50:39 VERBOSE[1309] logger.c:   == ISDN1: Setting up DTMF detector (PLCI=0x101, flag=1)
    2007-02-13 15:50:39 VERBOSE[1309] logger.c:   == ISDN1: Incoming call '036XXXXX132' -> '123155'
    2007-02-13 15:50:39 VERBOSE[1309] logger.c:     -- ISDN1: Updated channel name: CAPI/ISDN1/123155-5
    2007-02-13 15:50:39 VERBOSE[1403] logger.c:     -- Executing Goto("CAPI/ISDN1/123155-5", "handle_fax|s|1") in new stack
    2007-02-13 15:50:39 VERBOSE[1403] logger.c:     -- Goto (handle_fax,s,1)
    2007-02-13 15:50:39 VERBOSE[1403] logger.c:     -- Executing SetVar("CAPI/ISDN1/123155-5", "FAXFILE=/var/spool/asterisk/fax/1171378239.5") in new stack
    2007-02-13 15:50:39 VERBOSE[1403] logger.c:     -- Executing capiCommand("CAPI/ISDN1/123155-5", "receivefax|/var/spool/asterisk/fax/1171378239.5") in new stack
    2007-02-13 15:50:39 VERBOSE[1403] logger.c:   == ISDN1: Answering for 123155
    
    wie gesagt, auf der gegenseite (auch wenn ich dort ein faxgerät verwende, das den sync-beep schickt) kommt vom asterisk nur stille.

    Als hardware hab ich eine Diva Server PRI 23M.
    und die wird nitialisiert mit:
    Code:
    divactrl load -c 1 -f ETSI -n 4
    

    bin da etwas ratlos. mit der Answer(), rxFax()-kombi passiert das selbe.

    Gruß
    sebastien
     
  2. armincm

    armincm Aktives Mitglied

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    1,006
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das sieht alt aus. Nimm doch mal die aktuelle Version.

    Ein log mit
    set verbose 5
    capi debug
    wuerde auch helfen.

    Armin
     
  3. mcbastian

    mcbastian Neuer User

    Registriert seit:
    6 Mai 2005
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ah. das update hats gebracht :)

    hab nun neuesten asterisk der 1.2er serie und chan_capi_cm 1.0.0. jetzt erhalte ich den faxton und der asterisk hängt sich nicht mehr auf.

    werd es nun noch mit nem fax an der gegenseite testen, dem sollte aber nix mehr im wege stehen.

    danke. :)

    da es sich um ein produktivsystem handelt und ansonsten 100%ig läuft, bin ich mit updates immer etwas vorsichtig (never touch a running system und so ;-) )

    Gruß
    Sebastian