.titleBar { margin-bottom: 5px!important; }

[Gelöst] Telekom und kein ausgehender Call

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von astrakid, 30 Sep. 2011.

  1. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    #1 astrakid, 30 Sep. 2011
    Zuletzt bearbeitet: 1 Okt. 2011
    Hi,
    seit heute läuft mein Anschhluss komplett über IP. Der Speedport W723V funktioniert, einschließlich telefonie.

    wenn ich nun aber versuche, asterisk gegen die telekom zu registrieren, kann ich nicht rauswählen (reinwählen auch noch nicht, aber das kommt später).

    folgendes zeigt mir sip show peer telekom_ausgehend:

    Code:
      * Name       : telekom_ausgehend
      Secret       : <Set>
      MD5Secret    : <Not set>
      Remote Secret: <Not set>
      Context      : default
      Subscr.Cont. : <Not set>
      Language     : de
      AMA flags    : Unknown
      Transfer mode: open
      CallingPres  : Presentation Allowed, Not Screened
      FromUser     : 0231231231
      FromDomain   : tel.t-online.de Port 5060
      Callgroup    :
      Pickupgroup  :
      MOH Suggest  :
      Mailbox      :
      VM Extension : asterisk
      LastMsgsSent : 32767/65535
      Call limit   : 0
      Max forwards : 0
      Dynamic      : No
      Callerid     : "" <0231231231>
      MaxCallBR    : 384 kbps
      Expire       : -1
      Insecure     : port,invite
      Force rport  : Yes
      ACL          : No
      DirectMedACL : No
      T.38 support : No
      T.38 EC mode : Unknown
      T.38 MaxDtgrm: -1
      DirectMedia  : No
      PromiscRedir : No
      User=Phone   : No
      Video Support: No
      Text Support : No
      Ign SDP ver  : No
      Trust RPID   : No
      Send RPID    : No
      Subscriptions: Yes
      Overlap dial : Yes
      DTMFmode     : inband
      Timer T1     : 500
      Timer B      : 32000
      ToHost       : tel.t-online.de
      Addr->IP     : 217.0.17.90:5060
      Defaddr->IP  : (null)
      Prim.Transp. : UDP
      Allowed.Trsp : UDP
      Def. Username: hans.meier
      SIP Options  : 100rel
      Codecs       : 0x80c (ulaw|alaw|g726)
      Codec Order  : (alaw:20,g726:20,ulaw:20)
      Auto-Framing :  No
      100 on REG   : No
      Status       : Unmonitored
      Useragent    :
      Reg. Contact :
      Qualify Freq : 60000 ms
      Sess-Timers  : Accept
      Sess-Refresh : uas
      Sess-Expires : 1800 secs
      Min-Sess     : 90 secs
      RTP Engine   : asterisk
      Parkinglot   :
      Use Reason   : No
      Encryption   : No
    
    meine sip.conf:
    Code:
    [general]
    bindport=5070                   ; UDP Port to bind to (SIP standard port is 5060)
    bindaddr=0.0.0.0                ; IP address to bind to (0.0.0.0 binds to all)
    srvlookup=yes                   ; Enable DNS SRV lookups on outbound calls
    language=de
    disallow=all   ; First disallow all codecs
    allow=alaw
    allow=g726
    allow=ulaw
    
    maxexpirey=240                  ; Wichtig fuer T-Online
    defaultexpirey=600              ; Wichtig fuer T-Online, mindestens 240
    
    register => 0231231231:<meinPW>:[email protected]/231231
    
    subscribemwi=yes
    
    [11]
    callerid=0231231231
    nat=yes
    type=friend
    secret=11
    [email protected]
    host=dynamic
    context=eltern
    
    [telekom_ausgehend]
    type=peer
    authuser=hans.meier
    defaultuser=hans.meier
    username=hans.meier
    secret=<meinPW>
    host=tel.t-online.de
    callerid=0231231231
    fromdomain=tel.t-online.de
    fromuser=0231231231
    insecure=very,port,invite
    canreinvite=no
    nat=yes
    dtmfmode=inband
    ;sendrpid=no
    realm=tel.t-online.de
    
    extensions.conf:
    Code:
    [general]
    static=yes
    writeprotect=no
    priorityjumping=no
    autofallthrough=yes
    clearglobalvars=no
    
    [eltern]
    include => 0231231231
    include => 0800
    
    [0231231231]
    exten => 0231231231,1,Set(CALLERID(all)=${CALLERID(name)})
    exten => 0231231231,n,Dial(SIP/11,25,Ttr) ; incoming calls are redirected to SIP 
    exten => 0231231231,n,VoiceMail(231231,u)
    
    [0800]
    exten => _0800X.,1,Set(CALLERID(num)=0231231231)
    exten => _0800X.,n,NoOp("TEST-Anruf ueber Context 0800")
    exten => _0800X.,n,Dial(SIP/${EXTEN}@telekom_ausgehend)
    exten => _0800X.,n,Hangup
    
    mir ist klar, dass ich mit dieser extensions.conf nur eine 0800er nummer anrufen kann - zum testen reicht das aber allemal!

    anbieten kann ich noch bei bedarf ein debug-log... mir half das aber nicht gerade weiter...
    vielleicht kann mir ja hier shon jemand helfen.

    gruß und danke im voraus,
    astrakid
     
  2. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    #2 astrakid, 1 Okt. 2011
    Zuletzt bearbeitet: 1 Okt. 2011
    gelöst. die "hangups" sind natürlich überflüssig, hab ich bei meinem tunnelblick nicht beachtet. komisch, dass ich die da überhaupt reingesetzt habe... naja. jetzt gehts. ;-)