.titleBar { margin-bottom: 5px!important; }

Uhrzeit ständig falsch

Dieses Thema im Forum "FRITZ!Box Fon: Telefonie" wurde erstellt von silberfuchs, 28 Dez. 2008.

  1. silberfuchs

    silberfuchs Neuer User

    Registriert seit:
    27 März 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich habe folgende Ausstattung: 7270 inkl. 2x MT-C und 1x MT-D an einem Stollmann ISDN Adapter an einem Kabel Deutschland Telefon-Anschuss. Seit der Integration des MT-D habe ich ständig wieder eine falsche Uhrzeit und ein falsches Datum auf der Box -- so zuindest mein Gefühl. Kann das sein? Woher nimmt die Box Datum & Uhrzeit? Nach einem Nestart stimmt es wieder.....

    Danke für einen Tipp....
     
  2. chked

    chked IPPF-Promi

    Registriert seit:
    20 Nov. 2006
    Beiträge:
    4,187
    Zustimmungen:
    7
    Punkte für Erfolge:
    38
    Datum und Uhzeit lassen sich einigermassen präzise messen, "gefühlte" Zeit ist ein ziemlich schlechter Vergeleichsmassstab.
    Die Zeit nimmt die Box von einen NTP-Server, der zyklisch immer wieder abgefragt wird.
     
  3. silberfuchs

    silberfuchs Neuer User

    Registriert seit:
    27 März 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Sorry, war ein Mißverständnis - die Zeit ist wirklich falsch, z.B. 14.07.11 20:31Uhr an. Leider nicht nur die Telefone, sondern auch die Fritzbox selbst ....hab' auch schon einen Komplettreset gemacht - hilft nichts.
     
  4. loeben

    loeben IPPF-Promi

    Registriert seit:
    4 Okt. 2006
    Beiträge:
    4,263
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Systemarchitekt
    Ort:
    im sonnigen Süden
    Bessert sich das, wenn Du den MT-D wieder de-integrierst? Probier es doch bitte mal aus und berichte.
     
  5. silberfuchs

    silberfuchs Neuer User

    Registriert seit:
    27 März 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe es gerade nochmals getestet - macht keinen Unterschied, ob das MT-D angemeldet ist oder nicht - muss wohl am Stollmann ISDN Adapter liegen.....
     
  6. wollet42

    wollet42 Neuer User

    Registriert seit:
    5 Aug. 2005
    Beiträge:
    95
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Aachen
    #6 wollet42, 28 Dez. 2008
    Zuletzt bearbeitet: 28 Dez. 2008
    Hallo,
    ich hab ne 7270 ohne dect Telefone, bei mir ist die Uhrzeit auch immer falsch seit dem letzten Firmware update.

    Ich hab mal versucht manuell auf der box mit date die Zeit zu setzten mit einem erstaunlichen Ergebniss.
    Code:
    # date -s 20081228
    Sat Aug  8 12:28:00 CEST 2020
    
    Die Busybox setzt die Uhrzeit falsch.

    Da ich eine ge-freetzte Box habe, würde es mich mal interessieren ob auf einer original AVM der dater Befehl das gleiche liefert.

    Gruss,
    Wolle

    [edit]
    hab nochwas getestet: nach reboot ist die Uhrzeit der fritz wieder ok, jedoch hab ich auf dem ISDN phones totalen Quatsch drauf.

    Wo wird denn die Zeit auf dem S0 hergeholt, von der Fritz Systemzeit?

    Vielleicht liegt es bei mir auch an der Umstellung auf DSL only (ist etwa Zeitgleich erfolgt wie das Firmware update und das auftauchen der Probleme)
     
  7. silberfuchs

    silberfuchs Neuer User

    Registriert seit:
    27 März 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ...kann ich den Befehl auch "absetzen" mit einer Originalbox? Wenn ja, was muss ich tun?

    Ich nutze die Box ja hinter meinem Kabelmodem ....
     
  8. wollet42

    wollet42 Neuer User

    Registriert seit:
    5 Aug. 2005
    Beiträge:
    95
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Aachen
    über telnet einloggen, dann gehts
     
  9. frank_m24

    frank_m24 IPPF-Urgestein

    Registriert seit:
    20 Aug. 2005
    Beiträge:
    17,571
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Niederrhein
    Hallo,

    nee, die Box setzt die Zeit nicht falsch, dein Befehl war falsch:
    Code:
    Usage: date [OPTION]... [+FMT] [TIME]
    
    Display time (using +FMT), or set time
    
    Options:
            -u              Work in UTC (don't convert to local time)
            -R              Output RFC-822 compliant date string
            -I[SPEC]        Output ISO-8601 compliant date string
                            SPEC='date' (default) for date only,
                            'hours', 'minutes', or 'seconds' for date and
                            time to the indicated precision
            -d TIME         Display TIME, not 'now'
            -r FILE         Display last modification time of FILE
            [-s] TIME       Set time to TIME
            -D FMT          Use FMT for str->date conversion
    
    Recognized formats for TIME:
            hh:mm[:ss]
            [YYYY.]MM.DD-hh:mm[:ss]
            YYYY-MM-DD hh:mm[:ss]
            MMDDhhmm[[YY]YY][.ss]
    
     
  10. silberfuchs

    silberfuchs Neuer User

    Registriert seit:
    27 März 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ...bei mir gibt er folgendes aus:

    # date -s 20081228
    Wed Aug 8 12:28:00 CEST 2012
    # Aug 8 12:28:00 telefon[1153]: set initial telefon time from linux time to 12:
    28 8.08 2012!
    # date -s 20081228
    Thu Aug 8 12:28:00 CEST 2013
    # Aug 8 12:28:00 telefon[1153]: set initial telefon time from linux time to 12:
    28 8.08 2013!

    ...wie lautet dennn der richtige Befehl - kann mir jemand helfen?
     
  11. frank_m24

    frank_m24 IPPF-Urgestein

    Registriert seit:
    20 Aug. 2005
    Beiträge:
    17,571
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Niederrhein
    Hallo,

    mit "date -s 122820282008.30" setzt die Box die Uhrzeit brav auf den 28.12.2008 20:28 und 30 Sekunden. ;)
     
  12. wollet42

    wollet42 Neuer User

    Registriert seit:
    5 Aug. 2005
    Beiträge:
    95
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Aachen
    uups, du hast recht.

    Allerdings nimmt sie nur das Format an MMDDhhmmYYYY

    Bei einigen anderen Formaten krieg ich Fehlermeldungen, oder mach ich die auch falsch?

    Code:
    # date -s 2008-12-28 20:36
    BusyBox v1.12.3 (2008-12-20 18:36:15 CET) multi-call binary
    
    Usage: date [OPTION]... [+FMT] [TIME]
    ...
    
    # date -s 1228203008
    date: invalid date '1228203008'
    
    #date 2008.12.28-20:39
    Sun Dec 28 20:39:00 CET 2008
    
    
    Naja, scheint ja zu gehen.

    Bleibt aber noch der Quatsch auf dem S0, irgendwelche ideen?

    Gruss,
    Wolle
     
  13. frank_m24

    frank_m24 IPPF-Urgestein

    Registriert seit:
    20 Aug. 2005
    Beiträge:
    17,571
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Niederrhein
  14. wollet42

    wollet42 Neuer User

    Registriert seit:
    5 Aug. 2005
    Beiträge:
    95
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Aachen
    Danke für den Tipp.

    Ich hab ich mal beim Support nachgefragt, ich werde die Antwort hier posten.

    Gruss,
    Wolle

    PS workaround zum Uhrstellen hab ich hier gepostet: link
     
  15. frank_m24

    frank_m24 IPPF-Urgestein

    Registriert seit:
    20 Aug. 2005
    Beiträge:
    17,571
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Niederrhein
  16. wollet42

    wollet42 Neuer User

    Registriert seit:
    5 Aug. 2005
    Beiträge:
    95
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Aachen
    komisch.

    Da silberfuchs das Problem ja auch hat und er kein Freetz nutzt (jedenfalls laut Signatur) hab ich auf AVM getippt.
     
  17. frank_m24

    frank_m24 IPPF-Urgestein

    Registriert seit:
    20 Aug. 2005
    Beiträge:
    17,571
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Niederrhein
    Hallo,

    es ist bislang nur eine Vermutung. Auch im Freetz Bereich wurde schon der Verdacht geäußert, es könnte ein AVM Problem sein. Ein "Nicht-Freetz-Nutzer" mit dem Problem könnte ein guter Beweise sein. ;)
     
  18. silberfuchs

    silberfuchs Neuer User

    Registriert seit:
    27 März 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #18 silberfuchs, 29 Dez. 2008
    Zuletzt bearbeitet: 29 Dez. 2008
    Meine Signatur stimmt .... :) Ich habe die Anleitung von AVM probiert - funktioniert problemlos, die Uhrzeit ist sofort wieder aktuell - nach dem ersten Telefonat jedoch wieder falsch .....
     
  19. wollet42

    wollet42 Neuer User

    Registriert seit:
    5 Aug. 2005
    Beiträge:
    95
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Aachen
    #19 wollet42, 30 Dez. 2008
    Zuletzt bearbeitet: 30 Dez. 2008
    Hi,
    hier die Antwort von AVM auf meine Anfrage:
    Code:
    Sehr geehrter Herr ...,
    
    vielen Dank für Ihre Anfrage.
    
    ISDN-Endgeräte beziehen Ihre Uhrzeit und das Datum aus dem ISDN-Festnetz.
    Sofern Ihnen kein ISDN-Signal mehr am Anschluss direkt zur Verfügung steht,
    erkundigen Sie sich bitte direkt bei 1 & 1, ob eine anderweitige Lösung
    möglich ist. Die FRITZ!Box selbst bezieht Ihre Uhrzeit aus dem Internet und
    kann diese am S0-Bus nicht selbst zur Verfügung stellen.
    
    Mit freundlichen Grüßen aus Berlin
    Das kann ich kaum glauben, da es ja möglich ist die Uhrzeit manuell via Telefon in der Fritzbox zu ändern und diese Zeit wird dann auf die ISDN Telefone übertragen.
    Ich hake nochmal nach.
     
  20. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Die Box bezieht ihre Zeit aus dem Internet und kann diese Zeit sehr wohl auf dem internen S0-Bus zur Verfügung stellen.