.titleBar { margin-bottom: 5px!important; }

USB Fernanschluss; lästiges "RunAs" Fenster beim Start & Drucker "merken"

Dieses Thema im Forum "AVM-Software" wurde erstellt von frankyx, 30 Nov. 2008.

  1. frankyx

    frankyx Neuer User

    Registriert seit:
    31 Mai 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen,

    ich habe gerade meinen HP PSC1100 über USB an meine FritzBox angeschlossen und die Software für den USB-Fernzugang installiert. Soweit funktioniert alles wunderbar ich kann scannen & drucken.
    Allerdings gibt es 2 Dinge die mich stören:
    1. Wenn der User eingeschränkte Rechte hat kommt bei Neustart ein Fenster mit der Frage unter welchem User die Software laufen soll. Die Antwort ist aber egal. :confused:
    2. Nach dem Neustart ist der Drucker erst mal nicht verbunden. Man muss Ihn erst anklicken.:cry:



    zu Punkt 1:
    Ist anderen auch schon aufgefallen. Ich habe allerdings keine Lösung finden können. Gibts dazu was Neues? Hat jemand inzwischen eine Lösung wie man das Fenster unterdrückt?

    zu Punkt 2:
    Dazu hab ich im Forum noch nichts gelesen. Hat da jemand einen Tipp?

    Besten Dank für die Hilfe!

    Gruß,
    Franky X.


    FRITZ!Box Fon WLAN 7141 (UI)
    Firmware-Version 40.04.59
     
  2. unawave

    unawave Neuer User

    Registriert seit:
    2 Juni 2005
    Beiträge:
    176
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Das Problem besteht wohl darin, daß beim Start des USB-Fernanschluss quasi eine neue Hardware installiert wird (neuer USB-Anschluß) - und das darf wohl ein Benutzer mit eingeschränkten Rechten nicht.

    Ich habe folgende Lösung umgesetzt:
    Man kann beliebige Programme als "Dienste" starten. Und wenn man das Programm "fritzbox-usb-fernanschluss.exe" als Systemdienst startet, dann wird es sogar mit höheren Rechten als "Administrator" gestartet (System-Dienst) und es wird sofort beim PC-Start gestartet.

    Das Programm "fritzbox-usb-fernanschluss.exe" befindet sich recht versteckt unter:
    "C:\Dokumente und Einstellungen\<user>\Lokale Einstellungen\Apps\2.0\D2EWWK5X.0AQ\7G41CWXV.YKC\frit..tion_f8d772dfbb3f7453_0002.0001_0db5bf149dd7a141\fritzbox-usb-fernanschluss.exe"

    Ich habe den ganzen Ordner, in dem "fritzbox-usb-fernanschluss.exe" liegt, in den Ordner "C:\Programme\" kopiert und diesem Ordner den Namen "fritzbox-usb-fernanschluss" gegeben - damit nicht noch irgendwelche Konflikte mit den Benutzer-Rechten entstehen. Das Programm "fritzbox-usb-fernanschluss.exe" befindet sich dann auf meinem PC unter:
    C:\Programme\fritzbox-usb-fernanschluss\fritzbox-usb-fernanschluss.exe

    Dann sollte sich der Dienst mit folgender reg-Datei installieren lassen:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\FritzBox-USB-Fernanschluss]
    "Description"="Startet den FritzBox USB-Fernanschluss als Systemdienst"
    "Type"=dword:00000110
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\FritzBox-USB-Fernanschluss\Parameters]
    "Application"="\"C:\\Programme\\fritzbox-usb-fernanschluss\\fritzbox-usb-fernanschluss.exe\""
    "AppDirectory"="\"C:\\Programme\\fritzbox-usb-fernanschluss\\\""
    Nach einem Neustart sollte der Dienst "FritzBox-USB-Fernanschluss" in der Dienste-Liste von Windows auftauchen.

    Genaueres zum installieren von Programmen als Dienste findet man hier.

    Dazu habe ich keine Lösung. Wenn man mehrere PCs in einem Netzwerk hat, macht das auch keinen Sinn. Denn dann würden sich ja alle PCs beim Start mit dem Drucker verbinden wollen. Und bei USB-Fernanschluss geht ja immer nur ein aktiver.
     
  3. frankyx

    frankyx Neuer User

    Registriert seit:
    31 Mai 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo unaware,

    besten Dank fuer die super Lösung. Der Trick mit srvany.exe hat auch bei mir funktioniert.

    Zum Problem2:
    In meinem Netzwerk sind halt selten 2 Rechner gleichzeitig aktiv und meine Freundin ist sehr unerfahren mit dem PC. Da wäre es schon praktisch wenn sich der USB-Fernanschluss automatisch verbindet. Sie hat Schichtdienst und dadurch bin ich oft nicht zu Hause wenn Sie am Rechner arbeitet. => kein unmittelbarer Support möglich.

    Aber nochmals vielen Dank für die Lösung für Problem1!
    Das hilft mir schon mal enorm weiter.

    Gruß,
    Frank
     
  4. KuniGunther

    KuniGunther Aktives Mitglied

    Registriert seit:
    8 Juni 2005
    Beiträge:
    2,187
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Zu Punkt 2:

    Wenn Du im geöffneten USB-Fernanschluss-Fenster einen Rechtsklicks auf den Drucker machst, dann solltest Du die Optionen "Verbinden", "Trennen", und "Autostart" haben. Hast Du es schon mal versucht Autostart zu aktivieren?
     
  5. unawave

    unawave Neuer User

    Registriert seit:
    2 Juni 2005
    Beiträge:
    176
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Soweit ich mich erinnere führt die "Autostart"-Funktion nur dazu, daß das Programm automatisch gestartet wird - aber nicht, daß automatisch mit dem USB-Endgerät verbunden wird. Und beim automatischen Start des Programmes hatte ich festgestellt, daß bei einem Benutzer mit eingeschränkten Rechten einfach "nichts" passiert. Selbst diese Meldung von "frankyx" erschien bei mir nicht:

    Ich glaube auch, daß das automatische Verbinden schwieriger ist. Denn schließlich könnten am USB-Fernanschluß auch mehrere USB-Endgeräte angeschlossen sein (über einen USB-Hub). Mit welchem Gerät sollte dann verbunden werden? Oder was ist, wenn gar kein Endgerät angeschlossen ist - wenn z.B. das USB-Endgerät ausgeschaltet ist?
     
  6. KuniGunther

    KuniGunther Aktives Mitglied

    Registriert seit:
    8 Juni 2005
    Beiträge:
    2,187
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Du sollst Dich nicht erinnern, sondern einfach das ausprobieren, was ich beschrieben habe!

    Es gibt zwei Autostart-Funktionen! Das "Autostart", welches Du meinst, ist über einen Rechtklick auf das Taskbar-Symbol zu erreichen. Es gibt aber noch ein gerätespezifisches, welches beim Rechtsklick auf das Gerätesymbol im rechten Panel bei geöffnetem Programmfenster selektiert werden kann. Unter dem entsprechenden Gerät erscheint dann die Schrift "Autostart". Dieses Autostart bewirkt, dass bei Programmstart das Gerät automatisch verbunden wird.

    Genau das Gerät, für das Du die Option aktiviert hast.
     
  7. frankyx

    frankyx Neuer User

    Registriert seit:
    31 Mai 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Volker,

    vielen Dank für den Hinweis. Hab es ausprobiert, und es funktioniert!
    Das ist ja super!
    Beste Grüsse aus München,
    FrankyX
     
  8. tourani

    tourani Neuer User

    Registriert seit:
    22 Juni 2013
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #8 tourani, 22 Juni 2013
    Zuletzt bearbeitet: 22 Juni 2013
    Auch wenn diese Beiträge schon etwas älter sind, bin ich doch heute erst darauf gestoßen. Ich habe nämlich das selbe leidige Problem gehabt, bei jedem Start des Rechners kam die lästige Frage nach den Admin-Rechten.
    Ich habe daraufhin versucht, wie oben beschrieben, die Anwendung als Dienst zu installieren. Da ich aber wahrscheinlich eine andere Windows-Version verwende (Windows 7 Home Premium 32 Bit), funktionierte das leider alles nicht.
    Ich habe aber in einem anderen Foren-Beitrag einen anderen Lösungsweg gefunden.
    Zwar hat auch der nicht 100%ig funktioniert, hat mir aber weiter geholfen.
    Zusammen mit dem Hinweis aus einem anderen Forum
    Code:
    @echo off
    taskkill /F /IM sidebar.exe > NUL
    start "" "C:\Program Files (x86)\Windows Sidebar\sidebar.exe"
    
    und dem Lösungsansatz von hier habe ich dann folgenden funktionierenden Code gebastelt:
    Code:
    @echo off
    set __COMPAT_LAYER=RunAsInvoker
    start "" "C:\Program Files\fritzbox-usb-fernanschluss\fritzbox-usb-fernanschluss.exe"
    
    Vielleicht hilft es ja dem ein oder anderen!