.titleBar { margin-bottom: 5px!important; }

USB Headset plantronics .audio 45 unter SuSE Linux 9.2

Dieses Thema im Forum "Andere Software/Hardware" wurde erstellt von schuelsche, 1 März 2005.

  1. schuelsche

    schuelsche Neuer User

    Registriert seit:
    22 Dez. 2004
    Beiträge:
    46
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich habe ein Plantronics Headset Audio 45, auch mit integrierter USB-Soundkarte.

    Ich habe das Headset über die USB-Schnittstelle an meinen Rechner mit SuSE 9.2 angeschlossen. Über "tail -f /var/log/messages" bekomme ich auch folgende Meldung:
    Code:
    kernel: usb 1-2: new full speed USB device using address 4
    kernel: usb 1-2: Product: Plantronics Headset
    kernel: usb 1-2: Manufacturer: Plantronics
    kernel: usb 1-2: SerialNumber: 00050-0504044410003-V060000D
    kernel: evdev_connect: evdev cdff67a0 handle cdff67bc name event4
    kernel: input: USB HID v1.00 Device [Plantronics Plantronics Headset] on usb-0000:00:1f.2-2
    kernel: ALSA sound/usb/usbaudio.c:1182: current rate 0 is different from the runtime rate 48000
    kernel: ALSA sound/usb/usbaudio.c:1182: current rate 0 is different from the runtime rate 48000
    kernel: usbcore: registered new driver snd-usb-audio
    
    Ein usbview zeigt mir an:
    Code:
    UHCI Host Controller
    Plantronics 
    
    Plantronics Headset
    Manufacturer: Plantronics
    Serial Number: 00050-0504044410003-V060000D
    Speed: 12Mb/s (full)
    USB Version:  1.10
    Device Class: 00(>ifc )
    Device Subclass: 00
    Device Protocol: 00
    Maximum Default Endpoint Size: 8
    Number of Configurations: 1
    Vendor Id: 047f
    Product Id: 0ca1
    Revision Number:  0.04
    
    Config Number: 1
    Number of Interfaces: 4
    Attributes: 80
    MaxPower Needed: 100mA
    
    Interface Number: 0
    Name: snd-usb-audio
    Alternate Number: 0
    Class: 01(audio) 
    Sub Class: 1
    Protocol: 0
    Number of Endpoints: 0
    
    Interface Number: 1
    Name: snd-usb-audio
    Alternate Number: 0
    Class: 01(audio) 
    Sub Class: 2
    Protocol: 0
    Number of Endpoints: 0
    
    Interface Number: 1
    Name: snd-usb-audio
    Alternate Number: 1
    Class: 01(audio) 
    Sub Class: 2
    Protocol: 0
    Number of Endpoints: 1
    
    Endpoint Address: 01
    Direction: out
    Attribute: 9
    Type: Isoc
    Max Packet Size: 100
    Interval: 1ms
    
    Interface Number: 1
    Name: snd-usb-audio
    Alternate Number: 2
    Class: 01(audio) 
    Sub Class: 2
    Protocol: 0
    Number of Endpoints: 1
    
    Endpoint Address: 01
    Direction: out
    Attribute: 9
    Type: Isoc
    Max Packet Size: 200
    Interval: 1ms
    
    Interface Number: 2
    Name: snd-usb-audio
    Alternate Number: 0
    Class: 01(audio) 
    Sub Class: 2
    Protocol: 0
    Number of Endpoints: 0
    
    Interface Number: 2
    Name: snd-usb-audio
    Alternate Number: 1
    Class: 01(audio) 
    Sub Class: 2
    Protocol: 0
    Number of Endpoints: 1
    
    Endpoint Address: 84
    Direction: in
    Attribute: 9
    Type: Isoc
    Max Packet Size: 50
    Interval: 1ms
    
    Interface Number: 2
    Name: snd-usb-audio
    Alternate Number: 2
    Class: 01(audio) 
    Sub Class: 2
    Protocol: 0
    Number of Endpoints: 1
    
    Endpoint Address: 84
    Direction: in
    Attribute: 9
    Type: Isoc
    Max Packet Size: 100
    Interval: 1ms
    
    Interface Number: 2
    Name: snd-usb-audio
    Alternate Number: 3
    Class: 01(audio) 
    Sub Class: 2
    Protocol: 0
    Number of Endpoints: 1
    
    Endpoint Address: 84
    Direction: in
    Attribute: 9
    Type: Isoc
    Max Packet Size: 200
    Interval: 1ms
    
    Interface Number: 3
    Name: usbhid
    Alternate Number: 0
    Class: 03(HID  ) 
    Sub Class: 0
    Protocol: 0
    Number of Endpoints: 1
    
    Endpoint Address: 83
    Direction: in
    Attribute: 3
    Type: Int.
    Max Packet Size: 2
    Interval: 3ms
    

    Unter kcontrol wird mir unter Sound die Soundkarte nicht angezeigt. Ebensowenig in Yast unter Sound. Auch gibt es dort nicht die Möglichkeit, ein Produkt von plantronics zu installieren.

    Da ich normalerweise kein KDE benutze, habe ich die Soundkarte einfach eingesteckt, als waimea lief. Da läuft natürlich keine automatische Hardwareerkennung. Habe dann KDE gestartet und die Soundkarte wieder eingesteckt, aber da kam dann keine Hardwareerkennung mehr, wie das wohl normalerweise der Fall sein sollte...

    Jetzt bin ich etwas ratlos, weil ich keine Ahnung habe, wie ich nun auf das Device zugreifen soll...

    Kann mir da jemand weiterhelfen und sagen, wie ich die Karte konfiguriert bzw. angesprochen bekomme? Muss doch irgendein device sein unter /dev/..., das ich da jetzt ansprechen müsste?!

    Grüsse
    schuelsche