.titleBar { margin-bottom: 5px!important; }

Verbindungsprobleme - Portweiterleitung

Dieses Thema im Forum "FRITZ!Box Fon: DSL, Internet und Netzwerk" wurde erstellt von mk401, 8 Jan. 2009.

  1. mk401

    mk401 Neuer User

    Registriert seit:
    18 Sep. 2007
    Beiträge:
    30
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo

    Ich versuche seit einiger Zeit eine Asterisk auf einer Fritzbox 7170 zum laufen zu bringen. Dank diverser Foren-Beiträge läuft die Anlage auch, allerdings nur im Testbetrieb.
    Im Augenblick habe ich noch zwei Probleme.
    1. Anrufe von Aussen nicht möglich
    2. Bei Anruf nach aussen hört der Anrufer nicht den Angerufenen

    Ich nehme mal an, dass beide Probleme damit zusammenhängen, dass ich in meiner Fritzbox noch keine Portweiterleitung eingerichtet habe.
    Ich habe meinen Bindport auf 5061 eingestellt, da ich annehme, dass die Fritzbox den Port 5060 für sich beansprucht. Auch die RTP Ports habe ich nocht nicht freigeschaltet.

    Nun meine Frage: Die Fritzbox verweigert eine Weiterleitung auf die eigene IP Adresse (192.168.178.1)
    Igendwo habe ich gelesen, dass man der Fritzbox eine weitere IP Addresse zuweisen kann (debug.cfg) und dass man dieses vor dem Asterisk eintragen müsse. Da in meiner debug.cfg allerdings nur der Restart der Asterisk eingetragen ist, weiss ich nicht, wo das sein könnte.

    Hat jemand eine Idee, oder die geschilderten Probleme selbst schon mal gelöst?

    Wäre echt dankbar für jede Hilfe

    Liebe Grüße

    Martin
     
  2. chked

    chked IPPF-Promi

    Registriert seit:
    20 Nov. 2006
    Beiträge:
    4,186
    Zustimmungen:
    7
    Punkte für Erfolge:
    38
    Die Einrichtung einer weiteren IP geht mit dem Befehl ifconfig.

    Code:
    ifconfig eth0:1 192.168.178.2 netmask 255.255.255.0 broadcast 192.168.178.255 up
    
    Diese Zeile fügst du einfach in der debug.cfg vor dem Asterisk-Start ein.
     
  3. birnenkind

    birnenkind Mitglied

    Registriert seit:
    28 Apr. 2007
    Beiträge:
    222
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hoi,

    oder in der ar7.cfg von hand auf die fritzIP eintragen, sollte auch funktionieren.....

    gruessle
     
  4. mk401

    mk401 Neuer User

    Registriert seit:
    18 Sep. 2007
    Beiträge:
    30
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo

    Schon mal vielen Dank, hat prima geklappt, zumindest habe ich mein Problem Nr.2 gelöst.

    Könnt ihr mir jetzt noch verraten, wie ich meine Anlage dazu bekomme, von außen errieichbar zu sein?
    Wie bekomme ich den 1und1 SIP Server dazu, mit meiner Asterisk auf einem anderen Port als 5060 zu kommunizieren.

    Vielen Dank

    Martin