Verstehen von Sipuras Log-Meldungen

jrrp

Mitglied
Mitglied seit
21 Mrz 2004
Beiträge
356
Punkte für Reaktionen
0
Punkte
0
Hallo!

Eigentlich kann ich wunderbar telefonieren. Beim Spielen mit Rufumleitungen habe ich ins Log reingeguckt, und der SPA meckert ab und zu. Es tut mir weh, dass ich ihn nicht verstehe :wink:

Im Ernst, vielleicht könnte man mit Hilfe der Experten hier eine Art FAQ oder Liste der wichtigsten Meldungen des SPA zusammenstellen. Ich fang mal an und dann folgen meine Fehlermeldungen:

Registrierung beim VoIP-Provider:
REGISTER sip:sipgate.de ...

NAT-Keepalive vom SPA an VoIP-Provider:
NOTIFY sip:proxy.de.sipgate.net SIP/2.0 ...

STUN-Befehle
[1]REG: STUN XXXXXXXX->YYYYYYYY, 5060->5060
[5060]STUN trying 0

Meine Errors sind (ohne Code-Formatierung, weil kurz):

SIP/2.0 403 Forbidden<013><010>Via: SIP/2.0/UDP 83.136.32.162:5065;branch=XXX-XXX,SIP/2.0/UDP IP:5061;branch=XXX-XXX<013><010>From: XXX <sip:[email protected]>;tag=XXX<013><010>To: <sip:nat.at43.at>;tag=XXX<013><010>Call-ID: [email protected]<013><010>CSeq: 3 NOTIFY<013><010>Warning: PPC at 83.136.32.162:5060 -- Access to nat.at43.at not allowed for this client.<013><010>Content-Length: 0

(83.136.32.162 = nat.at43.at)

SIP/2.0 500 I'm terribly sorry, server error occured (2/TM)<013><010>Via: SIP/2.0/UDP IP:5060;branch=XXX-XXX<013><010>From: XXX <sip:[email protected]>;tag=XXX<013><010>To: <sip:sipgate.de>;tag=XXX<013><010>Call-ID: [email protected]<013><010>CSeq: 35 NOTIFY<013><010>Server: Sip EXpress router (0.8.12-tcp_nonb (i386/linux))<013><010>Content-Length: 0<013><010>Warning: 392 217.10.79.9:5060 "Noisy feedback tells: pid=8431 req_src_ip=217.10.79.9 req_src_port=5060 in_uri=sip:sipgate.de out_uri=sip:sipgate.de via_cnt==34"

(217.10.79.9 = sipgate.de)

Zur Zeit keine Weiterleitungen. Irgendwas habe ich falsch eingestellt, aber was? Beide Regsitrierungen bei Sipgate und at43.at sind OK. Übrigens registriert sich der SPA alle 80 sec bei at43.at, obwohl ich das Intervall auf 3600 sec eingestellt habe...

Vielen Dank im Voraus!
jrrp
 

exim

Admin a.D.
Mitglied seit
27 Apr 2004
Beiträge
1,013
Punkte für Reaktionen
0
Punkte
0
Du könntest mal bei den nächsten Posting die über den Meldungen befindlichen Pfeile wie z.B. "spa [0:5060]<<63.214.186.6:5060" mit reinsetzen denn die zeigen, in welche Richtung die Meldung lief.

Die Erklärungen stehen ja eigentlich da:
403 Forbidden - der nat.at43.at mag Dich nicht :wink:
500 Server Error - Sipgate-Problem

Über ein FAQ auf dem Board wird ja gerade nachgedacht und Verweise auf die Doku des SIP-Protokolls (RFCs etc.) werden da mit Sicherheit auch dabei sein. Ich werde mich dann mal an ein paar Sipura-Sachen heranmachen ...

Gruß,
Exim
 

Robinson

Aktives Mitglied
Mitglied seit
24 Mrz 2004
Beiträge
1,751
Punkte für Reaktionen
0
Punkte
0
Aber is schon niedlich, das SIP-Protokoll: "I'm terribly sorry, ..."
 

jrrp

Mitglied
Mitglied seit
21 Mrz 2004
Beiträge
356
Punkte für Reaktionen
0
Punkte
0
exim schrieb:
Du könntest mal bei den nächsten Posting die über den Meldungen befindlichen Pfeile wie z.B. "spa [0:5060]<<63.214.186.6:5060" mit reinsetzen denn die zeigen, in welche Richtung die Meldung lief.
Mache ich doch gerne:

[1:5061]<<83.136.32.162:5060
und dann
SIP/2.0 403 Forbidden<013><010>Via: SIP/2.0/UDP 83.136.32.162:5065
[...] Warning: PPC at 83.136.32.162:5060 -- Access to nat.at43.at not allowed for this client.

sowie

[0:5060]<<217.10.79.9:5060
und dann
SIP/2.0 500 I'm terribly sorry, server error occured

exim schrieb:
Die Erklärungen stehen ja eigentlich da:
403 Forbidden - der nat.at43.at mag Dich nicht :wink:
500 Server Error - Sipgate-Problem
Na ja, [pingelig start] Da steht eher, was passiert, und nicht warum [/pingelig end]. Ich würde gerne verstehen, warum der NAT-Server von at43.at mich nicht mag (obwohl sich der SPA registrieren kann) und woher der Sipgate Fehler kommt, der den SPA so traurig macht :wink:
Es scheinen aber eingehende Verbindungen zu sein, oder?

Robinson schrieb:
Aber is schon niedlich, das SIP-Protokoll
Umso schlimmer, dass ich sie nicht verstehe, es bricht mir das Herz :wink:

Gruß & Dank, jrrp
 

exim

Admin a.D.
Mitglied seit
27 Apr 2004
Beiträge
1,013
Punkte für Reaktionen
0
Punkte
0
Der SIP Express Router (den nutzt Sipgate) sagt auch nicht "100 Trying" sondern "100 Trying - Your call is important to us" :) Aber entscheidend sind die Nummern der Statusmeldungen und diese sind wie das gesamte SIP an http angelehnt:

[edit, aktueller RFC]
http://www.ietf.org/rfc/rfc3261.txt?number=3261
[/edit]

403 Forbidden
The server understood the request, but is refusing to fulfill it. Authorization will not help, and the request SHOULD NOT be repeated.

500 Server Internal Error
The server encountered an unexpected condition that prevented it from fulfilling the request. The client MAY display the specific error condition, and MAY retry the request after several seconds.

Du kannst nur prüfen, ob von Deiner Seite alles in Ordnung ist, z.B. bei der 403 ob Du überhaupt registriert bist (bist Du ja, wie Du schreibst). Wenn bei Dir alles ok ist kennt die Gründe dann wohl nur der Provider, wobei ich bei Sipgate manchmal selbst daran zweifle.

jrrp schrieb:
Übrigens registriert sich der SPA alle 80 sec bei at43.at, obwohl ich das Intervall auf 3600 sec eingestellt habe...
Der vom Client gesetzte Registrierungsintervall ist nur ein Vorschlag, die letztendliche Entscheidung trifft der Reg.server.
 

jrrp

Mitglied
Mitglied seit
21 Mrz 2004
Beiträge
356
Punkte für Reaktionen
0
Punkte
0
Vielen Dank! Ich werde mal a bissal warten und schauen, wie sich die Fehlermeldungen am Wochenende entwickeln. Plötzlich mag mich der nat.at43.at wieder :) Dafür bekomme ich eine Meldung "404 User not found - no voice mail available" (AT43 hat eine Voice-Mailbox). Vielleicht muss ich einfach die AT43-Menschen anmailen - schließlich ist die eine Fehlermeldung weg und die andere da ohne mein Zutun...

Das RFC2543 habe ich mir schon als Gute-Nacht-Lektüre runtergeladen :wink:

Gruß, jrrp
 

jrrp

Mitglied
Mitglied seit
21 Mrz 2004
Beiträge
356
Punkte für Reaktionen
0
Punkte
0
exim schrieb:
Sorry, der aktuelle SIP-RFC scheint der 3261 zu sein, der hat als Kommentar u.a. "Obsoletes: 2543".
mensch, da habbich gestern nacht das veraltete papier gelesen :wink:
 

jrrp

Mitglied
Mitglied seit
21 Mrz 2004
Beiträge
356
Punkte für Reaktionen
0
Punkte
0
Nachtrag zu den Fehlermeldungen (gekürzte Antwort der Nachricht im AT43-Forum):

Fehlercode 401 bei der Registrierung: Es ist normal, wenn der SIP-Client zuerst eine Registrierung ohne Passwort versucht, ein Fehler kommt, dann versucht der SIP-Client die Registrierung mit Passwort, und es klappt es mit Code 200 OK. Diese Fehlermeldung 401 ist also kein Fehler.

Fehler beim NAT-Keepalive NOTIFY: "403 Forbidden [...] Access to nat.at43.at not allowed for this client". Ist auch kein Fehler, weil es geht nur darum, dass der Server die Verbindung aufrecht hält. Dass dieses Halten mit einer Fehlermeldung passiert, ist egal.

Also kann man beide "Fehler"meldungen ignorieren :)

Gruß, jrrp
 

exim

Admin a.D.
Mitglied seit
27 Apr 2004
Beiträge
1,013
Punkte für Reaktionen
0
Punkte
0
Interessanterweise sagt calamar0.nikotel.com zu den SPA-Keepalive-meldungen inzwischen "OK" und nicht mehr "Call/transaction log soes not exist", dafür antwortet zur Zeit sipgate auf die keepalives mit "server error" ...
 

jrrp

Mitglied
Mitglied seit
21 Mrz 2004
Beiträge
356
Punkte für Reaktionen
0
Punkte
0
Exim, hattest du nicht gesagt, dass die NOTIFYs die NAT-Keep-Alives sind?

Der Sipgate-Support hat mir gemailt, dass Sipgate keine NOTIFYs erlaubt:
"Notifys sind bei uns nicht zugelassen. Es scheint, dass das Notify nicht richtig ist, da ein ServerError gesendet wird, und nicht das erwartete 403 Forbidden."

Ich habe jetzt beim SIP-Tab bei NAT-Keepalive nix eingetragen (laut AT43 regelt das der NAT-Server) und bei den Line-Eigenschaften habe ich "Register Expires=60" bei Sipgate und "Register Expires=3600" bei AT43.at. Weil nämlich der AT43-Server in der Tat sich alle 60-80 Sekunden meldet und der Sipgate-Server mich bei Register Expires=3600 vergisst.

Macht das Sinn? Zumindest sind alle Fehlermeldungen weg, egal ob es echte oder unechte Fehler waren :wink:
 

exim

Admin a.D.
Mitglied seit
27 Apr 2004
Beiträge
1,013
Punkte für Reaktionen
0
Punkte
0
Ja, der SPA schickt als Defaulteinstellung Notify-Messages. Das lief mit Sipgate früher aber schonmal und da kam ein 403 oder 404, weiß es nicht mehr genau. Mir aber auch egal was der Sipgate-Server sagt - solange er meine Reg. nicht verwirft und durch die Keepalives die Verbindung offen bleibt passt es doch :)
 

jrrp

Mitglied
Mitglied seit
21 Mrz 2004
Beiträge
356
Punkte für Reaktionen
0
Punkte
0
OK. Das Motto beim SIP-Protokoll scheint zu sein: Wir schicken lauter Fehlermeldungen, aber es passt trotzdem alles, schön, dass wir darüber geredet haben :)
 

markbeu

IPPF-Promi
Mitglied seit
4 Apr 2004
Beiträge
3,263
Punkte für Reaktionen
0
Punkte
0
Hallole,
ich bin auch gerade am Mitloggen des Sipuras via Kiwi Syslog Daemon, weil ich meinem Internetprovider BlueCable nachweisen moechte, dass es dort seit dem vergangenen Wochenende Probs mit der Leitungsqualitaet gibt.
Deshalb eine Frage an die Profis hier:
Wie erreiche ich es, den Verlust von Paketen zu loggen?

Wenn ich uebrigens auf die Sipura-Info-Seite gehe, sehe ich dort waehrend eines laufenden Gespraeches, dass immer mal massiv viele Pakete verloren gehen.
Genau dann hoere ich den Gespraechspartner abgerissen bzw. er mich.

Bis Samstag, dem 26.06.04 lief VoIP ohne Probs und seit Sonntag staendig diese Aussetzer.
BlueCable behauptet natuerlich, dass bei Ihnen alles ok sei! :-(
Ich benoetige echt ein Sonderkuendigungsrecht, um da wegzukommen.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Neueste Beiträge

Statistik des Forums

Themen
233,100
Beiträge
2,030,145
Mitglieder
351,432
Neuestes Mitglied
MultiTEC