Voicemail

voip-knowledge

Neuer User
Mitglied seit
15 Jan 2006
Beiträge
108
Punkte für Reaktionen
0
Punkte
0
Wo finde ich den eine richtig gute Anleitung, wie ich Voicemail am besten auf meinem Asterisk einrichte?
Am besten mit einbindung von Snom Telefonen.
Danke
 

stäubel

Neuer User
Mitglied seit
11 Aug 2006
Beiträge
198
Punkte für Reaktionen
0
Punkte
16
Guten Tach

Für die Mailbox sind Änderungen in der Datei
extension.conf, sip.conf und voicemail.conf notwendig.

extensions.conf:
In dieser Datei muss die Reihenfolge festgelegt werden:

Code:
[default]

;Interne VoiceMail Konfiguration
;für die Nummern 70 bis 99

exten => _9[789]X,1,VoiceMailMain(${EXTEN:1})  ;um die Mailbox zu konfigurieren (z.B. für 70)
                                               ;am Telefon einfach 970 eingeben


[incoming]

exten => _70,1,Answer()
exten => _70,2,VoiceMail(su70)      ;diese Mailbox kommt bei einkommenden Gespräch
exten => _70,3,Hangup()
Diese Änderungen sind bei sip.conf nötig:
(zusätzlich mailbox= Phone number)

Code:
[70]          
type=friend 
username=Hans  
secret=1234     
host=dynamic
callerid=Hans  
disallow=all  
allow=alaw  
allow=ulaw    
mailbox=70

Die Datei voicemail.conf muss gut durchgesehen werden und unter anderem folgendes einkommentiert werden:

Code:
emaildateformat=%A, %B %d, %Y at %r

sendvoicemail=yes

[zonemessages]

switzerland=Europe/Zurich| 'digits/3' 'digits/2' 'digits/1' 'digits/0' 'vm-received' A  'digits/at' HM

Am Schluss bei Default muss dann noch jede Box eingetragen werden:

Code:
[default]

70 => 1234,Hans,[email protected]

Hoffe konnte dir weiterhelfen.

Grüsse Stäubel
 

voip-knowledge

Neuer User
Mitglied seit
15 Jan 2006
Beiträge
108
Punkte für Reaktionen
0
Punkte
0
Hi, vielen Dank für deine super Erklärung. Ich möchte das ganze aber ohne E-Mail Versand, da ich nur Snom320 Telefone einsetzte und die ja eine Mailtaste haben.
Habe gestern auch schon ein wenig rumprobiert, aber irgendwie will das ganze noch nicht.

voicemail.conf:
;
; Voicemail Configuration
;

[general]
mxsilence=0
envelope=yes
maxmessage=60
minmessage=3
maxgreet=0
format=wav49

[default]

8011 => 1234,Test
sip.conf
[11]
callerid=Test <11>
domain=192.168.2.109
type=friend
username=Hausverwaltung
secret=geheim
host=dynamic
dtmfmode=info
nat=yes
canreinvite=no
vmexten=8011
mailbox=8011
extension.conf
exten => 11,1,Dial(SIP/11,5)
exten => 11,n,Answer
exten => 11,n,wait,2
exten => 11,n,Voicemail(8011)
exten => 11,n,Playback(Goodbye)
exten => 11,n,Hangup()

exten => 8011,1,VoiceMailMain,s${CALLERIDNUM}

Ich hab keine Ahnung, wo das Problem jetzt liegen soll!?
 

stäubel

Neuer User
Mitglied seit
11 Aug 2006
Beiträge
198
Punkte für Reaktionen
0
Punkte
16
Ich möchte das ganze aber ohne E-Mail Versand, da ich nur Snom320 Telefone einsetzte und die ja eine Mailtaste haben.
Habe gestern auch schon ein wenig rumprobiert, aber irgendwie will das ganze noch nicht.
Also bei meiner Version sollte eigentlich beides funktionieren.
(Mail und über SNOM mit der Retrieve Taste.)
Wenn du keine Mails möchtest, kannst du diese Konfiguration einfach
weglassen.

Funktionierts bei dir, wenn du direkt die Nummer 8011 über die
Telefontastatur wählst? Oder geht das auch nicht?

Grüsse Stäubel
 

voip-knowledge

Neuer User
Mitglied seit
15 Jan 2006
Beiträge
108
Punkte für Reaktionen
0
Punkte
0
Wenn ich die Nummer 8011 eingebe, kommt "Bitte geben Sie die Nummer Ihrer Mailbox ein". Wenn ich das dann getan habe sagt mir eine freundliche Frauenstimm "Bitte geben Sie Ihr Mailboxpasswort ein". Gesagt, getan. Doch leider war es das dann auch "Login fehlgeschlagen".
Das Problem bei den Snom Geräten ist, dass die Mailbox nicht so heißt, wie die Druchwahl, sonst rufe ich mich selber an.
Wie kann ich denn ein Gespräch von einer anrufenden MSN an mein Gerät weiterleiten?
 

stäubel

Neuer User
Mitglied seit
11 Aug 2006
Beiträge
198
Punkte für Reaktionen
0
Punkte
16
Wenn ich die Nummer 8011 eingebe, kommt "Bitte geben Sie die Nummer Ihrer Mailbox ein". Wenn ich das dann getan habe sagt mir eine freundliche Frauenstimm "Bitte geben Sie Ihr Mailboxpasswort ein". Gesagt, getan. Doch leider war es das dann auch "Login fehlgeschlagen".
Versuch es nochmals, indem du in der voicemail.conf
einfach das Passwort weglässt
Also z.B. so:
Code:
[default]

70 => ,Hans,[email protected]
Koma nicht vergessen.

statt

Code:
[default]

70 => 1234,Hans,[email protected]
Die Mail solltest du auch einfach weglassen können, wenn du keine Mails möchtest

Das Problem bei den Snom Geräten ist, dass die Mailbox nicht so heißt, wie die Druchwahl, sonst rufe ich mich selber an.
Darum haben wir es so gelöst:
Code:
exten => _9[789]X,1,VoiceMailMain(${EXTEN:1})
Man kann sich nicht selber anrufen, da eine 9 davor steht.
Aber es wird dann doch die eigene Mailbox aufgerufen, da die 9 durch
EXTEN:1 wieder weggeschnitten wird.

Man muss einfach immer eine 9 davor wählen, aber das kannst du ja dem
Retrieve Knopf beibringen.

Wie kann ich denn ein Gespräch von einer anrufenden MSN an mein Gerät weiterleiten?
Das versteh ich jetzt nicht ganz, meinst du einfach den normalen Ablauf im Dialplan an dein Gerät?
Code:
exten => _[78]X,1,Dial(SIP/${EXTEN},${RINGTIME},r)
exten => _[78]X,2,VoiceMail(su${EXTEN})
exten => _[78]X,3,Hangup()
[78]X = von externer Nummer letzte zwei Stellen
(bei uns genügen zwei Stellen)
EXTEN = interne zwei stellige Nummer die mit der externen überein stimmt
RINGTIME = Zeit bis die Mailbox kommt

Grüsse Stäubel
 

voip-knowledge

Neuer User
Mitglied seit
15 Jan 2006
Beiträge
108
Punkte für Reaktionen
0
Punkte
0
Hi, also, wenn ich jetzt mit der 971 auf meine Mailbox zugreife, kommt folgendes: Sie haben keine neuen Nachrichten usw.....
Leider kann ich in dem Menü nichts auswählen. Muss ich am Telefon etwas besonderes einstellen damit meine Auswahl angenommen wird?

Tausend Dank schonmal.

---edit 21:49

Ich habe gerade versucht von einem anderen internen Telefon eine Nachricht aufzusprechen, es kam aber kein beep Ton. Folgendes stand dazu in der CLI:
Nov 14 21:45:12 WARNING[5324]: file.c:512 ast_openstream_full: File beep does not exist in any format
Nov 14 21:45:12 WARNING[5324]: file.c:824 ast_streamfile: Unable to open beep (format alaw): No such file or directory
-- x=0, open writing: /var/spool/asterisk/voicemail/default/71/tmp/XzfPDf format: wav49, 0x815d428

---edit 22:05

Komisch, nachdem ich jetzt etwas auf die Mailbox gesprochen habe, kann ich leider nicht mehr über die Retrieve Taste meine Mailbox ansprechen: Not Found: 71 . Auf der Weboberfläche des Telefons ist aber alles richtig (971)!?
Wenn ich 971 eintippe komme ich auf die Mailbox, die sagt mir auch, das eine Nachricht verfügbar ist. Nur leider kann ich wie oben beschrieben nicht darauf zugreifen, da meine Eingaben nicht angenommen werden.
Habe auch noch folgende Fehlermeldung:
Nov 14 22:00:18 WARNING[5416]: app_voicemail.c:5944 load_config: maxsilence should be less than minmessage or you may get empty messages
Ich glaube wenn diese Probleme behoben sind läuft das ganze endlich :)



---edit Clemens: Mehrfachposts zusammengefasst.
 

stäubel

Neuer User
Mitglied seit
11 Aug 2006
Beiträge
198
Punkte für Reaktionen
0
Punkte
16
kann ich leider nicht mehr über die Retrieve Taste meine Mailbox ansprechen: Not Found: 71 . Auf der Weboberfläche des Telefons ist aber alles richtig (971)!?
Wenn ich 971 eintippe komme ich auf die Mailbox,
Hast du den Retrieve Knopf auch wirklich als DIREKTWAHL (971) definiert?

Wenn ich 971 eintippe komme ich auf die Mailbox, die sagt mir auch, das eine Nachricht verfügbar ist. Nur leider kann ich wie oben beschrieben nicht darauf zugreifen, da meine Eingaben nicht angenommen werden.
Hörst du am Telefon ein akustisches DTMF Signal, wenn du eine Taste drückst?

Ich habe gerade versucht von einem anderen internen Telefon eine Nachricht aufzusprechen, es kam aber kein beep Ton. Folgendes stand dazu in der CLI:
Welche Asterisk Version hast du den eigentlich und was hast du alles installiert?
Sounds Version?
Asterisk Version?

Grüsse Stäubel
 

voip-knowledge

Neuer User
Mitglied seit
15 Jan 2006
Beiträge
108
Punkte für Reaktionen
0
Punkte
0
Hast du den Retrieve Knopf auch wirklich als DIREKTWAHL (971) definiert?
Also, Direktwahl war tats. das Problem.

Welche Asterisk Version hast du den eigentlich und was hast du alles installiert?
Habe eigentlich alles an Packeten installiert:
asterisk-1.2.13
sounds-1.2.1
habe aber die Original Sounds mit ast_promts_de_v2_0 überschrieben

Hörst du am Telefon ein akustisches DTMF Signal, wenn du eine Taste drückst?
Ich höre die normalen piep Töne. Da reagiert aber leider gar nichts.
 

voip-knowledge

Neuer User
Mitglied seit
15 Jan 2006
Beiträge
108
Punkte für Reaktionen
0
Punkte
0
HAB ES GEFUNDEN!!!

DTMF via SIP INFO:Aus
das ist falsch!
Muss auf an stehen.

So, jetzt besteht nur noch das Problem mit dem beep :)
 

voip-knowledge

Neuer User
Mitglied seit
15 Jan 2006
Beiträge
108
Punkte für Reaktionen
0
Punkte
0
Es besteht doch noch ein Problem.
Das Message Lämpchen blinkt trotz abgerufener und gelöschter Nachrichten weiter. Wie bekomm ich das wieder aus?
 

tomster

Mitglied
Mitglied seit
6 Dez 2004
Beiträge
238
Punkte für Reaktionen
0
Punkte
0
Blinkt es oder leuchtet es nur?
Leuchten kann auch noch an den verpassten Anrufen in der Anrufliste liegen, wenn du unter Präferenzen die Checkbox [Message LED für Dialog State/Verpasste Anrufe] auf an geclickt hast. Dann musst du nur die Anrufliste aufrufen, dann ist das LED wieder aus.
 

voip-knowledge

Neuer User
Mitglied seit
15 Jan 2006
Beiträge
108
Punkte für Reaktionen
0
Punkte
0
Das hatte ich schon probiert, die verpassten Anrufe sind es nicht.
Das LED blinkt. Muss also was mit der Mailbox zu tun haben!?
 

voip-knowledge

Neuer User
Mitglied seit
15 Jan 2006
Beiträge
108
Punkte für Reaktionen
0
Punkte
0
Dieses Problem tritt nicht mehr auf, wenn die Mailbox mit # beendet wird!
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,901
Beiträge
2,027,917
Mitglieder
351,033
Neuestes Mitglied
thburkhart