VPN mit iPod und Fritzbox 7390

carsten_h

Neuer User
Mitglied seit
1 Aug 2005
Beiträge
129
Punkte für Reaktionen
1
Punkte
18
Moin!

So langsam aber sicher verzweifle ich mit dem VPN.
Ich habe laut Anleitungen aus dem Internet eine cfg-Datei für ein VPN für die Fritzbox (7390) zusammengestellt. Das habe ich importiert und die Fritzbox akzeptiert es auch.
Wenn ich mit dem iPod eine Verbindung aufbaue, gelingt diese auch und in der Fritzbox unter Internet/VPN sehe ich auch, daß die Verbindung hergestellt wurde.

Wenn ich aber nun z.B. auf dem iPod Safari mit fritz.box aufrufe, sehe ich die Fritzbox aus dem Netz, in dem ich gerade bin und nicht meine eigene, die über VPN ja eigentlich erreichbar sein sollte.
Die FritzApp funktioniert ebenfalls nicht, da sie nicht auf meine Fritzbox zugreift.

Hier ist die cfg-Datei:
Code:
vpncfg {
    connections {
            name = "sagichnicht";
            enabled = yes;
            conn_type = conntype_user;                
            remoteip = 0.0.0.0;
            remote_virtualip = 192.168.178.201;
            phase2remoteid {
                ipaddr = 192.168.178.201;
            }
            remoteid {
                    key_id = "sagichnicht";
            }
            accesslist = "permit ip any 192.168.178.201 255.255.255.255";
            key = "sagicherstrechtnicht";
            always_renew = no;
            reject_not_encrypted = no;
            dont_filter_netbios = yes;
            localip = 0.0.0.0;
            local_virtualip = 0.0.0.0;
            mode = phase1_mode_aggressive;
            phase1ss = "all/all/all";
            keytype = connkeytype_pre_shared;
            cert_do_server_auth = no;
            use_nat_t = yes;
            use_xauth = yes;
            use_cfgmode = no;
            xauth {
                valid=yes;
                username="ich";
                passwd="geheim";
            }
            phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
            phase2localid {
                ipnet {
                    ipaddr = 0.0.0.0; 
                    mask = 0.0.0.0;
                }
            }
    }

    ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500",
                        "udp 0.0.0.0:4500 0.0.0.0:4500";
}
Statt:
permit ip any 192.168.178.201 255.255.255.255
habe ich auch schon:
permit ip 0.0.0.0 0.0.0.0 192.168.178.201 255.255.255.255
ausprobiert, aber es passiert nicht anderes.

Vielleicht kann mir ja jemand hier helfen.
Danke!
 
Zuletzt bearbeitet von einem Moderator:

Pluto79

Mitglied
Mitglied seit
5 Aug 2005
Beiträge
204
Punkte für Reaktionen
0
Punkte
16
vpncfg {
connections {
enabled = yes;
conn_type = conntype_user;
name = "[email protected]";
always_renew = no;
reject_not_encrypted = no;
dont_filter_netbios = yes;
localip = 0.0.0.0;
local_virtualip = 0.0.0.0;
remoteip = 0.0.0.0;
remote_virtualip = 192.xxx.xxx.xxx;
remoteid {
key_id = "Passwort";
}
mode = phase1_mode_aggressive;
phase1ss = "all/all/all";
keytype = connkeytype_pre_shared;
key = "Passwort";
cert_do_server_auth = no;
use_nat_t = yes;
use_xauth = yes;
xauth {
valid = yes;
username = "Username";
passwd = "Passwort";
}
use_cfgmode = no;
phase2localid {
ipnet {
ipaddr = 0.0.0.0;
mask = 0.0.0.0;
}
}
phase2remoteid {
ipaddr = 192.xxx.xxx.xxx;
}
phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
accesslist =
"permit ip 0.0.0.0 0.0.0.0 192.xxx.xxx.xxx 255.255.255.255";
Bei mir sieht es so aus, und alles funktioniert bestens.
 

carsten_h

Neuer User
Mitglied seit
1 Aug 2005
Beiträge
129
Punkte für Reaktionen
1
Punkte
18
Auf den ersten Blick habe ich keine großen Unterschiede feststellen können. Ich habe einfach meine Daten in Deiner Konfiguration eingetragen und die zwei fehlenden } ergänzt.
Was soll ich sagen, es ging dann auf Anhieb!

Danke!