webdav scheint zu funktionieren, ist aber immer 'stopped'

henfri

Mitglied
Mitglied seit
21 Sep 2005
Beiträge
427
Punkte für Reaktionen
1
Punkte
18
Hallo,

wenn ich webdav über das Freetz WebIF oder über /etc/init.d/rc.davfs2 start starte, scheint das zu klappen. Aber wenn ich dann nachsehe, ob es wirklich läuft, erhalte ich die Nachricht, dass webdav nicht läuft:
Code:
/var/mod/root # /etc/init.d/rc.davfs2 start
mount WebDAV...done.
/var/mod/root # /etc/init.d/rc.davfs2 status
stopped
Im Syslog nix interessantes. Wie kann ich herausfinden, was fehlschlägt?

Ich verwende den aktuellen Trunk.

Gruß&Danke,
Hendrik
 

henfri

Mitglied
Mitglied seit
21 Sep 2005
Beiträge
427
Punkte für Reaktionen
1
Punkte
18
Hm,
hat keiner einen Tipp, wie ich den Fehler eingrenzen kann?
Ich such auch gerne in Skripten etc ;-)

Gruß,
Hendrik
 

hermann72pb

IPPF-Promi
Mitglied seit
6 Nov 2005
Beiträge
3,618
Punkte für Reaktionen
2
Punkte
38
läuft es denn tatsächlich oder nicht? Kannst du es irgendwie anders überprüfen als mit dem status?

Wenn es läuft und nur nicht richtig mit "status" angezeigt wird, dann schau mal in rc.davfs2 rein, Abschnitt "status". Womöglich schlägt die Methode fehl, mit der man dort den Status ermittelt. Vielleicht hat jemand da was vergessen zu aktualisieren.

MfG
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Code:
# sh -x /mod/etc/webdav
+ mkdir -p /var/davfs2
+ mkdir -p /var/davfs2/temp
+ mkdir -p /var/cache
+ rm /var/cache/davfs2
+ ln -s /var/davfs2/temp /var/cache/davfs2
+ modprobe coda
+ [ /var/tmp/dav !=  ]
+ echo secrets /var/davfs2/secrets_1
+ chmod 0600 /var/davfs2/secrets_1
+ echo mount [URL]http://www.gmx.de[/URL]...
mount [URL]http://www.gmx.de[/URL]...
+ mkdir -p /var/tmp/dav
+ mount.davfs [URL]http://www.gmx.de[/URL] /var/tmp/dav -o conf=/var/davfs2/davfs2_1.conf
Mounting failed.
Could not resolve hostname `[url]www.gmx.de':[/url] Host not found
+ [  !=  ]
+ [  !=  ]
MfG Oliver
 

henfri

Mitglied
Mitglied seit
21 Sep 2005
Beiträge
427
Punkte für Reaktionen
1
Punkte
18
Hallo,

das Beispiel von Oliver läuft soweit (nur habe ich kein login. Aber sonst...)

Ich denke, ich habe das Problem eingrenzen können.
Und zwar erhalte ich beim Start von /mod/etc/webdav die Fehlermeldung "unknown option in /etc/davfs2/davfs2.conf".

In dieser Datei steht aber nur "secrets ...".
In der Doku hierzu steht:
Code:
secrets
    Name of a file that holds the credentials for servers and the proxy, and passwords to decrypt the client certificate. The name must be an absolute path. The file must be read and writable by the owner only (mode 600).
    Default: ~/.davfs2/secrets
    Only allowed in the user configuration file. The system wide secrets file is allways /etc/davfs2/secrets.
Und genau letzteres könnte das Problem sein.

Die /etc/davfs2/davfs2.conf zu ändern bringt nix, da sie beim start von /mod/etc/webdav überschrieben wird. Aber in der /mod/etc/webdav kann man die entspr. Zeile (zeile 10) auskommentieren.
Dann läuft es erstmal. Ist das ein Bug, oder mache ich etwas falsch?

Dann komme ich aber zur Fehlermeldung
Code:
bash-3.2# ./webdav
mount https://sd2dav.1und1.de...
neon library does not support TLS/SSL
Ich denke, da fehlt Freetz ein Paket, oder? Welches ist das?


Gruß,
Hendrik
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Wenn du SSL Support willst, dann musst du das im menuconfig auswählen. Außerdem brauchst du dann Zertifikate auf der Box. Dazu gibts ein Ticket im Trac.

MfG Oliver
 

henfri

Mitglied
Mitglied seit
21 Sep 2005
Beiträge
427
Punkte für Reaktionen
1
Punkte
18
Hallo,

mein Problem von oben
--------
Ich denke, ich habe das Problem eingrenzen können.
Und zwar erhalte ich beim Start von /mod/etc/webdav die Fehlermeldung "unknown option in /etc/davfs2/davfs2.conf".

In dieser Datei steht aber nur "secrets ...".
In der Doku hierzu steht:
Code:
secrets
    Name of a file that holds the credentials for servers and the proxy, and passwords to decrypt the client certificate. The name must be an absolute path. The file must be read and writable by the owner only (mode 600).
    Default: ~/.davfs2/secrets
    Only allowed in the user configuration file. The system wide secrets file is allways /etc/davfs2/secrets.
Und genau letzteres könnte das Problem sein.

Die /etc/davfs2/davfs2.conf zu ändern bringt nix, da sie beim start von /mod/etc/webdav überschrieben wird. Aber in der /mod/etc/webdav kann man die entspr. Zeile (zeile 10) auskommentieren.
Dann läuft es erstmal. Ist das ein Bug, oder mache ich etwas falsch?
---------

Besteht aber unabhängig von der SSL Problematik. Deshalb ist dieser Thread leider noch nicht gelöst. Wenn mich nicht alles täuscht, funktioniert die Lösung aus dem aktuellen Trunk deshalb nicht.

Oder übersehe ich etwas?

Gruß&Danke,
Hendrik
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Ich hab ja auch ein anderes Problem gefixt. :p

Eigentlich dürfte gar keine davfs2.conf da sein!?

MfG Oliver
 
U

unisys

Guest
Übrigens ist das mit "davfs2.conf" und "secrets" anscheinend noch immer nicht gefixt bzw. geändert, hier ein Auszug von meinem syslog:

09-25-2009 03:46:55 Local7.Debug 192.168.1.1 Sep 25 03:46:56 syslog: davfs2 1.4.1
09-25-2009 03:46:55 Local7.Debug 192.168.1.1 Sep 25 03:46:56 syslog: opening /etc/davfs2/davfs2.conf failed
09-25-2009 03:46:55 Local7.Debug 192.168.1.1 Sep 25 03:46:56 syslog: opening /etc/davfs2/secrets failed
Könnte man das Problem (dass doch ein wenig irritiert im syslog) nicht ausbügeln... :?:
 

Silent-Tears

IPPF-Promi
Mitglied seit
3 Aug 2007
Beiträge
7,456
Punkte für Reaktionen
0
Punkte
0
Das sind debugmeldungen, keine Fehler. Wozu sollte man da Hand anlegen?
 
U

unisys

Guest
Ich dachte, weil jetzt ohnehin neue Dateien genutzt werden und dies eigentlich nichtmehr nötig ist. Aber mir solls recht sein...
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,903
Beiträge
2,027,987
Mitglieder
351,044
Neuestes Mitglied
enigoihwiohwiohwpit