Wieder mal Crosscompiler

Status
Für weitere Antworten geschlossen.

klez

Neuer User
Mitglied seit
21 Mrz 2006
Beiträge
40
Punkte für Reaktionen
0
Punkte
0
Hi. Ich bin seit kurzem stolzer Besitzer einer 7170 und wollte mir nun meine eigene kleine "Distri" zusammenbasteln. Leider scheitere ich bereits bei dem erstellen der Toolchain (ds mod). Habe hier im Forum schon gelesen, dass andere das gleiche Problem hatten. Leider war keine Lösung beschrieben.

make[4]: *** [../../../binutils-2.16.91.0.6/bfd/doc/bfd.info] Fehler 1
make[4]: Leaving directory `/home/xx/source/fritzbox/ds-0.2.2/source/toolchain/binutils-2.16.91.0.6-build/bfd/doc'
Making info in po
make[4]: Entering directory `/home/xx/source/fritzbox/ds-0.2.2/source/toolchain/binutils-2.16.91.0.6-build/bfd/po'
make[4]: Für das Ziel »info« ist nichts zu tun.
make[4]: Leaving directory `/home/xx/source/fritzbox/ds-0.2.2/source/toolchain/binutils-2.16.91.0.6-build/bfd/po'
make[4]: Entering directory `/home/xx/source/fritzbox/ds-0.2.2/source/toolchain/binutils-2.16.91.0.6-build/bfd'
make[4]: Für das Ziel »info-am« ist nichts zu tun.
make[4]: Leaving directory `/home/xx/source/fritzbox/ds-0.2.2/source/toolchain/binutils-2.16.91.0.6-build/bfd'
make[3]: *** [info-recursive] Fehler 1
make[3]: Leaving directory `/home/xx/source/fritzbox/ds-0.2.2/source/toolchain/binutils-2.16.91.0.6-build/bfd'
make[2]: *** [all-bfd] Fehler 2
make[2]: Leaving directory `/home/xx/source/fritzbox/ds-0.2.2/source/toolchain/binutils-2.16.91.0.6-build'
make[1]: *** [all] Fehler 2
make[1]: Leaving directory `/home/xx/source/fritzbox/ds-0.2.2/source/toolchain/binutils-2.16.91.0.6-build'
make: *** [/home/xx/source/fritzbox/ds-0.2.2/source/toolchain/binutils-2.16.91.0.6-build/binutils/objdump] Fehler 2
Das ganze entsteht unter einem Debian Sarge gcc Version 3.3.5 und unter einem Kubuntu Breezy mit gcc Version 4.0.x. Leider bin ich hier mit meinem Latein am Ende. Wäre froh, wenn mir jemand helfen könnte. Gruß
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Hi.
Leider hast du die Fehlermeldung nicht in deinem Post. Kannst du die Zeilen vorher auch noch posten?

MfG Oliver
 

klez

Neuer User
Mitglied seit
21 Mrz 2006
Beiträge
40
Punkte für Reaktionen
0
Punkte
0
Ich bin derzeit auf der Arbeit und kann es daher nur unter Kubuntu testen. Habe während des stöberns im Forum entdeckt, dass danisahne mal das gleiche Problem mit dem Buildroot gehabt zu haben scheint. Siehe Hier.
Das beantwortet auch gleihczeitig Deine Frage nach den vorherigen Zeilen. Bis auf die Information mit "makeinfo" ist da nämlich sonst nichts (ausser Aufrufe, dei ohne Probleme funktionieren). Neu entpacken und kompilieren hat bei mir nichts gebracht. Warum sollte es auch? :)
 

danisahne

Aktives Mitglied
Mitglied seit
30 Jul 2005
Beiträge
1,493
Punkte für Reaktionen
0
Punkte
0
Hast du nun texinfo installiert und nochmal von vorne begonnen (das meint heini66 mit nochmal entpacken)? Ich kann mich erinnern, dass er irgendwie trotzdem nicht den build fortsetzen wollte, es klappte bei mir glaube nur, wenn man es nochmal von vorne machte. Es müßte dabei eventuell auch ausreichen, wenn du das Verzeichnis ./source/toolchain löscht und nochmal ´make toolchain' ausführst.

Mfg,
danisahne
 

klez

Neuer User
Mitglied seit
21 Mrz 2006
Beiträge
40
Punkte für Reaktionen
0
Punkte
0
Alles klar. Das Verzeichnis source/toolchain löschen und anschliessend nochmal make toolchain scheint es zu bringen. Vorrausgesetzt man hat vorher makeinfo / texinfo installiert. Jetzt kann ich mit dem Basteln beginnen, Danke !
 
Status
Für weitere Antworten geschlossen.

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
231,884
Beiträge
2,016,307
Mitglieder
348,983
Neuestes Mitglied
eiffel133