Wireguard mit Freetz ng: Clients haben kein Internet

gtntdev

Neuer User
Mitglied seit
16 Mrz 2021
Beiträge
15
Punkte für Reaktionen
0
Punkte
1
Hi:)

Ich habe auf meiner Cable 6591 freetz ng mit package Wireguard installliert, die Configs hab ich nach folgender Anleitung erstellt.
Die Clients haben Zugriff auf Hosts des FB Adressbereichs (192.168.178.1/24), jedoch haben sie keine Verbindung zum Internet.

Hier die Routes:
Code:
[QUOTE]
[email protected]:/var/mod/root# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     2      0        0 dsl
10.0.0.11       0.0.0.0         255.255.255.255 UH    0      0        0 wg0
10.0.0.12       0.0.0.0         255.255.255.255 UH    0      0        0 wg0
10.0.0.13       0.0.0.0         255.255.255.255 UH    0      0        0 wg0
10.0.0.14       0.0.0.0         255.255.255.255 UH    0      0        0 wg0
10.0.0.15       0.0.0.0         255.255.255.255 UH    0      0        0 wg0
10.0.0.16       0.0.0.0         255.255.255.255 UH    0      0        0 wg0
10.0.0.17       0.0.0.0         255.255.255.255 UH    0      0        0 wg0
10.0.0.18       0.0.0.0         255.255.255.255 UH    0      0        0 wg0
10.0.0.19       0.0.0.0         255.255.255.255 UH    0      0        0 wg0
88.134.229.161  0.0.0.0         255.255.255.255 UH    2      0        0 dsl
88.134.229.225  0.0.0.0         255.255.255.255 UH    2      0        0 dsl
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 lan
169.254.1.0     0.0.0.0         255.255.255.252 U     0      0        0 adp0.555
188.192.253.0   0.0.0.0         255.255.255.0   U     2      0        0 dsl
192.168.100.0   0.0.0.0         255.255.255.0   U     4      0        0 dsl
192.168.178.0   0.0.0.0         255.255.255.0   U     0      0        0 lan
192.168.179.0   0.0.0.0         255.255.255.0   U     0      0        0 guest
192.168.180.1   0.0.0.0         255.255.255.255 UH    2      0        0 dsl
192.168.180.2   0.0.0.0         255.255.255.255 UH    2      0        0 dsl
[/QUOTE]

Als DNS ist die Fritzbox eingetragen, wie in der Anleitung oben beschrieben.
Hat jemand eine Idee was ich noch ändern/ergänzen muss?
Falls die config Dateien wichtig sind, bitte kurz kommentieren.

Ip in den WG Einstellungen in der FB GUI ist folgende eingetragen:
10.0.0.1/24

Liebe Grüße, Lukas
 

sf3978

IPPF-Promi
Mitglied seit
2 Dez 2007
Beiträge
7,915
Punkte für Reaktionen
20
Punkte
38
Die Clients haben Zugriff auf Hosts des FB Adressbereichs (192.168.178.1/24), jedoch haben sie keine Verbindung zum Internet.

Als DNS ist die Fritzbox eingetragen, ...
Hast Du bei den Clients, als gateway (Router) für ihre "default route", auch die FritzBox eingetragen?
 

gtntdev

Neuer User
Mitglied seit
16 Mrz 2021
Beiträge
15
Punkte für Reaktionen
0
Punkte
1
Hast Du bei den Clients, als gateway (Router) für ihre "default route", auch die FritzBox eingetragen?
Ja ist eingetragen.

Bin jetzt nochmal nach einer anderen Anleitung vorgegangen bei der Konfiguration, jetzt bin ich mir sicher, dass diese stimmt.

Etwas ungewöhnliches hab ich beobachten können (ich hab sehr viel Paketverlust), also einzelne Pings kommen durch (sowohl FB Netz als auch öffentliche Anfragen, deswegen bauen sich die Seiten nur so langsam auf, dass es aussieht, als ob keine Verbindung bestünde):
Code:
C:\Users\Lukas>ping www.google.com

Ping wird ausgeführt für www.google.com [142.250.185.228] mit 32 Bytes Daten:
Antwort von 142.250.185.228: Bytes=32 Zeit=137ms TTL=112
Zeitüberschreitung der Anforderung.
Antwort von 142.250.185.228: Bytes=32 Zeit=88ms TTL=112
Zeitüberschreitung der Anforderung.

Ping-Statistik für 142.250.185.228:
    Pakete: Gesendet = 4, Empfangen = 2, Verloren = 2
    (50% Verlust),
Ca. Zeitangaben in Millisek.:
    Minimum = 88ms, Maximum = 137ms, Mittelwert = 112ms

C:\Users\Lukas>ping 192.168.178.29

Ping wird ausgeführt für 192.168.178.29 mit 32 Bytes Daten:
Antwort von 192.168.178.29: Bytes=32 Zeit=91ms TTL=63
Zeitüberschreitung der Anforderung.
Antwort von 192.168.178.29: Bytes=32 Zeit=67ms TTL=63
Zeitüberschreitung der Anforderung.

Ping-Statistik für 192.168.178.29:
    Pakete: Gesendet = 4, Empfangen = 2, Verloren = 2
    (50% Verlust),
Ca. Zeitangaben in Millisek.:
    Minimum = 67ms, Maximum = 91ms, Mittelwert = 79ms

C:\Users\Lukas>

Vielleicht hat hier jemand einen Tip..

Edit: @KunterBunter danke, ist aktualisiert:)
Eigentlich ist es aber nicht besonderes:
1) Client und Server Private- und PublicKeys erzeugen mit dem wg Tool
2) Nach der Vorlage anpassen (bei mir ohne PresharedKey auf Client und Server)
3) Port editieren in beiden Configs und freigeben auf FB (dazu habe ich die 3.te Möglichkeit vom OpenVPN Package genutzt)

Viele Grüße,
Lukas
 
Zuletzt bearbeitet:

gtntdev

Neuer User
Mitglied seit
16 Mrz 2021
Beiträge
15
Punkte für Reaktionen
0
Punkte
1
Update:

Ich konnte jetzt nochmal einiges ausschließen, das Problem mit den "exakt 50% Package loss" bei Pings von Geräten im FB Netzt (außer FB selbst, die erreiche ich super) und öffentlichen Anfragen (wie www.google.com) über den Tunnel besteht auch von unterschiedlichsten Local Netzwerken, egal ob 4G, Wlan oder Lan und egal welches Subnetz (lokales Netz hatte ich auch einmal komplett was anderes wie im Tunnel oder remote FB Netz).

Jetzt kommt das interessante:
Im FB Netzt ist ein RPi, auf dem läuft ebenfalls ein WG Server, natürlich auf einen anderen öffentlichen Port, und mit diesem Tunnel funktioniert es immer sofort (also alle Geräte im remote Netz, öffentliche Anfragen und die FB selbst). Ich habe immer die offiziellen WG Clients zum Testen verwendet (Windows Gui, und Ubuntu shell). Die Client Konfigurationen habe ich Cross gecheckt und sind bis auf die Keys und den Port identisch. Einziger Unterschied bei Linux ist, dass ich wg-quick verwende zum Verbinden und der Parameter "Addresse" nicht in der FB Config vorkommt, den muss man ja über das WebInterface eingeben.

Die Routen schauen auf beiden Geräten ähnlich aus, aber vielleicht hat ja jemand eine funktionierende WG Installation auf einer FB und könnte da mal einen Auszug posten (route -n). Einzig, der RPi hat ein paar Nat Einträge in den iptables bei den Forward-rules, die kann ich auf der FB nicht anschauen, da keine iptables intalliert. Ich gehe jetzt fest davon aus, dass es ein Routing Problem auf der FB ist.

Viele Grüße,
Lukas
 

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via