.titleBar { margin-bottom: 5px!important; }

WPA(2) mit Ubuntu einrichten über wpa_gui

Dieses Thema im Forum "Sonstiges" wurde erstellt von beckmann, 4 Nov. 2006.

  1. beckmann

    beckmann Guest

    Hallo weis jemand wie ich WPA2 zum laufen bekommen mit Ubuntu? Die WLAN Karte funktioniert unter Linux schon mal. Aber das einrichten macht mir große Probleme.

    Ich habe was von wpa_gui gelesen und das ich es mir per apt-get holen kann. Leider ist im dieses paket unbekannt egal welche schreibeweise ich benutze. Wäre nett wenn mir jemand sagen könnte wie ich an wpa_gui komme, scheinbar ist das Paket einfach nicht für Ubuntu vorhanden im gegensatz zu Debian.
     
  2. frank_m24

    frank_m24 IPPF-Urgestein

    Registriert seit:
    20 Aug. 2005
    Beiträge:
    17,571
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Niederrhein
    Hallo,

    ich denke, die wpa_gui ist Bestandteil des wpa_supplicant. Versuche es damit mal.

    Ich persönlich halte aber mehr davon, die Konfiguration manuell (wpa_supplicant.conf) vorzunehmen. Sind bei PSK nur 3 Zeilen und kann direkt beim Booten verwendet werden (in Gentoo zumindest).

    Viele Grüße

    Frank
     
  3. beckmann

    beckmann Guest

    Danke darüber habe ich mich auch schon versucht. Leider wird das nicht wirklich was, ich schreibe mal auf was ich bis jetzt habe:

    Anmerkung, ich habe WPA-PSK also kein WPA2

    /etc/wpa_supplicant.conf
    Code:
    ctrl_interface=/var/run/wpa_supplicant
    eapol_version=1
    ap_scan=2
    
    network={
            ssid="Name meines Netzes"
            proto=WPA
            key_mgmt=WPA-PSK
            pairwise=TKIP
            group=TKIP CCMP
            #psk="Der echte WPA Key"
            psk=Der gecryptete Key
    }
    
    /etc/default/wpasupplicant
    Code:
    
    # WARNING! Make sure you have a configuration file!
    
    ENABLED=1
    
    # Useful flags:
    #  -D <driver>          Wireless drive, typically optional.
    #  -i <ifname>          Interface
    #  -c <config file>     Configuration file
    #  -d                   Debugging (-dd for more)
    #  -w                   Wait for interface to come up
    
    # See the manual page wpa_supplicant(1) for more options and information.
    
    [b]OPTIONS="-w -dd -D wext -i eth1 -c /etc/wpa_supplicant.conf"[/b]
    
    # EXAMPLES:
    
    # OPTIONS="-i wlan0 -D hostap -c /etc/wpa_supplicant.conf"
    # OPTIONS="-i ath0 -D madwifi -c /etc/wpa_supplicant.conf"
    
    Die Meldung beim Starten:
    Code:
    [b]user@ubuntu:/etc$ sudo /etc/init.d/wpasupplicant start[/b]
    Starting wpa_supplicant: Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'wext'
    Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    eapol_version=1
    ap_scan=2
    Line: 5 - start of a new network block
    ssid - hexdump_ascii(len=9):
         <Zeichen>                        Name meines Netzwekes
    proto: 0x1
    key_mgmt: 0x2
    pairwise: 0x8
    group: 0x18
    PSK - hexdump(len=32): [REMOVED]
    Line 13: removed CCMP from group cipher list since it was not allowed for pairwise cipher
    Priority group 0
       id=0 ssid='Name meines Netzwerkes'
    Daemonize..
    There is already a pid file /var/run/dhclient.pid with pid 12046
    killed old client process, removed PID file
    done.
    
    und wenn ich wpa_cli starte
    Code:
    [b]user@ubuntu:/etc$ sudo wpa_cli[/b]
    wpa_cli v0.4.5
    Copyright (c) 2004-2005, Jouni Malinen <jkmaline@cc.hut.fi> and contributors
    
    This program is free software. You can distribute it and/or modify it
    under the terms of the GNU General Public License version 2.
    
    Alternatively, this software may be distributed under the terms of the
    BSD license. See README and COPYING for more details.
    
    
    Selected interface 'eth1'
    
    Interactive mode
    
    > <2>Authentication with 00:00:00:00:00:00 timed out.
    <2>Trying to associate with SSID 'Name meines Netzwerks'
    <2>WPA: Failed to parse WPA IE from association info
    <2>Association request to the driver failed
    <2>Trying to associate with SSID 'Name meines Netzwerks'
    <2>WPA: Failed to parse WPA IE from association info
    <2>Association request to the driver failed
    
    
    
    :noidea:
     
  4. frank_m24

    frank_m24 IPPF-Urgestein

    Registriert seit:
    20 Aug. 2005
    Beiträge:
    17,571
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Niederrhein
    Hallo,

    zum einen reicht es in den meisten Fällen, eine wpa_supplicant.conf mit folgenden Inhalt einzurichten, den Rest holen sich aktuelle wpa_supplicants (0.5.x) Versionen aus den WLAN Scans (mehr steht bei mir jedenfalls nich drin):

    Code:
    ctrl_interface=/var/run/wpa_supplicant
    network={
            ssid="Name meines Netzes"
            psk="Der echte WPA Key"
    }
    Der Output vom wpa_cli sieht fast danach aus, dass der supplicant ein Problem mit dem Treiber hat. Gerade die interessanten Informationen kann der wpa_supplicant den Scan-Results nicht entnehmen (WPA IE).
    Was ist es für eine WLAN Karte? Implementiert sie die Wireless Extensions vollständig? Passt die Version der Wireless Extensions zwischen Treiber, Kernel und wpa_supplicant?
    Kannst du vielleicht ein proprietäres Driver Interface des wpa_supplicants benutzen (ipw, madwifi, hostap ...)?

    Viele Grüße

    Frank
     
  5. beckmann

    beckmann Guest

    Ich verwende ein Centrino Laptop mit der Intel Wirelesskarte. Die WLAN Karte scheint auch zu funktionieren Kismet tut es z.B. ohne Probleme. ipw2200 heist die WLAN Karte.

    iwconfig sagt mir:
    Code:
    eth1      unassociated  ESSID:"Name meines WLANS"
              Mode:Managed  Channel=0  Access Point: 00:00:00:00:00:00
              Bit Rate=0 kb/s   Tx-Power=20 dBm
              Retry limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    Auch iwlist tut es ohne Probleme:
    Code:
    user@ubuntu:/etc$ iwlist scanning
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    eth1      Scan completed :
              Cell 01 - Address: [b]Mac meines WLAN Routers[/b]
                        ESSID:[b]"Name meines WLANS"[/b]
                        Protocol:IEEE 802.11bg
                        Mode:Master
                        Channel:4
                        Encryption key:on
                        Bit Rate:54 Mb/s
                        Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 24 36 48 54
                        Quality=55/100  Signal level=-68 dBm
                        Extra:wpa_ie=[b]ein hexadezimaler Key[/b]
                        Extra: Last beacon: 70ms ago
              Cell 02 - Address: MAC Adresse eines zweiten WLANS
                        ESSID:"<hidden>"
                        Protocol:IEEE 802.11bg
                        Mode:Master
                        Channel:13
                        Encryption key:on
                        Bit Rate:54 Mb/s
                        Extra: Rates (Mb/s): 1 2 5.5 9 11 6 12 18 24 36 48 54
                        Quality=68/100  Signal level=-59 dBm
                        Extra:wpa_ie=Hexadezimale Zahl
                        Extra:rsn_ie=Hexadezimale Zahl
                        Extra: Last beacon: 626ms ago
    
    sit0      Interface doesn't support scanning.
    
    Was soll ich noch umändern oder online stellen? Ich kenne mich da nich so besonders aus.
     
  6. frank_m24

    frank_m24 IPPF-Urgestein

    Registriert seit:
    20 Aug. 2005
    Beiträge:
    17,571
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Niederrhein
    Hallo,

    eine ipw2200, sehr schön ;)

    Ändere mal in der /etc/default/wpasupplicant folgende Zeile:
    Code:
    OPTIONS="-w -dd -D [B]wext[/B] -i eth1 -c /etc/wpa_supplicant.conf"
    in
    Code:
    OPTIONS="-w -dd -D [B]ipw[/B] -i eth1 -c /etc/wpa_supplicant.conf"
    Viele Grüße

    Frank
     
  7. beckmann

    beckmann Guest

    Danke Frank, das war es :)