.titleBar { margin-bottom: 5px!important; }

X-Lite mit Freenet läuft nur teilweise...

Dieses Thema im Forum "XLite/ XPro/ eyeBeam" wurde erstellt von dominikde, 22 Okt. 2004.

  1. dominikde

    dominikde Neuer User

    Registriert seit:
    22 Okt. 2004
    Beiträge:
    130
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen,

    habe heute meinen Freenet-Zugang erhalten und gleich mal mit X-Lite getestet (nach Freenet-Anleitung eingestellt). Ich habe KEINE Firewall aktiviert (testweise) und alle Ports nach außen sind offen.

    1. Test: Anrufen meines Bekannten im Festnetz

    Perfekt! Bis auf das Echo (was bei X-Lite wohl normal ist).

    2. Test: Ich rufe mich vom Handy unter meiner Freenet-Nummer an

    - X-Lite klingelt, Rufnummer wird angezeigt
    - am Handy höre ich jedoch noch kein Tuten vom Wählen
    - naja.. Anruf per X-Lite angenommen
    - Zeit läuft mit, doch egal ob am Handy oder X-Lite niemand hört etwas
    - auf meinem Handy steht immer noch drauf "Verbinden"
    - nach kurzer Zeit bricht mein Handy den Verbindungsaufbau ab
    - die Zeit am X-Lite läuft aber weiter
    - ich lege in X-Lite auf und erhalte die Meldung "Call Leg/Transaction Does Not Exist"

    3. Test: iPhone von Freenet

    Tja... dort läuft alles perfekt - eingehend als auch abgehend - wunderbar! Aber da ich Mac-User bin und keine Lust auf ne Windows-Emulation habe, muss ich doch irgendwie X-Lite zum Laufen kriegen :)

    4. Diagnose

    Ich habe mir mal das Diagnostics-Log von meinem 2. Versuch angeschaut (in gekürzter Fassung):

    - Anruf (X-Lite klingelt):

    RECEIVE TIME: 1928780
    RECEIVE << 194.97.54.97:5060
    INVITE sip:XXXXXXXXX@217.173.146.100:5060 SIP/2.0

    SEND TIME: 1929733
    SEND >> 194.97.54.97:5060
    SIP/2.0 100 Trying


    SEND TIME: 1929757
    SEND >> 194.97.54.97:5060
    SIP/2.0 180 Ringing

    RECEIVE TIME: 1929757
    RECEIVE << 194.97.54.97:5060
    INVITE sip:XXXXXX@217.173.146.100:5060 SIP/2.0

    ...sieht soweit mal gut aus...

    - Anrufannahme:

    SEND TIME: 1953374
    SEND >> 194.97.54.97:5060
    SIP/2.0 200 Ok

    SEND TIME: 1954960
    SEND >> 194.97.54.97:5060
    SIP/2.0 200 Ok

    SEND TIME: 1958219
    SEND >> 194.97.54.97:5060
    SIP/2.0 200 Ok

    SEND TIME: 1964454
    SEND >> 194.97.54.97:5060
    SIP/2.0 200 Ok

    ...aber von Freenet kommt nix zurück?! Oder ist der Befehl für die Anrufannahme falsch? Zeit läuft und im Log passiert nichts...

    - Auflegen...

    SEND TIME: 2930075
    SEND >> 194.97.54.97:5060
    BYE sip:06XXXXXXXXX@62.104.210.130:5060 SIP/2.0

    RECEIVE TIME: 2930185
    RECEIVE << 194.97.54.97:5060
    SIP/2.0 481 Call Leg/Transaction Does Not Exist

    ...da wohl der Befehl für die Anrufannahme bei Freenet nicht angekommen ist, kennt er die Session/das Telefonat nicht und weist mit "Call Leg/Transaction Does Not Exist" ab.

    -

    Wo liegt nun der Fehler? Hält sich Freenet nicht an die Standards? oder doch ein Bug/Fehler/Einstellungsproblem von X-Lite?

    Über Antwort von Euch würde ich mich sehr freuen, da wohl auch andere einige Probleme mit X-Lite und Freenet haben (und nicht immer der Router dran Schuld ist *smile*).

    Gruß,
    Dominik
     
  2. dominikde

    dominikde Neuer User

    Registriert seit:
    22 Okt. 2004
    Beiträge:
    130
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ..hat niemand das gleiche Problem? Wird wohl doch Zeit, dass meine FritzBox Fon kommt :)