.titleBar { margin-bottom: 5px!important; }

YANT: Perverses NAT-Problem

Dieses Thema im Forum "FRITZ!Box Fon: Telefonie" wurde erstellt von Riverwind, 7 Nov. 2008.

  1. Riverwind

    Riverwind Neuer User

    Registriert seit:
    11 Okt. 2005
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Schermbeck (NRW)
    Hallo liebe Lesenden!

    NAT-Threads gibt es hier im Forum mehr als genug. Das habe ich auch schon gesehen. Ich habe auch schon ein ganze Reihe mit diversen Verlinkungen zu anderen Threads, Anleitungen und HowTos durch. Wie so häufig in meinem Leben habe ich hier einen Spezialfall, für den es keine fertige Lösung gibt und den ich entsprechend behandeln muß.

    Hintergrund:
    Bei mir steht der Wechsel des Zugangs-ISPs an (von der Telekom zu O2).
    Der Grund:
    - Kosten: Die Telekom hat mich monatlich rund 70 Euronen gekostet.
    - Bandbreite: Bei der Telekom hatte ich eine ADSL mit 3072KBit/s, bei O2 bekomme ich eine ADSL2+ rate adaptive, was bei meiner Dämpfung noch gut 12MBIt/s ausmachen sollte.

    Die MSNs hatte ich vorher schon zu Sipgate portiert. Darunter war auch eine dreistellige Rufnummer, die ich auf keinen Fall verlieren will. Deshalb habe ich auch abgewartet, bis die Portierung abgeschlossen war, bevor ich den neuen Auftrag für den Zugang erteilt habe. Die Folge: Ich habe derzeit keinen eigenen Internetzugang (zu Hause).

    Damit ich zumindest ins Netz kann für Mail, News, eBay und Co. habe ich mich mit meiner Nachbarin geeinigt, daß ich ihren Zugang mitnutzen darf. Die Verbindung wird über WLAN hergestellt und steht soweit. Surfen, Mail und alles funktioniert auch soweit (sogar ICQ), aber SIP eben nicht. Das war mir eigentlich vollkommen Wumpe, doch wie es scheint, verzögert sich der Anschluß bei O2 noch etwas, weshalb ich halb aus Notwendigkeit und halb aus Spieltrieb gerne SIP funktionsfähig machen würde.

    Das Problem:
    Wegen der Tatsache, daß ich meinen Internetzugang nicht selber in der Hand habe und ich gleichzeitig weder mein LAN noch das meiner Nachbarin irgendwie groß verändern wollte, steht jetzt folgendes Netz:


    Mein LAN (192.168.100.0)
    |
    |
    |
    Fritzbox 7270 (192.168.100.250) mit aktueller "Laborware"
    |
    |
    |
    Siemens SE505v1 (192.168.100.240 LAN-seitig) mit DD-WRT v23SP2
    | (192.168.2.100 WLAN-seitig) als WLAN Client
    |
    |
    Arcor EasyBox A 600 (192.168.2.1) von meiner Nachbarin
    | \
    | \
    | \
    | \
    Internet LAN meiner Nachbarin (192.168.2.0)

    In meinem LAN läuft ein unabhängiger DHCP-Server, der statische Adressen an bekannte Rechner vergibt. Die Fritz und der SE505 beziehen keine Adresse sondern haben ihre direkt vorgegeben (beim SE505 trifft das für beide Adressen zu). Standardgateway ist die Fritz. Wenn ich irgendwann mal wieder einen eigenen Zugang habe, muß ich nur in der Fritz etwas ändern. Die Fritz ist derzeit konfiguriert als IP-Client und hat als Standardgateway den SE505. Der SE505 hat als Standardgateway 192.168.2.1 eingestellt.

    Das funtkioniert für viele Sachen (wie oben erwähnt) auch ganz gut. Ein mtr sieht richtig cool aus. :) Sip funktioniert aber nicht so richtig.

    Ganz ohne Einstellungen (also ohne Portforwarding und Co.) funktioniert SIP bei Sipgate teilweise. Die Anmeldung klappt, ausgehende Anrufe klappen auch hin und wieder. Gleiches gilt für ankommende Anrufe. Wenn mal eine Verbindung da ist, können sich die Parteien auch unterhalten. "Einseitige" Gespräche hatte ich bislang noch nicht. Aber, das klappt halt eben nicht immer.

    Ich habe noch ein paar Sip-Rufnummern von der Arbeit, die ich mir mit nach Hause nehme, wenn ich nicht im Büro bin. Diese Rufnummern sind von 1&1. Da klappt die Anmeldung gar nicht.

    Dann habe ich versucht, mit Portfarwarding die Sache zu entschärfen. Folgendes habe ich gemacht (Portnummern sind die Eingangsports):

    6050-6060 6068-6097
    Arcor Easybox
    |
    |
    6050-6060 6068-6097
    Siemens SE505
    |
    |
    5050-5060 7068-7097
    Fritzbox 7270

    Stun-Server sind eingerichtet.
    Interessanterweise hat das zur Folge, daß SIP jetzt gar nicht mehr geht. Ich kann nicht mehr raustelefonieren und angerufen werden kann ich auch nicht mehr. Es kommt nur die Meldung "Der gewünschte Gesprächspartner [...]" Interessant dabei ist, daß ich bei Sipgate grünes Licht bekomme (angemeldet), während ich bei 1&1 nur Timeouts kassiere.

    Nun die Frage an die Experten: Gibt es einen Brandheißen Tip, wie ich das zum Laufen bringe? Habe ich (mal wieder) nur etwas übersehen?

    Beste Grüße und ein schönes Wochenende!
    Christian