.titleBar { margin-bottom: 5px!important; }

zaphfc bringt beim laden 0 channels configured.

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von anfänger, 26 Nov. 2004.

  1. anfänger

    anfänger Neuer User

    Registriert seit:
    21 Okt. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ich arbeite mit fedora core 2 einer fcpci karte, die läufft und das auch ohne probleme (anrufe von extern gehen rein) nun will ich neine isdn-anlage zum telefonieren nutzen habe mit bristuff 0.2.0 das ganze installiert

    will nun make loadNT machen und erhalte
    Code:
    [root@server zaphfc]# make loadNT
    make -C /usr/src/linux-2.6 SUBDIRS=/home/pl/cache/bristuff-0.2.0-rc2a/zaphfc modules
    make[1]: Entering directory `/usr/src/linux-2.6.8-1.521'
      Building modules, stage 2.
      MODPOST
    *** Warning: "zt_register" [/home/pl/cache/bristuff-0.2.0-rc2a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_transmit" [/home/pl/cache/bristuff-0.2.0-rc2a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_receive" [/home/pl/cache/bristuff-0.2.0-rc2a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_ec_chunk" [/home/pl/cache/bristuff-0.2.0-rc2a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_unregister" [/home/pl/cache/bristuff-0.2.0-rc2a/zaphfc/zaphfc.ko] undefined!
    make[1]: Leaving directory `/usr/src/linux-2.6.8-1.521'
    modprobe zaptel
    insmod ./zaphfc.ko modes=1
    ztcfg -v
    
    Zaptel Configuration
    ======================
    
    
    0 channels configured.
    
    und asterisk startet dann logischer weise nicht mit:
    Code:
     [chan_zap.so] => (Zapata Telephony w/PRI)
      == Parsing '/etc/asterisk/zapata.conf': Found
    Nov 26 12:53:38 WARNING[-151057760]: chan_zap.c:824 zt_open: Unable to specify channel 1: No such device or address
    Nov 26 12:53:38 ERROR[-151057760]: chan_zap.c:6316 mkintf: Unable to open channel 1: No such device or address
    here = 0, tmp->channel = 1, channel = 1
    Nov 26 12:53:38 ERROR[-151057760]: chan_zap.c:9859 setup_zap: Unable to register channel '1-2'
    Nov 26 12:53:38 WARNING[-151057760]: loader.c:334 ast_load_resource: chan_zap.so: load_module failed, returning -1
      == Unregistered channel type 'Tor'
      == Unregistered channel type 'Zap'
    Nov 26 12:53:38 WARNING[-151057760]: loader.c:429 load_modules: Loading module chan_zap.so failed!
    
    weiss jemand rat?

    danke anfänger
     
  2. jensx

    jensx Neuer User

    Registriert seit:
    20 Okt. 2004
    Beiträge:
    124
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Dresden
    Da scheint er wohl die Karte nicht zu finden. Die Warnings sind übrigens normal. wie sieht denn die /etc/asterisk/zapata.conf und wichtiger /etc/zaptel.conf aus? evtl. nimmt er auch die zaptel.conf aus dem Make-Verzeichnis.

    mit zttool kann man den Status der Karte prüfen, während man mit wiederholten ztcfg vorsichtig sein muß, da gab es bei mir hinterher ein Problem bei der Nutzung aus dem Asterisk.
     
  3. anfänger

    anfänger Neuer User

    Registriert seit:
    21 Okt. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke er hatte eine falsche zaptel.conf genommen

    nun gehts etwas weiter!

    abfänger