zaphfc-treiber funktioniert nicht

Pirx

Neuer User
Mitglied seit
26 Mai 2004
Beiträge
15
Punkte für Reaktionen
0
Punkte
0
Hallo,
gibt es hier möglicherweise jemanden, der sich mit dem zaphfc-treiber und dem hfc-s -chip auskennt und mir weiterhelfen kann oder jemanden kennt, der das könnte?
(ich hoffe, es ist nicht zu speziell und/oder OT hier, falls ja, sry)

ich versuche, den treiber auf freebsd zum laufen zu bringen (war bisher fast nur nur copy und paste). Das Problem ist leider, das die karte nicht mit dem fifo im system-speicher zusammenarbeitet. Ich kriege dann nur die Meldung

"zaphfc: bchan rx fifo not enough bytes to receive! (z1=xx, z2=xx, wanted 8 got 1), probably a buffer overrun)"

und das natürlich bei dem interrupt zwei mal, das schafft ...
(xx steht für 0x1FF, dem default-wert) .
Der fifo wird korrekt initialisiert mit den zählern nach dem soft-reset, die karte kennt den fifo also. der treiber lädt auch fleissig in den fifo rein wie er soll, nur die karte scheint es nie abzuholen :(
ich weiss echt nicht mehr weiter, hab schon so viel versucht und verzweifel langsam. achso, unter linux läuft das teil, ist nicht kaputt.

vielen dank,
mfg jörg
 

Pirx

Neuer User
Mitglied seit
26 Mai 2004
Beiträge
15
Punkte für Reaktionen
0
Punkte
0
zaphfc-treiber funktioniert [erledgt.] - neues problem

der treiber funktioniert, yippee (schreibfehler, grr).. aber gleich ein neues problem:

mein (!) telefon legt nicht auf, wenn der anrufer vor ablauf des timeouts in der entsprechenden extension auflegt.

das entsprechende sip-packet von sipgate zum auflegen kommt an (CANCEL), wird aber leider ignoriert. bin mir recht sicher, das es am zaptel liegt, hat eventuell jemand eine idee?
(weiss leider nicht, wo zaptel mit dem chan_zap diesbezüglich interagiert, sind beide einfach zu gross)

danke im voraus,
bye jörg
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,107
Beiträge
2,030,188
Mitglieder
351,444
Neuestes Mitglied
w.hess