.titleBar { margin-bottom: 5px!important; }

Zwei Fritz Boxen hintereinander, Probs mit Telefonie an der zweiten FB

Dieses Thema im Forum "FRITZ!Box Fon: Telefonie" wurde erstellt von timm2k, 25 Nov. 2006.

  1. timm2k

    timm2k Gesperrt

    Registriert seit:
    16 Okt. 2006
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 timm2k, 25 Nov. 2006
    Zuletzt bearbeitet: 25 Nov. 2006
    Moin Community,

    das Thema "zwei Fritzboxen hintereinander" wurde ja schon mehrfach diskutiert und bei den meisten scheint es bezüglich der Telefonie auch wohl Problemlos zu laufen. Bei mir leider nicht.

    Erstmal zum Aufbau: ich habe einen analogen Anschluss von den T-eletubbies 1und1 3dsl mit einer FB 7170 als DSL-Router. "Dahinter" ist eine FB Fon WLan. Diese steht in einem anderen Gebäude. Sie ist bezüglich der Netzwerkeinstellungen korrekt als Client eingerichtet.

    An der 7170 sind 5 SIP-Accounts (4x 1und1, 1 SIPGATE) eingerichtet und funktionieren auch problemlos. Um weitere Telefone anzuschließen, hängt noch eine ISDN-Anlage am abgehenden S0-Bus der FB. Wie gesagt, dort funktioniert alles problemlos.

    An der FB Fon WLan ist ein weiterer SIPGATE-Account eingerichtet. Die Registrierung bei SIPGATE funktioniert. Man kann wählen und angerufen werden. Leider funktioniert die Sprachübertragung von der FB Fon WLan nur in abgehender Richtung. (Ich kann sprechen, gegenüber hört mich, leider höre ich mein gegenüber nicht.)

    Den Account habe ich nach den Vorgaben von SIPGATE eingerichtet (kein Proxy, kein STUN).

    An der 7170 ist UPNP für Portweiterleitungen aktiviert.

    Wäre schön, wenn mir jemand bei der Beseitigung der Taubheit helfen kann.


    Gruß
    Timm

    Nachtrag Firmwarestände:
    7170: 29.04.28-5184
    Fon WLan: 08.04.15
     
  2. mb28658

    mb28658 Neuer User

    Registriert seit:
    18 Mai 2006
    Beiträge:
    139
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Beruf:
    Support-Techniker
    Ort:
    Bez.St.Pölten
    Hallo Timm,
    habe (oder hatte) ähnliche Probleme.
    Bei mir waren die Boxen aber im Lan.
    Die Erste Box als Router direkt mit DSL verbunden die zweite als IP-Klient im LAN.
    An beiden Boxen die identischen Accounts eingerichtet.
    Habe von AVM folgende Info bekommen.
    Im LAN-Modus IMMER den STUN-Server eintragen und die Portweiterleitung (Internettel/Erweiterte Einst.)für IP-Tel auf AKTIV halten !

    mfg

    Michael
     
  3. timm2k

    timm2k Gesperrt

    Registriert seit:
    16 Okt. 2006
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Michael,

    danke für deine Antwort. Ich habe die beiden Fritzboxen auch in einem LAN (nicht per WLAN) verbunden. Die Option "Portweiterleitung des Internet-Routers für Internettelefonie aktiv halten" ist aktiv (refresh: 1 min).

    Sobald ich den sipgateschen STUN-Server (stun.sipgate.de:10000, oder auch ohne Port) angebe, meldet die hintere FB

    "Internettelefonie war nicht erfolgreich. Ursache: Temporarily not available (480)"

    Ich denke, das Problem ließe sich lösen, wenn ich SIP- und RTP-Port ändern könnte.

    In einem Backup der Konfig kann ich auch sehen, dass AVM den STUN-Port wohl fest verdrahtet, was im Falle SIPGATE der falsche Port ist.

    Ich habe mir gedacht, ich könnte die voip.cfg unter /var/flash einfach editiern. Leider sind dort alle Configs augenscheinlich leer. Des weiteren haben sie ein c-Flag in den Dateiberechtigungen. (Ist wohl der Grund dafür, dass sie ihren Inhalt nicht preisgeben.)

    Weiß noch jemand rat? Sonst bemühe ich den AVM-Support.

    Schonmal danke :)
     
  4. timm2k

    timm2k Gesperrt

    Registriert seit:
    16 Okt. 2006
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe das Problem gelöst.

    die voip.cfg ließen sich mit nvi /var/flash/voip.cfg editieren. Man darf wohl vorher nicht das Verzeichnis aufsuchen, da man sonst eine leere Datei angezeigt bekommt.

    FB Fon WLan: In der voip.cfg habe ich den DNS- und RTP-Port für den SIP-Account geändert (7077 -> 8077, 7078 -> 8078). Zusätzlich habe ich den SIP-Port mit voipd -p auf 5070 eingestellt.

    FB 7170: Portweiterleitungen für 8077 - 8078, 5070 auf FB Fon WLan.