[Problem] [7390] make bricht ab bei wget-gnu mit SSL

hssuhle

Neuer User
Mitglied seit
16 Mai 2005
Beiträge
174
Punkte für Reaktionen
0
Punkte
16
Code:
checking for libssl... no
configure: error: --with-ssl=openssl was given, but SSL is not available.

ERROR: Build failed.
make: *** [source/target-mips_uClibc-0.9.31.1/wget-1.13.4/.configured] Fehler 1

HILFÄÄÄÄÄÄ!

(die .config hänge ich mal an...)
 

Anhänge

  • config.txt
    27.5 KB · Aufrufe: 6

sf3978

IPPF-Promi
Mitglied seit
2 Dez 2007
Beiträge
8,014
Punkte für Reaktionen
28
Punkte
48
Brauchst Du beide wget? -gnu und aus der busybox? Versuch mal ohne das wget aus der busybox.
Code:
FREETZ_PACKAGE_WGET=y
Code:
FREETZ_[COLOR=red]BUSYBOX_[B]WGET[/B][/COLOR]=y
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,787
Punkte für Reaktionen
13
Punkte
38
Da es bei mir funktioniert würde ich vermuten, dass es auch bei dir mit einem frischen Checkout durchläuft? (Um ehrlich zu sein ging es nicht auf Anhieb, da es mit der gcc-Version in der Toolchain aus der gcc-4.6.2 Download Toolchain Konflikte gab...)

Gruß
Oliver
 

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Da die Abhängigkeiten in der Make-Datein drin stehen, wäre es interessant zu sehen, warum configure meint, dass kein SSL verfügbar wäre.
 

hssuhle

Neuer User
Mitglied seit
16 Mai 2005
Beiträge
174
Punkte für Reaktionen
0
Punkte
16
Da es bei mir funktioniert würde ich vermuten, dass es auch bei dir mit einem frischen Checkout durchläuft? (Um ehrlich zu sein ging es nicht auf Anhieb, da es mit der gcc-Version in der Toolchain aus der gcc-4.6.2 Download Toolchain Konflikte gab...)

Gruß
Oliver

Hi Oliver,

Ich hatte gerade komplett neu ausgecheckt. Komplett wieder von Null angefangen...
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,787
Punkte für Reaktionen
13
Punkte
38
@Ralf
Ich hatte das Problem durch die Umstellung der Download-Toolchain auf gcc-4.6.2 und zurück auf 4.5.3. wget hat im 4.5.3 Verzeichnis nach den Headern gesucht und openssl hat sie nach 4.6.2 kopiert.

Gruß
Oliver
 

hssuhle

Neuer User
Mitglied seit
16 Mai 2005
Beiträge
174
Punkte für Reaktionen
0
Punkte
16
@Oliver:

Hst Du den Pfad gefixt?
 

hssuhle

Neuer User
Mitglied seit
16 Mai 2005
Beiträge
174
Punkte für Reaktionen
0
Punkte
16
Wie bekomme ich das Paket jetzt compiliert? Welchen Pfad muss ich wie anpassen?
 

sf3978

IPPF-Promi
Mitglied seit
2 Dez 2007
Beiträge
8,014
Punkte für Reaktionen
28
Punkte
48
Wie bekomme ich das Paket jetzt compiliert?
Füge in der wget.mk, zwischen den vorhandenen blauen Zeilen, die rote Zeile ein und mach "make wget-precompiled":
Code:
...
[COLOR=blue]$(PKG)_DEPENDS_ON += openssl[/COLOR]
[COLOR=red][B]$(PKG)_CONFIGURE_ENV += ac_cv_libssl=yes[/B][/COLOR]
[COLOR=blue]$(PKG)_CONFIGURE_OPTIONS += --with-ssl=openss[/COLOR]
...
Code:
...
mkdir -p packages/target-mips_uClibc-0.9.31.1/wget-1.13.4/root/usr/bin/; cp source/[COLOR=red][B]target-mips[/B][/COLOR]_uClibc-0.9.31.1/wget-1.13.4/src/wget packages/target-mips_uClibc-0.9.31.1/wget-1.13.4/root/usr/bin/wget; /home/gm/myfreetz/freetz8531/trunk/toolchain/build/mips_gcc-4.5.3_uClibc-0.9.31.1/mips-linux-uclibc/bin/mips-linux-uclibc-strip --remove-section={.comment,.note,.pdr} packages/target-mips_uClibc-0.9.31.1/wget-1.13.4/root/usr/bin/[COLOR=red][B]wget[/B][/COLOR];
[COLOR=red][B]done.[/B][/COLOR]
 

hssuhle

Neuer User
Mitglied seit
16 Mai 2005
Beiträge
174
Punkte für Reaktionen
0
Punkte
16
ok, klasse! Der Tipp war schon mal ziemlich cool.
wget-gnu hat ohne zu zucken compiliert.

Wozu war die Zeile am Ende? Die habe ich stumpf ignoriert.
 

sf3978

IPPF-Promi
Mitglied seit
2 Dez 2007
Beiträge
8,014
Punkte für Reaktionen
28
Punkte
48
Wozu war die Zeile am Ende?
Die ist nur zur Info. Wenn Du ldd auf deiner Box hast, dann poste bitte die Ausgabe von:
Code:
[COLOR=red]ldd /usr/bin/wget-gnu[/COLOR]
wenn Du das wget-gnu auf deiner Box hast.
 

hssuhle

Neuer User
Mitglied seit
16 Mai 2005
Beiträge
174
Punkte für Reaktionen
0
Punkte
16
Das dauert noch etwas.

Jetzt compiliere ich erst mal dsniff, sofern es durchläuft ;-)
 

sf3978

IPPF-Promi
Mitglied seit
2 Dez 2007
Beiträge
8,014
Punkte für Reaktionen
28
Punkte
48
..., sofern es durchläuft ;-)
Ich denke es wird nicht durchlaufen. Lösche das Verzeichnis "make/dsniff" und wende den neuen Patch aus dem Anhang an. Vor dem "make dsniff-precompiled", die Änderung in der db-lib (--enable-compat185) nicht vergessen.
 

Anhänge

  • dsniff_7390.patch.txt
    63 KB · Aufrufe: 2
  • dsniff_280112.patch.txt
    64.7 KB · Aufrufe: 1
Zuletzt bearbeitet:

hssuhle

Neuer User
Mitglied seit
16 Mai 2005
Beiträge
174
Punkte für Reaktionen
0
Punkte
16

sf3978

IPPF-Promi
Mitglied seit
2 Dez 2007
Beiträge
8,014
Punkte für Reaktionen
28
Punkte
48

hssuhle

Neuer User
Mitglied seit
16 Mai 2005
Beiträge
174
Punkte für Reaktionen
0
Punkte
16
Hatte sie auch gerade gefunden - mal sehen, was passiert
 

hssuhle

Neuer User
Mitglied seit
16 Mai 2005
Beiträge
174
Punkte für Reaktionen
0
Punkte
16
Fertig. Durchgelaufen. Keine Fehler.

Ich werde jetzt die Box fertig machen, die fehlenden Pakete compilieren, und sie dann später ausliefern. Ich hoffe, dass heute alles klappt.

Daumen drücken!

Danke für Eure kompetente und superschnelle Hilfe!
 

sf3978

IPPF-Promi
Mitglied seit
2 Dez 2007
Beiträge
8,014
Punkte für Reaktionen
28
Punkte
48

hssuhle

Neuer User
Mitglied seit
16 Mai 2005
Beiträge
174
Punkte für Reaktionen
0
Punkte
16
dnsspoof arbeitet genau so wie du geschrieben hast.
Alle DNS-Abfragen werden auf die Box umgeroutet.

COOOOOOL!
 

Statistik des Forums

Themen
241,462
Beiträge
2,164,313
Mitglieder
365,949
Neuestes Mitglied
MichaR1955
Holen Sie sich 3CX - völlig kostenlos!
Verbinden Sie Ihr Team und Ihre Kunden Telefonie Livechat Videokonferenzen

Gehostet oder selbst-verwaltet. Für bis zu 10 Nutzer dauerhaft kostenlos. Keine Kreditkartendetails erforderlich. Ohne Risiko testen.

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.