.titleBar { margin-bottom: 5px!important; }

[Problem] asterisk 1.8 + Aastra 55i + AudioCodes Mediant 2000 MediaGateway SIP

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Worfinator, 22 Feb. 2012.

  1. Worfinator

    Worfinator Neuer User

    Registriert seit:
    29 Dez. 2005
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Moin zusammen!

    Ich habe einen asterisk 1.8 + Aastra 55i Hardphones + AudioCodes Mediant 2000 MediaGateway laufen. Das GW kommuniziert mit dem asterisk per SIP. An dem GW hängt ein PMXer mit 30 Kanälen von Versatel. Auf dem PMXer läuft Clip no Screening.
    Ich kann auch prima rein und raus telefonieren. Auch mit beliebiger übermittelter Rufnummer dank Clip no Screening. Alles total super.

    Bis auf eine ganz klitze kleine Kleinigkeit die mich aber total nervt:
    Setze ich auf einem Aastra 55i eine Rufumleitung nach extern, z.B. auf ein Handy schaffe ich es nicht die urspüngliche Rufnummer des Anrufers an den externen Anschluss weiterzureichen.
    Ich habe hier schon umfangreich gedebuggt, die Rufnummer wir korrekt gesetzt.
    Das Format der Rufnummer und der Wählplan E.164 sind auch korrekt. Sonst würd es ja auch bei normalen ausgehenden Anrufen nicht klappen. Die Caller Number kommt auch korrekt auf dem GW an als "From". Allerdings wird die Presentation der Rufnummer immer auf privat gesetzt, so dass das externe Ziel der Rufumleitung keine Nummer sieht.
    Auf dem GW habe ich "Presentation" auf Allowed geschaltet. Mehr geht dort nicht, keine Möglichkeit das ganze zu erzwingen.
    Aus irgendwelchen Gründen setzt mein Freund der asterisk in diesem speziellen Fall das Flag für unterdrücken. Mir gelingt es nicht, ihm dieses Verhalten bei der durch das Aastra 55i ausgelösten Rufumleitung abzugewöhnen.

    Wie kann man die Übermittlung der Rufnummer mit dem asterisk erwingen?
    Geht das irgendwie?

    Anbei ein Auszug aus der extensions.conf zum Rauswählen auf deutsche Ziele:
    ...
    exten => _X.,n,Set(CALLERID(num)=${CANI})
    exten => _X.,n,Dial(${TRUNK}/0049${EXTEN:2},120)
    exten => _X.,n,Hangup()

    Vielen Dank für eure Hilfe
     
  2. abw1oim

    abw1oim Aktives Mitglied

    Registriert seit:
    26 März 2007
    Beiträge:
    946
    Zustimmungen:
    1
    Punkte für Erfolge:
    18
    Ort:
    Bonn
    Unbeachtlich der Tatsache, dass mir auch nicht einfällt, warum in diesem Szenario der Asterisk meint, prohib zu nutzen, kannst Du mal folgendes machen:

    Code:
    exten => _X.,n,Set(CALLERID(num)=${CANI})
    exten => _X.,n,Set(CALLERPRES()=allowed_not_screened)
    exten => _X.,n,Dial(${TRUNK}/0049${EXTEN:2},120)
    exten => _X.,n,Hangup()
    Zumindest nach Dokulage sollte das an einem CLIP NO SCREENING-Anschluß zur RN-Übermittlung führen.
     
  3. afro

    afro Neuer User

    Registriert seit:
    18 Nov. 2004
    Beiträge:
    52
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nach langem Hin und Her und schlaflosen Nächten und vielen Tests mit dem Worfinator hier die Lösung:

    In die sip.conf muss folgendes eingetragen werden:
    ;Rufnummernübermittlung für externe Calls
    sendrpid=yes
    ;Rufnummernübermittlung für interne Calls
    callingpres=allowed_passed_screen