Asterisk + T-Online

lord-of-linux

Mitglied
Mitglied seit
3 Dez 2005
Beiträge
568
Punkte für Reaktionen
1
Punkte
0
Hallo,

ich arbeite mich gerade anhand des betateilchen-Workshops in den Asterisk ein. Intern funktioniert das alles schon super. Nun bin ich allerdings bei der Einrichtung meines externen SIP-Accounts. Der ist von T-Online. Da es nicht funktioniert hat, war ich ein bisschen hier im Forum unterwegs und habe unter anderem aus folgenden Threads die Varianten zum T-Online-Einbinden probiert:
http://www.ip-phone-forum.de/showthread.php?t=71600
http://www.ip-phone-forum.de/showthread.php?t=89553
und ein paar Anderen.

Zur Zeit läuft der Asterisk natürlich hinter der Fritz!Box. Allerdings will ich mal Asterisk on FBF installieren. Allerdings erst, wenn der Rest soweit funktioniert.

Hier mal mein aktueller Config-Versuch:
sip.conf
Code:
;
; SIP Configuration for Asterisk
;


[general]
context=default
allowguest=no
bindport=5060
bindaddr=0.0.0.0
srvlookup=yes

register => 03xxxxxxx:pw:[email protected]:5060/032xxxxxxx

[t-online-out]
type=friend
username=email
secret=passwort
host=tel.t-online.de
fromuser=032XXXXXXX
fromdomain=tel.t-online.de
canreinvite=yes
qualify=500
disallow=all
allow=ulaw
insecure=very
nat=yes
dtmfmode=inband


[t-online-in] 
type=peer
fromdomain=tel.t-online.de
host=tel.t-online.de
disallow=all
allow=ulaw
context=sip-in


;
;Die internen Geräte, aber die funktionieren ja
;
Hier noch die extensions.conf:
Code:
[general]
static=yes
writeprotect=no

; --------------------------------------------------------------------
; Es hat sich als gute Praxis erwiesen, die Inhalte der Datei
; extensions.conf modular aufzubauen. Diese Praxis wollen
; wir auch hier anwenden
;

[lokal]
; Erreichbarkeit der Nebenstellen 30-39
; untereinander herstellen

exten => _3X,1,NoCDR()
exten => _3X,n,Dial,SIP/${EXTEN}|55|Ttr

; für das IAX Geraet aus Exkurs 1 stellen wir hier die Erreichbarkeit her
;
exten => 40,1,NoCDR()
exten => 40,n,Dial,IAX2/40|55|Ttr


[t_online_out]
exten => _0.,1,SetCIDName(032XXXX)
exten => _0.,2,Dial,SIP/${EXTEN}@t-online-out|45|r


[sip-in]
exten => 032XXXXXXX,1,Dial,SIP/30|30|r


[echotest]
exten => 81,1,answer
exten => 81,2,wait,1
exten => 81,3,playback,demo-echotest
exten => 81,4,echo
exten => 81,5,playback,demo-echodone
exten => 81,6,hangup

; --------------------------------------------------------------------
;
; hier kommt der default-Context, in dem alle Geraete in der
; Grundkonfiguration erstmal laufen.
; Alle Geraete koennen sich gegenseitig anrufen

[default]
include => lokal
include => echotest
include => t_online_out
Allerdings will der Asterisk sich einfach nicht verbinden.

wenn ich das ganze beobachte, dann sieht es so aus:
Code:
[B]server*CLI> sip show peers[/B]
Name/username              Host            Dyn Nat ACL Port     Status
32/32                      10.0.0.2         D   N      5060     Unmonitored
31/31                      192.168.213.10   D   N      5060     Unmonitored
30/30                      192.168.213.2    D   N      51988    Unmonitored
t-online-in                217.0.132.118               5060     Unmonitored
t-online-out/mailadresse  217.0.132.118        N      5060     OK (26 ms)
5 sip peers [5 online , 0 offline]

[B]server*CLI> sip show registry[/B]
Host                            Username       Refresh State
tel.t-online.de:5060            032XXXXX       120 Request Sent

((Hinweis: Manchmal sieht es auch so aus (bspw. nach reload):)
[B]server*CLI> sip show registry[/B]
Host                            Username       Refresh State
tel.t-online.de:5060            032XXXXX       120 Auth. Sent
Anrufe auf die T-Onlinenummer werden nicht signalisiert (in der CLI merke ich auch nichts), ausgehende Versuche werden mit "The person you are calling..." von X-Lite beendet und aus der CLI bekomme ich folgendes:
Code:
Sep 14 12:43:07 WARNING[11611]: pbx.c:2415 __ast_pbx_run: Timeout, but no rule 't' in context 'default'

Kann mir jemand bei meinem Problem helfen? Ich hoffe ich habe alles relevante aufgelistet.
 

stinkstiefel

Aktives Mitglied
Mitglied seit
19 Feb 2006
Beiträge
1,664
Punkte für Reaktionen
0
Punkte
0
In deiner sip.conf fehlt externip=
Portforwardings für Sip hast du in der Fritz!Box gemacht?
Nur ulaw erlauben ist etwas dürftig es darf ruhig etwas mehr sein.
 

lord-of-linux

Mitglied
Mitglied seit
3 Dez 2005
Beiträge
568
Punkte für Reaktionen
1
Punkte
0
stinkstifel schrieb:
In deiner sip.conf fehlt externip=
OK, werde ich nachtragen.
stinkstifel schrieb:
Portforwardings für Sip hast du in der Fritz!Box gemacht?
Welche Ports brauche ich? Ich dachte, nur das Registrieren funktioniert normal auch so.
stinkstifel schrieb:
Nur ulaw erlauben ist etwas dürftig es darf ruhig etwas mehr sein.
Hatte auch schon mehr drin. Habe halt den Rest dann auch wieder rausgenommen, ging sowieso genausowenig. Welches ist den der beste Codec? Mit der Geschwindigkeit sollte es ja bei 16.000er kein Problem sein.
 

stinkstiefel

Aktives Mitglied
Mitglied seit
19 Feb 2006
Beiträge
1,664
Punkte für Reaktionen
0
Punkte
0
Welche Ports du mit asterisk nutzt und somit auch weiterleiten musst solltest du schon wissen.
5060 UDP ist der Standardport für die Registration. (steht auch in deiner sip.conf)
Welchen RTP-Portbereich du eingestellt hast sagt dir deine rtp.conf.
 

rollo

IPPF-Promi
Mitglied seit
5 Jul 2004
Beiträge
8,288
Punkte für Reaktionen
1
Punkte
38
Hinter der Fritz!Box wird das nix mit bindport=5060, den musst du ändern und entpechend forwarden in der Box.

jo
 

lord-of-linux

Mitglied
Mitglied seit
3 Dez 2005
Beiträge
568
Punkte für Reaktionen
1
Punkte
0
Hallo stinkstifel,

danke schonmal für deine Hilfe. Allerdings funktioniert es immer noch nicht. Habe deine Tipps umgesetzt, das mit der Registrierung sieht aber noch genauso aus. Habe nun noch notice für die cli aktiviert und bekomme ständig folgenden:
Code:
Sep 14 17:53:40 NOTICE[5598]: chan_sip.c:5387 sip_reg_timeout:    -- Registration for '[email protected]' timed out, trying again (Attempt #10)
Irgend eine Idee, wie ich das zum laufen bringen könnte?
 

FunkyFish

Neuer User
Mitglied seit
7 Sep 2006
Beiträge
11
Punkte für Reaktionen
0
Punkte
0
Hallo,

ich bin grad auch am betateilchen-workshop ;) und hatte das gleiche Problem wie du.
Ein wenig googlen hat mir folgenden Link gebracht:
http://simon.baatz.info/index.php/asterisk-konfiguration-fur-dsl-telefonie-uber-t-online/

Dabei ist folgendes mein Problem gewesen:
Code:
Im Abschnitt general sind folgende besondere Einträge nötig:

[general]
…
;Note: T-Online seems to need 240 seconds at least!
defaultexpirey=600 ; Default length of incoming/outgoing registration
T-Online braucht wohl etwas länger :)

Gruß
-Fufi-
 

lord-of-linux

Mitglied
Mitglied seit
3 Dez 2005
Beiträge
568
Punkte für Reaktionen
1
Punkte
0
Zuletzt bearbeitet:

3CX PBX - GRATIS
Linux / Win / Cloud

Neueste Beiträge

Statistik des Forums

Themen
232,348
Beiträge
2,021,409
Mitglieder
349,904
Neuestes Mitglied
Tomi07