.titleBar { margin-bottom: 5px!important; }

Asterisk unter SuSE 9.2 -> rcasterisk start failed

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von jui, 19 Dez. 2004.

  1. jui

    jui Mitglied

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    229
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Habe heute ein SuSE 9.2 installiert und manuell nachträglich die asterisk-rpms auch noch draufgeworfen um out-of-the-box asterisk kennenzulernen.
    Alle Abhängigkeiten wurden sauber aufgelöst und ich habe neben astersik auch noch das asterisk-capi-rpm und weitere rpm (alles ausser zaptel) mal installiert.
    Im Rechner habe ich eine AVM B1 PCI V.3 und eine FritzCard PCI steckne, beide unter SuSE mit Capi 2 am laufen. Ich bin allerdings auch kein Linux-Guru aber ausreichend Basiskenntnisse um das hinzukriegen habe ich - wie ich meine - doch.

    Die ISDN-Karten sind noch nicht mit dem ISDN-S0-Bus verbunden.
    Der Aufruf "rcasterisk start" führt zu einem "failed". Ein manueller Start von asterisk mit den Parametern -rvvvgc führt zu einer Fehlermeldung wie in folgendem Thread beschrieben:
    http://www.ip-phone-forum.de/forum/viewtopic.php?t=7853

    Fehlermeldung:
    Code:
    app_capiCD.so]Dec 8 23:28:28 WARNING[1076836992]: loader.c:242 ast_load_resource: /usr/lib/asterisk/modules/app_capiCD.so: undefined symbol: capidebug
    Dec 8 23:28:28 WARNING[1076836992]: loader.c:423 load_modules: Loading module app_capiCD.so failed!
    
    Wer kann helfen und wie kann ich den Fehler eingrenzen?

    Bin für jede Hilfe dankbar ... wenn das erstmal läuft werden VIELE weitere Fragen kommen :)

    Gruß,

    Jui
     
  2. sabersoft

    sabersoft Neuer User

    Registriert seit:
    29 Okt. 2004
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hmm,

    also den Asterisk aus dem Source zu übersetzen ist einfacher als sich mit solchen Fehlern rumzuärgern.

    Wie es scheint brauchst du nur das Asterisk-1.0.3.tar.gz und das chan_capi-0.3.5.tar.gz (von junghanns).

    Zuerst den Asterisk besorgen, entpacken und mal nen make machen. Falls irgendwas Fehlen sollte , meckert er schon ;) und mit etwas geschick sieht man sofort was fehlt und was man nachinstallieren sollte.
    wenn das geschafft ist ein "make install" und alles wird in die jeweiligen Verzeichnisse kopiert. Wenn man beispieldateien möchte (conf etc) dann noch ein "make samples".

    Dann chan_capi besorgen, entpacken und ein make machen, wenn dies auch sauber durchläuft, ohne FEHLER, dann alles so machen wie es in der README steht ( Dateien kopierne, die Capi.conf nach /etc/asterisk kopieren und anpassen) und die modules.conf anpassen. Steht vieles auf http://voip-info.org/tiki-index.php?page=Asterisk

    Ronny
     
  3. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Wie ich zwischenzeitlich festgestellt habe, funktioniert auch zaptel in 9.2 nicht sauber. Die Treiber werden zwar geladen aber in Asterisk stehen die Kanäle nicht zur Verfügung. Das Device wird anscheinend nicht angelegt.

    Nachdem mir meine Frau zwischenzeitlich gedroht hat, den Rechner und mich auf die Strasse zu setzen, muß ich wohl das ganze Asterisk in die Ecke stellen.
    Um so tief in Linux einzusteigen, dass ich das Zeug komplett selbst compilieren kann, fehlt mir die Zeit.

    Bevor jetzt wieder dumme Bemerkungen von Linux-Gurus kommen, ich empfehle von euch auch nicht, dass ihr den Rechner selbst baut, wenn er nicht bootet.