[Gelöst] be.ip plus SIP Fehler 407

StephanVo

Neuer User
Mitglied seit
4 Aug 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Hallo miteinander,

Ich stehe gerade vor der Aufgabe eine be.ip plus am Vodafone IP Anlagen Anschluss (Schnittstellenbeschreibung R.4B) zu konfigurieren.

Grundsätzlich kann ich mit den mir zur Verfügung gestellten Daten seitens Vodafone über die Test Rufnummern heraus telefonieren. Allerdings kommt kein Anruf an.

Ich habe aber im SIP trace eine Fehlermeldung die wie folgt lautet: SIP/2.0 407 Proxy Authentication Required.

Daufhin habe ich den Vodafone Support darauf angesprochen. Dem Mitarbeiter kam die Meldung bekannt vor. Eine Proxy Registrierung wäre nicht erforderlich. Nebenbei bemerkte er, er habe noch niemanden beraten der wüsste wo man das abstellen kann (ob er sich auf die be.ip bezog oder generell auf alle Anlagen weiß ich nicht).

Hat jemand eine Ahnung wo und wie ich die Proxy Registrierung abstellen kann?

Gruß
Stephan
 
Zuletzt bearbeitet:

_tms

Neuer User
Mitglied seit
2 Jun 2016
Beiträge
165
Punkte für Reaktionen
14
Punkte
18
Hallo,

MGW oder PBX Modus?

PBX:
Proxy-Feld leer lassen / unter "weitere Einstellungen": Proxy-Anmeldung deaktivieren

MGW:
Ausgehender Proxy leer lassen

Es sieht aber eher nach einem Authorisierungsproblem aus => ggf. mit aktiviertem SRTP probieren.

Oder habe ich deine Anfrage falsch verstanden?
 

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
1,565
Punkte für Reaktionen
145
Punkte
63
407 ist eigentlich ganz normal. Die Frage ist, wer sendet es und wie geht es weiter.

Man bräuchte jetzt genau Dein Endgerät und genau Deinen Tarif, um gezielt zu antworten. Außerdem müssten wir Deine Netz-Topologie kennen, also ob die be.ip plus nicht hinter einem anderen Router, NAT bzw. Firewall sitzt sondern direkt das PPPoE macht.
Kein Anruf kommt an.
Ich kann nur allgemein antworten. Wenn Du auf den WAN-Seite einen Paket-Mitschnitt machst, und dort kommt bei einem Anruf kein SIP-INVITE, dann war das SIP-REGISTER nicht so, wie sich Vodafone das vorstellt. Vodafone schickt das SIP-INVITE dann entweder an die falsche IP oder gar nicht raus. Was hört der Anrufer; wie schnell? Ich würde beim Header Contact anfangen (IP und Port richtig)?
 

StephanVo

Neuer User
Mitglied seit
4 Aug 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Hallo miteinander und danke für die bisherigen Meldungen,


Der Threadtitel ist wegen des Tippfehlers etwas irreführend. Bitte korrigieren.
Korrigiert


[...]
MGW oder PBX Modus?
[...] [Edit Novize: Fullquote auf den notwendigen Teil eingedampft]
PBX Modus

Aufgrund anderer Aufgaben werde ich mich mit dem Thema erst am Donnerstag wieder beschäftigen. Melde mich dann noch mal..

Gruß
Stephan
 
Zuletzt bearbeitet von einem Moderator:

StephanVo

Neuer User
Mitglied seit
4 Aug 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Hallo miteinander,

nach Rücksprache mit Vodafone spielt die Fehlermeldung 407 keine Rolle. Diese wird von Vodafone (laut Schnittstellenbeschreibung) ignoriert.

Das keine externen Gespräche an der Telefonanlage signalisiert wurden lag Wohl daran, dass Vodafone alle 60 Sekunden einen Options PING sendet. Diesen kann man bei Vodafone deaktivieren lassen. Seitdem bin ich auch von extern erreichbar.

Gruß Stephan
 

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
1,565
Punkte für Reaktionen
145
Punkte
63
Das solltest Du an Deinen Einrichter bzw. an Bintec-Elmeg per Brief-Post melden.
SIP-OPTIONS, um die Firewall offen zu halten, sollten im Jahr 2020 kein Problem mehr darstellen.

Wenn die Bintec-Elmeg und nicht Vodafone den Status 407 erzeugt hat, dann ist irgendwas an der Konfiguration schief. Dann ordnet nämlich Bintec-Elmeg die SIP-OPTIONS nicht richtig zu. Auch wenn es jetzt geht, solltest Du Dir das anschauen – könnte nämlich in einer anderen Konstellation Dir wieder auf die Füße fallen.
 

Kalle2006

IPPF-Promi
Mitglied seit
23 Jul 2006
Beiträge
3,220
Punkte für Reaktionen
71
Punkte
48
Da Vodafone ohne SIP-Registrierung arbeitet, will die be.IP plus auch keine SIP-Options Pakete. Im Moment ist die Abschaltung des Options - Ping die richtige Lösung.