.titleBar { margin-bottom: 5px!important; }

benachrichtigung am Snom bei Faxeingang

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von achim22, 27 Sep. 2006.

  1. achim22

    achim22 Neuer User

    Registriert seit:
    20 Okt. 2005
    Beiträge:
    153
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi!
    Würde es gehen, am snom 360, eine Benachrichtigung zu bekommen wenn man ein Fax erhalten hat?

    Oder eine Leuchte von den Funktionstasten "blinkt" die könnte man ja mit Faxempfang beschriften.


    Gruß
     
  2. Ruad

    Ruad Mitglied

    Registriert seit:
    27 Juli 2005
    Beiträge:
    295
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    ein Niederrheiner in Berlin
    Man könnte zum Beispiel über Sipsak eine Nachricht versenden.
    Das mit den blinkenden Tasten beim Snom kann wohl über hints erledigen, wobei hier das Blinken nur anhält, solange das Fax ankommt. (Das Fax "telefoniert")
     
  3. achim22

    achim22 Neuer User

    Registriert seit:
    20 Okt. 2005
    Beiträge:
    153
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe es mal versucht, es kommt leider nichts an

    sipsak -i -M -O desktop -B "test test" -s sip:80@192.168.1.18


    Unter Asterisk CLI erhalte ich aber ein ok.

    Sep 27 15:23:52 WARNING[4082]: chan_sip.c:7417 receive_message: Received message to sip:80@192.168.1.18
    from sip:sipsak@127.0.0.1:1032;tag=49104a7a, dropped it...
    Content-Type:text/plain
    Message: test test

    Systeminformationen:
    Telefontyp:snom360-SIP
    MAC-Adresse:000413237AC7
    IP-Adresse:192.168.1.22
    Kernel Version:Linux 192.168.0.105 2.4.20 #43 Tue Aug 30 12:21:18 CEST 2005 mips
    Applikationsversion:snom360-SIP 6.2.2
    Rootfs-Version:snom360 jffs2 v3.36
    Firmware-URL:http://provisioning.snom.com/release/update.php
    Produktionsinformationen:Mac:000413237AC7;Version:Standard;Hardware:snom360 (MB V1.0_K10,KB
    V1.0_L7-NC);Lot: 07/06

    SIP Identitätsstatus:
    Identität 1 Status:80@192.168.1.18: OK
     
  4. Guard-X

    Guard-X Aktives Mitglied

    Registriert seit:
    14 Mai 2005
    Beiträge:
    2,497
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Aurich
  5. Ruad

    Ruad Mitglied

    Registriert seit:
    27 Juli 2005
    Beiträge:
    295
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    ein Niederrheiner in Berlin
    Es fehlt die Absender-IP. Sonst sind bei mir die Nachrichten auch nie angekommen.

    Code:
    System(/usr/local/bin/sipsak -M -O desktop -B "Nachricht" -s sip:"Empfänger"@"Empfänger-IP" -H Absende-IP)
     
  6. achim22

    achim22 Neuer User

    Registriert seit:
    20 Okt. 2005
    Beiträge:
    153
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    geht jetzt, lag an der Absender-IP. Die Nachricht bleibt aber auch auf dem Diplay, wenn das Fax schon gelesen wurde.....mal schauen was ich da machen kann.

    Kann man das Fax automatisch ausdrucken lassen?
     
  7. Ruad

    Ruad Mitglied

    Registriert seit:
    27 Juli 2005
    Beiträge:
    295
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    ein Niederrheiner in Berlin
    Du kannst dir die Nachricht auch als Kurznachricht schicken lassen. Das kann man dann auch einfach wegdrücken oder löschen. Wenn ich mich nicht irre.
    Bei "-O" muss als Parameter halt nicht desktop sondern... ähm.. das andere tschuldigung.. grad nicht zur hand.

    Und warum sollte man Faxe nicht ausdrucken lassen können? Dazu gibt es hier im Forum beim kurzen Überfliegen bereits viele viele Anregungen. Spätestens mit System() in Asterisk bist du doch in der Lage alles mit Linux unter Asterisk zu machen.
     
  8. achim22

    achim22 Neuer User

    Registriert seit:
    20 Okt. 2005
    Beiträge:
    153
    Zustimmungen:
    0
    Punkte für Erfolge:
    0

    Du meinst sipsak -M -B "test" -s sip:80@192.168.1.22 -i

    aber wie kann ich es wegdrücken oder löschen ?
    Habe alles gedrückt was ich finden konnte, steht immer test !
     
  9. jackfritt

    jackfritt Mitglied

    Registriert seit:
    28 Dez. 2005
    Beiträge:
    325
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    #9 jackfritt, 13 März 2007
    Zuletzt bearbeitet: 13 März 2007
    Also ich bekomme auch keine Nachricht an mein Snom. Gleiche Fehlermeldungen.

    Gruss,

    Jörg

    /EDIT

    network_id_port :

    auf 5060 stellen also

    network_id_port : 5060

    Telefon neustarten und es klappt.

    Mann kann übrigens einen leeren String schicken um den Text wieder wegzubekommen.

    /EDIT