.titleBar { margin-bottom: 5px!important; }

Besetzt bei Anwahl meines Asterisks über TK

Dieses Thema im Forum "Asterisk ISDN mit mISDN" wurde erstellt von nillo, 22 Sep. 2008.

  1. nillo

    nillo Neuer User

    Registriert seit:
    11 Aug. 2005
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Leute, bin neu in der Materie und habe nun endlich meinen Asterisk auf openSUSE 11 einigermaßen aufgesetzt. SIP Account wird registriert, soweit bin ich schonmal ganz glücklich. Mein Ziel ist es ein analog Telefon an einer Auerswald Anlage zu betreiben, diese über S0 mit meiner FritzCard PCI zu verbinden und dann über VoIP rauszutelefonieren / bzw. Anrufe auf dem selben Weg entgegenzunehmen.
    Ich bitte um keine Antworten/Tipps zu der Sinnigkeit dieses Projekts... ;-)
    Ich habe nun also ein analoges Telefon mit der Auerswald verbunden, interne Nr. 21. Die Fritzcard (mit misdn konfiguriert) hat die MSN 23. Wenn ich nun am analogen Telefon die 23 wähle, sehe ich im cli incoming call from 21 to 23 oder so ähnlich. Nach 2 Sek. bekomme ich dann ein besetzt. Soweit so gut, wenn ich nun aber an die 23 eine zu wählende Nr. dranhänge bekomme ich auch gleich ein besetzt. Ich habe die config files angehängt, vielleicht findet jemand den Fehler...

    asterisk 1.4.21.2
    Code:
    extensions.conf
    
    [general]
    static=yes
    writeprotect=no
    
    ;[1und1_out]
    ;exten => _23.,1,Dial,SIP/${EXTEN:2}@1und1|45|r
    
    [isdn_outbound]
    exten => 23,1,DISA,no-password|voip
    
    [voip]
    exten => _.,1,Goto(1und1_outbound{EXTEN})
    
    [1und1_outbound]
    include => default
    exten => _.,1,Dial(SIP/${EXTEN}@1und1,60)
    exten => _.,2,Congestion
    exten => _.,102,Busy
    
    [default]
    include => 1und1_out
    exten => 1234,1,Dial(SIP/${EXTEN},60)
    exten => 1234,2,Congestion
    exten => 1234,102,Busy
    
    sip.conf:
    
    [general]
    context = default
    allowoverlap = no
    bindport = 5060
    bindaddr = 0.0.0.0
    srvlookup = yes
    allowexternaldomains = no
    allowexternalinvites = no
    allowguest = yes
    allowsubscribe = no
    allowtransfer = yes
    alwaysauthreject = no
    autodomain = no
    callevents = no
    canreinvite =
    checkmwi =
    compactheaders = no
    defaultexpiry = 1800
    domain =
    dtmfmode =
    dumphistory = no
    externhost = meinhost.xx
    externip = meinhost.xx
    externrefresh =
    fromdomain =
    g726nonstandard = no
    jbenable = no
    jbforce = no
    jbimpl =
    jblog = no
    jbmaxsize =
    jbresyncthreshold =
    language =
    localnet=meine-ip/255.255.255.0
    maxcallbitrate = 384
    maxexpiry = 3600
    minexpiry = 60
    mohinterpret =
    mohsuggest =
    nat = yes
    notifyringing = no
    pedantic = no
    progressinband =
    promiscredir = no
    realm = 1und1.de
    recordhistory = no
    register =
    registerattempts =
    registertimeout =
    relaxdtmf = no
    rtpholdtimeout =
    rtptimeout =
    sendrpid = no
    sipdebug = no
    subscribecontext =
    t1min = 100
    t38pt_udptl = no
    tos_audio =
    tos_sip =
    tos_video =
    trustrpid = no
    disallow = all
    allow =
    register => 49x:meinpasswort@sip.1und1.de/49x
    
    [1und1]
    type=peer
    username=49x
    secret=meinpasswort
    host=sip.1und1.de
    fromuser=49x
    fromdomain=sip.1und1.de
    canreinvite=no
    qualify=no
    disallow=all
    allow=alaw
    allow=ulaw
    allow=g726
    insecure=very
    nat=no
    dtmfmode=info
    tos=0x18
    
    [1und1_in]
    type=peer
    fromdomain=sip.1und1.de
    host=sip.1und1.de
    disallow=all
    allow=ulaw
    context=ankommend
    
    [1234]
    type=friend
    username=1234
    secret=meinpasswort
    host=dynamic
    disallow=all
    allow=ulaw
    allow=alaw
    dtmfmode=rfc2833
    context=1und1
    
    [authentication]
    
    [Edit foschi: bitte code-Tags verwenden, und nicht schieben - dazu gibt es den "Ändern"-Button.]

    [edit nillo 23:31]
    hatte ich vergessen:

    diese Meldung bekomme ich im cli bei einem Anruf von meinem analogen Telefon:

    ISDN-1#02: Incoming call '21' -> '23'
    == ISDN-1#02: CAPI Hangingup for PLCI=0x101 in state 4
     
  2. Burmann

    Burmann Mitglied

    Registriert seit:
    16 Feb. 2005
    Beiträge:
    372
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wenn du den Asterisk Intern an die Auerswald anschließt, weiss der Anterisk nicht mit welcher Rufnummer er dich Verbinden soll. Machst du die Rufnummer länger, verbindet die Auerswald nicht zum Asterisk - denn der hat die Rufnummer '23'.

    Die Lösung ist die Asterisk-ISDN-Karte im NT-Modus zu betreiben und an ein externen S0-Port der Auerswald zu hängen.
    Oder (wenn das für dich keine Option ist) kannst du wenn der Asterisk mit '23' angewählt wurde den Anruf mit einer Meldung "bitte jetzt die Zielrufnummer eingeben" weitere DTMF-Ziffern einsammeln. Such dazu mal "dial through".