.titleBar { margin-bottom: 5px!important; }

dnsmasq löst keine externen Adressen auf

Dieses Thema im Forum "Freetz" wurde erstellt von reibuehl, 22 Okt. 2011.

  1. reibuehl

    reibuehl Neuer User

    Registriert seit:
    18 Dez. 2006
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    #1 reibuehl, 22 Okt. 2011
    Zuletzt bearbeitet: 22 Okt. 2011
    Hallo,

    ich versuche gerade Freetz 1.2 (Stand 26.9.2011) auf einer Fritzbox 7390 mit Firmware 04.91 einzurichten. Da ich für lokale Systeme dhcp und Namensauflösung aus der hosts Datei machen will, habe ich dnsmasq mit der Option "Start vor multid" aktiviert. Damit werden in der hosts Datei eingetragene Namen auch prima aufgelöst, allerdings habe ich keine externe Namensauflösung trotz aktiver DSL Verbindung. Wenn ich den dnsmasq stoppe und den multid restarte, habe ich wieder externe Namensauflösung aber alle internen Namen werden nicht mehr aufgelöst.

    Wenn dnsmasq läuft, enthält die /var/tmp/resolv.conf nur 127.0.0.1, genau so die /var/tmp/avm-resolv.conf. In der Freetz Web GUI werden aber die anscheinend vom DSL Provider übertragenen Server gelistet und sind auch ausgewählt:

    Code:
    Durch AVM/Provider zugewiesene Upstream Nameserver nutzen.
    momentan: 192.168.180.1 und 192.168.180.2 
    Dies sind auch in der /var/tmp/avm-resolv.conf wenn dnsmasq gestoppt und multid restarted wurde.

    Wie kann ich herausfinden, warum dnsmasq nicht die vom DSL Provider übergebenen DNS Server verwendet bzw. ihn dazu bringen?

    Gruß,
    Reiner.
     
  2. Suchiman

    Suchiman Mitglied

    Registriert seit:
    8 Apr. 2011
    Beiträge:
    320
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ja das scheint buggy zu sein, funktioniert bei mir auch nicht. Du kannst ja stattdessen unter extra diese DNS Server vom Opennic projekt eintragen
    Code:
    #DNS-Server
    server=81.89.98.6
    server=88.198.249.114
    server=217.6.34.47
    server=178.63.26.173
    
    Die von dir genannte Option musst du aber deaktivieren sonst funktionieren die nicht
     
  3. reibuehl

    reibuehl Neuer User

    Registriert seit:
    18 Dez. 2006
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Das funktioniert leider auch nicht. Wenn ich zusätzliche Nameserver unter "zusätzlich diese Upstream Nameserver nutzen" eintrage, wirkt sich dies nicht aus.
     
  4. Suchiman

    Suchiman Mitglied

    Registriert seit:
    8 Apr. 2011
    Beiträge:
    320
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Öhm das was ich genannt habe unter "extra" eintragen und nicht in diesem zusätzlich feld, und den haken bei AVM Provider raus. Hast du das so gemacht ?
     
  5. reibuehl

    reibuehl Neuer User

    Registriert seit:
    18 Dez. 2006
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Oh, mein Fehler. Hatte es nicht unter extra eingetragen. So tut es. Danke!
     
  6. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Kannst du bitte die Einträg im Webinterface nochmal "zurück setzen", so wie es anfangs nicht funktionierte. Und dann den Inhalt von /mod/etc/dnsmasq.conf posten.

    Gruß
    Oliver
     
  7. reibuehl

    reibuehl Neuer User

    Registriert seit:
    18 Dez. 2006
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo Oliver,

    hier der Inhalt von /mod/etc/dnsmasq.conf nach zurücksetzen der Werte und reboot:

    Code:
    # filter what we send upstream
    domain-needed
    bogus-priv
    filterwin2k
    localise-queries
    
    # allow /etc/hosts and dhcp lookups via *.lan.myhome.net
    local=/lan.myhome.net/
    domain=lan.myhome.net
    expand-hosts
    
    # If you want dnsmasq to listen for DHCP and DNS requests only on
    # specified interfaces (and the loopback) give the name of the
    # interface (eg eth0) here.
    # Repeat the line for more than one interface.
    # interface=br0
    
    # enable dhcp (start,end,netmask,leasetime)
    dhcp-authoritative
    dhcp-range=192.168.1.100,192.168.1.200,255.255.255.0,12h
    dhcp-leasefile=/tmp/dhcp.leases
    
    # use /etc/ethers for static hosts; same format as --dhcp-host
    # <hwaddr> <ipaddr>
    read-ethers
    
    # other useful options:
    # Default Gateway
    dhcp-option=3,192.168.1.1
    # DNS server address
    dhcp-option=6,192.168.1.1
    # NTP time server address
    dhcp-option=42,192.168.1.2
    # WINS server address
    dhcp-option=44,192.168.1.2
    
    # Set the boot filename and tftpd server name and address
    # for BOOTP. You will only need this is you want to
    # boot machines over the network.
    dhcp-boot=<...>
    
    # Assign fixed IP Addresses to known hosts
    dhcp-host=<...>
    
    (Die ganzen aus der hosts Datei erzeugten dhcp-boot und dhcp-host Einträge habe ich der Übersichtlichkeit halber durch <...> ersetzt, ich kann Dir die vollständige Datei aber bei Bedarf gerne per Mail schicken.)

    Gruß,
    Reiner.
     
  8. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Wie sehen die Einträge im Webinterface dabei aus? Da fehlen die Upstream Server. Entweder die von AVM oder eigene.

    Gruß
    Oliver
     
  9. reibuehl

    reibuehl Neuer User

    Registriert seit:
    18 Dez. 2006
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Im Webinterface werden die DNS Server meines Providers gelistet:

    Screenshot.jpg

    Gruß,
    Reiner
     
  10. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Kannst du bitte mal folgendes posten:
    Code:
    ls -l /tmp/flash
    ls -l /tmp/flash/dnsmasq
    
    Ich habe den Verdacht, dass du die dnsmasq.conf nicht generieren lässt, sondern selbst eine Datei erstellt hast.

    Gruß
    Oliver
     
  11. reibuehl

    reibuehl Neuer User

    Registriert seit:
    18 Dez. 2006
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    #11 reibuehl, 23 Okt. 2011
    Zuletzt bearbeitet: 23 Okt. 2011
    Hier der Output:
    Code:
    root@fritz:/var/mod/root# ls -l /tmp/flash
    drwx------    2 root     root            60 Jan  1  2000 authorized_keys_root
    -rw-r--r--    1 root     root           719 Sep  9 15:25 avm-firewall.diff
    drwxr-xr-x    2 root     root            80 Jan  1  2000 callmonitor
    -rw-r--r--    1 root     root           169 Apr 16  2011 callmonitor.diff
    drwxr-xr-x    2 root     root            60 Jan  1  2000 dnsmasq
    -rw-r--r--    1 root     root           167 Oct 23 18:25 dnsmasq.diff
    -rwxr-xr-x    1 root     root          2473 Mar 21  2008 dnsmasq_conf
    drwxr-xr-x    2 root     root           100 Jan  1  2000 dropbear
    -rw-r--r--    1 root     root            30 Jan  1  2000 dropbear.diff
    drwxr-xr-x    2 root     root            40 Jan  1  2000 inetd
    drwxr-xr-x    2 root     root            80 Jan  1  2000 mod
    -rw-r--r--    1 root     root            53 Mar  7  2009 mod.diff
    -rw-r--r--    1 root     root            29 Mar 21  2008 netsnmp.diff
    -rw-r--r--    1 root     root           262 Apr 13  2011 ntpd.conf
    -rw-r--r--    1 root     root            30 Mar 21  2008 openntpd.diff
    drwxr-xr-x    2 root     root           140 Jan  1  2000 openvpn
    -rw-r--r--    1 root     root           572 Aug  1  2010 openvpn.diff
    drwxr-xr-x    2 root     root            40 Apr 13  2011 samba
    -rw-r--r--    1 root     root           120 Apr 16  2011 samba.diff
    -rw-r--r--    1 root     root           520 Jan  1  2000 snmpd.conf
    -rw-r--r--    1 root     root            91 Apr 13  2011 usbroot.diff
    drwx------    2 root     root           120 Jan  1  2000 users
    -rw-r--r--    1 root     root            59 Feb 14  2010 wol.diff
    root@fritz:/var/mod/root# ls -l /tmp/flash/dnsmasq
    -rw-r--r--    1 root     root             1 Oct 23 18:25 dnsmasq.extra
    
     
  12. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Okay. Da ist sie. Erinnerst du dich noch warum du die Datei dort erstellt hast?

    Gruß
    Oliver
     
  13. reibuehl

    reibuehl Neuer User

    Registriert seit:
    18 Dez. 2006
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Nein, keine Ahnung. Kann die durch den upload einer gespeicherten Freetz-Konfiguration erstellt werden? Kann ich die löschen?
     
  14. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Mit "cat /tmp/flash/dnsmasq_conf" kannst du dir den Inhalt anschauen und raus kopieren. Mit "rm /tmp/flash/dnsmasq_conf;modsave" kannst du die Datei löschen.

    Gruß
    Oliver
     
  15. reibuehl

    reibuehl Neuer User

    Registriert seit:
    18 Dez. 2006
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    OK, nach dem löschen funktioniert es. Die /var/mod/etc/dnsmasq.conf sieht jetzt so aus:
    Code:
    domain-needed
    log-async=10
    no-resolv
    server=192.168.180.1
    server=192.168.180.2
    bogus-priv
    dhcp-range=192.168.1.100,192.168.1.200,255.255.255.0,12h
    domain=lan.myhome.net
    expand-hosts
    read-ethers
    stop-dns-rebind
    
    Kannst Du mir sagen, ob die verteilung fixer IP Adressen auf Basis der hosts Datei automatisch funktioniert? Ist das die "expand-hosts" Einstellung?

    Die jetzt rausgeflogenen dhcp-option und dhcp-boot Einstellungen (die wohl ursprünglich vermutlich der Grund für das File waren) kann ich doch unter extras angeben, oder?
     
  16. reibuehl

    reibuehl Neuer User

    Registriert seit:
    18 Dez. 2006
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Was mir noch auffällt: seit dem löschen der Datei bekomme ich im Webinterface bei jedem restart des dnsmasq Dienstes (und auch bei Konfigurationsänderungen) ein "failed" beim stop des dnsmasq. Der Prozess scheint aber zu laufen laut ps -w output.