DS-MOD mit 7170 Firmware Probleme

lolax

Mitglied
Mitglied seit
11 Feb 2006
Beiträge
293
Punkte für Reaktionen
1
Punkte
18
Hallo

ich habe eine 7170 mit der 29.04.15 drauf. nun möchte ich mir den ds-mod draufmachen.

das problem ist, wenn ich make eingebe, will er ja die 29.04.15 version online runterladen, diese findet er nicht und fragt dann ob er die 29.04.21 nehmen soll.

mit dieser version funktioniert aber make nicht, -- firmware error

sehe ich das richtig, das der ds mod 0.2.9 nur mit der 29.04.15 geht?

falls ja, woher bekomme ich denn diese firmware? antwort: habe mich schon in den sammelthreat eingetragen
 
Zuletzt bearbeitet:

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Hast du "make" nochmal aufgerufen nachdem du die Firmware-Version umgestellt hast?
Änder mal "Verbose mode" auf 2 im "make menuconfig" unter Advanced Options.
Und bitte die Ausgaben posten, nicht nur "firmware error". Damit kann ich nix anfangen.

MfG Oliver
 

Assin

Neuer User
Mitglied seit
27 Okt 2006
Beiträge
6
Punkte für Reaktionen
0
Punkte
0
Hi,

habe grad selbiges Problem. Ein Verbosity Level von 2 ergibt folgendes:

STEP 2: MODIFY
applying patches
applying patches (fon_wlan_7170-de)
patching file etc/profile
patching file usr/bin/system_status
patching file etc/init.d/rc.net
patching file etc/init.d/rc.voip
patching file etc/init.d/rc.S
Hunk #1 succeeded at 256 (offset 12 lines).
patching file etc/init.d/rc.S
patching file etc/init.d/rc.S
patching file usr/www/all/html/de/menus/menu2_fon.html
Hunk #1 succeeded at 69 (offset -2 lines).
patching file usr/www/all/html/de/menus/menu2_homehome.html
patching file usr/www/all/html/de/menus/menu2.inc
Hunk #1 FAILED at 9.
1 out of 1 hunk FAILED -- saving rejects to file usr/www/all/html/de/menus/menu2.inc.rej
patching file usr/www/all/html/de/menus/menu2_internet.html
patching file usr/www/all/html/de/menus/menu2_system.html
patching file usr/www/all/html/de/menus/menu2_usb.html
patching file usr/www/all/html/de/menus/menu2_wlan.html
make: *** [firmware] Error 2
 

sd8rdb

Neuer User
Mitglied seit
30 Apr 2005
Beiträge
196
Punkte für Reaktionen
0
Punkte
0
das Problem hatte ich auch, allerdings mit der 7141.

Irgendwo im Forum geistert ein Patch der die Sache behebt.

Allerdings hatte ich danach das Problem das sich die Fritzbox andauernd resetted hat. z.B. beim einrichten vom ds-mod hat sich die fritzbox sofort neugestartet wenn ich auf "telnet starten" geklickt hab.

edit: http://www.ip-phone-forum.de/attachment.php?attachmentid=10842&d=1161331964 den Patch einspielen
 

lolax

Mitglied
Mitglied seit
11 Feb 2006
Beiträge
293
Punkte für Reaktionen
1
Punkte
18
hi

also ich habe die datei 190-webmenu.patch mit winrar enpackt und dann die alte datei mit dieser überschrieben.

cygmin generiert mir nun mit dem make befehl auch ein image. keine probleme

wenn ich dann aber das fertige image in die 7170 installieren will, sagt mir diese, das das image einen fehler hat und will neustarten
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Hier sind nochmal die 2 geänderten Patches...
Code:
cd ds-0.2.9/
tar xjf patches-ds.0.2.9-04.2x.tar.bz2
MfG Oliver
 

Anhänge

lolax

Mitglied
Mitglied seit
11 Feb 2006
Beiträge
293
Punkte für Reaktionen
1
Punkte
18
habe nun dein patch auch noch getestet

es wird ein image erstellt, doch die 7170 bricht beim update ab
 

sd8rdb

Neuer User
Mitglied seit
30 Apr 2005
Beiträge
196
Punkte für Reaktionen
0
Punkte
0
bei mir meckert er beim ds-mod einrichten das clibc nicht finden kann und irgendwann reboot

(7141)
 

lolax

Mitglied
Mitglied seit
11 Feb 2006
Beiträge
293
Punkte für Reaktionen
1
Punkte
18
welche firmware benutzt du?
 

lolax

Mitglied
Mitglied seit
11 Feb 2006
Beiträge
293
Punkte für Reaktionen
1
Punkte
18
mal noch ne allgemeine frage

falls mir jemand die 29.04.15 mailen würde, könnte ich dann einfach ein neues image mit dem ds mod erstellen und dann per update auf die 7170 schicken, auch wenn da schon die 29.04.15 drauf ist?
denn das update muss doch immer neuer sein.

wie habt ihr denn das gemacht?
 

torsten3009

Neuer User
Mitglied seit
25 Okt 2006
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
bin gerade beim gleichen Problem,
habe auf der Box jedoch schon FW 29.04.21 drauf...

hat das schon einer auf der 7170 zum laufen bekommen?
 

torsten3009

Neuer User
Mitglied seit
25 Okt 2006
Beiträge
13
Punkte für Reaktionen
0
Punkte
0

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Die Labor-Version ist eigentlich nur für die Labor-Firmware gedacht. Für die 29.04.21 würde ich die original dsmod-Version 0.2.9 empfehlen. Da muss nur der Patch in patches/fon_wlan_7170/de ersetzt werden.

MfG Oliver
 

Dron

Neuer User
Mitglied seit
3 Mrz 2005
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
olistudent schrieb:
Die Labor-Version ist eigentlich nur für die Labor-Firmware gedacht. Für die 29.04.21 würde ich die original dsmod-Version 0.2.9 empfehlen. Da muss nur der Patch in patches/fon_wlan_7170/de ersetzt werden.

MfG Oliver
Leider helfen auch die Patches nichts :(. Das Image wird zwar ohne Fehler compiliert, doch bei raufspielen auf die Box kommt es zum Fehler und die Box will neugestartet werden.
 

sslneve

Neuer User
Mitglied seit
26 Okt 2006
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Selbes Problem hier. Die Box mag das Image nicht... gibt es außer der Lösung von Torsten noch was anderes?
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Ich hab keine Ahnung wie Torsten das gemacht hat. Aber das 29.04.21 Image kann definitiv nicht mit der Version fürs Laborimage gemoddet werden, weil da die falsche uClibc drin ist.
Wobei es sein kann, dass die erste Version von Bofhell gar nicht für die Laborfirmware war. ;-)
Ich werd das morgen bzw. heute mal ausprobieren und melde mich dann.

MfG Oliver
 

Boyz

Mitglied
Mitglied seit
3 Aug 2006
Beiträge
209
Punkte für Reaktionen
0
Punkte
16
also ich hab ausprobiert mit erste Version von Bofhell "ds-0.2.9-1-labor23.tar.bz2" damit geht nicht der zeigt an das der MOD für "FRITZ.Box_Fon_WLAN_7170-29.04.23-4924_Labor.image" ist
und mit aller erste Version von Bofhell "ds-0.2.9-labor-bofhell.tar.bz2" damit kriege ich Fehlermeldung wenn ich "make menuconfig" ausführen will tools/config/mconf: tools/config/mconf: cannot execute binary file
make: *** [menuconfig] Error 126

kein plan wie Torsten hingekriegt hat


Gruß
Boyz
 
Zuletzt bearbeitet:

Darkyputz

Aktives Mitglied
Mitglied seit
27 Jul 2005
Beiträge
2,323
Punkte für Reaktionen
0
Punkte
36
moin kinners...bin grad etwas unsicher...
habe das patch dings von olli in das entsprechende verzeichniss für meine 7170 kopiert und die 29.04.21 gemoddet wie immer und es hat gefunzt...
heißt das, das die ganzen bisher beobachteten inkompatibilitäten mit dem neuen kernel weg sind?

wäre schön wenn da mal jemand watt zu sagen könnte...

@OLLI...danke dir...
 
Zuletzt bearbeitet:

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Die 29.04.21 hat noch keinen neuen Kernel. ;-)

MfG Oliver
 

Darkyputz

Aktives Mitglied
Mitglied seit
27 Jul 2005
Beiträge
2,323
Punkte für Reaktionen
0
Punkte
36
@oli...schon glücklich mit deiner neuen box??
schade das das nur nen usb 1.1 port iss...dann würde nfs(läuft jetzt) und samba richtig spass machen...
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,304
Beiträge
2,032,596
Mitglieder
351,855
Neuestes Mitglied
Juergenm