DYNDNS mit Subdomain

Peter_Lehmann

Neuer User
Mitglied seit
13 Mrz 2007
Beiträge
176
Punkte für Reaktionen
39
Punkte
28
Hallo Freunde!

Zuerst etwas zum Einstieg in meine Frage:
Ich "kümmere mich" um ein Netz aus einigen Fritz!Boxen, in und außerhalb Deutschlands, auf denen ich einige Dienste/Geräte in den jeweiligen Heimnetzen aus den I-Net erreichbar gemacht habe.
So zum Beispiel ggw. 5 miteinander vernetzte Wireguard-Server und zwei Jitsi-meet-Server. Sämtliche sonstigen Zugänge in die jeweiligen Netze (und auch die GUI der F!B) sind nur über das WG-VPN möglich, also keine Portweiterleitungen außer für die Funktion der o.g. Server.
Alle F!B und alle Netze laufen voll im Dualstack-Betrieb.
Und um alles einfach erreichbar zu machen, nutze ich die Dienste von dynv6.com als DYNDNS.
=> alles hier genannte funktioniert eigentlich problemlos und auch schon etliche Monate.

Jetzt zu meiner eigentlichen Frage:
Um nicht (weiterhin) für jeden Server/Dienst einen einzelnen DynDNS-Namen anlegen zu müssen (=> damit funktioniert es völlig problemlos!) habe ich angefangen für jeden Router (FB 7590 und 7490) eine "Zone" (so nennt dynv6.com seine DynDNS-Namen) anzulegen und innerhalb dieser "Zone" 1 bis 3 AAAA-Records.

Beispiel:
<Standort1>.dynv6.net = die jeweilige F!B
<WG-Server>.<Standort1>.dynv6.net
<meet>.<Standort1>.dynv6.net
usw.

Dem DynDNS-Dienst wird mit der Aktivierung von DynDNS der jeweilige Präfix übergeben und über die jeweilige Portweiterleitung holt er sich den Suffix. Auf der Webseite ist dann die vollständige erreichbare IPv6 für jeden Server und auch der F!B zu sehen. Selbige sind natürlich auch mit "ip a" auf den Servern zu sehen und entsprechen auch den in der F!B angezeigten.

Das was ich hier beschrieben habe, funktioniert völlig problemlos auf den drei F!B mit der jeweils aktuellen "offiziellen" ReleaseFirmware (bspw. 07.12 bei der 7590). Sowohl der WG-Server als auch die meet-Server sind damit erreichbar.

Auf je einer 7590 und 7490 (meine eigene und eine ganz in der Nähe) habe ich allerdings die jeweils aktuelle LABOR zu laufen. Hier habe ich den Effekt, dass zwar auf dem DynDNS-Server die richtige IPv6 angezeigt wird, aber die jeweiligen Dienste sind über ihren DynDNS-Namen (mit Subdomain) nicht zu erreichen. Obwohl sowohl bei dynv6.com und auch auf dem Server diese IPv6 angezeigt werden.
Und noch einmal: bei einer eigenen "Zone" für jeden Server auf diesen F!B funktioniert es selbstverständlich.
(Bspw.: meet_standort1.dynv6.net)

Deshalb zwei konkrete Fragen an euch:
1.) Hat jemand Erfahrungen mit DynDNS und Subdomänen?
2.) Kann von euch jemand bestätigen, dass es bei der letzten Release-Firmware noch funktioniert und bei der LABOR nicht mehr?


Danke fürs Lesen meines Beitrages und schon mal im Voraus für helfende Antworten.
Und NEIN, ich habe mich bis jetzt noch nicht an AVM gewandt, das werde ich tun, wenn ich Antworten auf meine zweite Frage habe. Ich habe mit dem "Umbau" erst vor zwei Tagen begonnen.


MfG Peter
edit: ein vergessenes "A" eingefügt und die "eigene Zone" ergänzt.
 
Zuletzt bearbeitet:

Peter_Lehmann

Neuer User
Mitglied seit
13 Mrz 2007
Beiträge
176
Punkte für Reaktionen
39
Punkte
28
Guten Morgen!

Ich wage mich noch einmal "aus der Deckung".
Tut mir leid, wenn meine Fragen oder Probleme so kompliziert sind.

Deshalb noch einmal: Gibt es hier wirklich niemanden, der einen DynDNS-Dienst mit Subdomainen zur Erreichbarkeit mehrerer Dienste aus dem Internet nutzt?

Mir würde schon ein einfaches
"Bei mir geht es auch mit der aktuellen LABOR" (=> dann kann der Fehler ja nur bei mir liegen)
oder
"Auch bei mir geht es mit der aktuellen LABOR nicht" (=> dann würde ich dieses an AVM melden)
reichen.


MfG Peter
 

Insti

Mitglied
Mitglied seit
19 Aug 2016
Beiträge
446
Punkte für Reaktionen
39
Punkte
28
Hallo Peter,

Deshalb zwei konkrete Fragen an euch:
1.) Hat jemand Erfahrungen mit DynDNS und Subdomänen?
Ja aber nicht mit der Fritzbox. Meine DynDNS Host für ipv6 werden vom jeweiligem Server im LAN der Fritzbox gesetzt.
Seit Jahren nutze ich den Dienst von https://freedns.afraid.org/ und kann das auch empfehlen. Zum aktualisieren nutze ich inadyn-mt auf den Servern.
 

HabNeFritzbox

IPPF-Urgestein
Mitglied seit
12 Dez 2017
Beiträge
16,021
Punkte für Reaktionen
325
Punkte
83
Geht auch mit MyFritz, dort bekommen andere Geräte im Heimnetz auf Wunsch auch eigene Subdomain und dessen AAAA wird auch geupdatet.

Bei anderen Geräte ist Problem, dass diese ggf. selbst ihre AAAA mitteilen müssen.

Bei mir ist es nur die FB und NAS, daher überschaubar, daher lass ich die FB auf dem NAS ein Script ausführen, welches dann FB und NAS A und AAAA setzt beim Anbieter.
 

Peter_Lehmann

Neuer User
Mitglied seit
13 Mrz 2007
Beiträge
176
Punkte für Reaktionen
39
Punkte
28
Danke für eure Antworten!

Wie ich schon in meinem ersten Beitrag geschrieben habe, hat das alles mit der 07.12 und Dynv6.com (und natürlich auch MyFritz!) perfekt funktioniert. Bis zu dem Tag, wo ich (weil ich bewusst mittesten wollte) die LABOR installiert habe. Ich habe es auch erst bemerkt, als einer meiner Freunde meinen Jitsi-Server benutzen wollte und seine Verbindungsanfrage nicht weitergeleitet wurde. Die IPs der drei Geräte stimmen auch auf dem DynDNS-Server, in der F!B und auch auf den drei Servern überein, nur der ankommende Verbindungsversuch wird eben nicht ans jeweilige Gerät weitergeleitet. So als ob die Portweiterleitung (IPv4) oder der/die Firewall (IPv6) nicht funktionieren. Aber eben nur bei der LABOR und auch bei einer bewusst händisch neu eingerichteten F!B, also kein "vermanschtes" übernommenes Profil.

Ich werde, auch wenn mir niemand den Fehler bestätigen kann, das doch mal an AVM melden. Kann ja maximal passieren, dass ich eine sehr verwunderte Antwort bekomme.

MfG Peter